missing 4K HDMI support NVIDIA G03

I got me a 40" 4k screen, appears I am longer here than I thought.

The Laptop that I have with me is rather antique. And has a FX770m

When I connect to windows, the screen displays 4k resolution.

When I connect to Opensuse 15.1 , noveau driver does not activate HDMI and the monitor is not recognized. Are there patches to use HDMI?

On nvidia G03 HDMI is recognizes, but At max 2048X1080 https://forums.opensuse.org/images/icons/icon9.png

Is there any way to get 4k running?

I have a 2013 Firmi with only DisplayPort output that can with the default modesetting DDX when only a DisplayPort cable is used:

# xrandr| grep current
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
# inxi -GSxx
System:    Host: p5bse Kernel: 4.12.14-lp151.28.36-default x86_64 bits: 64 compiler: gcc v: 7.4.1
           Desktop: KDE 3 wm: kwin dm: startx Distro: openSUSE Leap 15.1
Graphics:  Device-1: NVIDIA GF119 [NVS 310] vendor: Hewlett-Packard driver: nouveau v: kernel
           bus ID: 01:00.0 chip ID: 10de:107d
           Display: server: X.Org 1.20.3 driver: modesetting resolution: 2560x1440~60Hz
           OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.2 compat-v: 3.1
           direct render: Yes

Tried with a passive DisplayPort to HDMI connector, my display reports input not supported. Tried again with an active DisplayPort to HDMI connector gives this:
https://paste.opensuse.org/view/raw/38660598With a much older GT218, HDMI is limited to 1920x1200, but 3840x2160 works with dual-link DVI, same display output as with the GF119.

Is this a NVIDIA Optimus configuration?

Did you verify that G03 is the correct NVIDIA driver for your NVIDIA card?

Please show (as root)

# hwinfo --gfxcard



32: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.386]
  Unique ID: VCu0.BB4zKyzKUBD
  Parent ID: vSkL.PuMaBpmAjf4
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia G96GLM [Quadro FX 770M]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x065c "G96GLM [Quadro FX 770M]"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x30e7 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xda000000-0xdaffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xd8000000-0xd9ffffff (rw,non-prefetchable)
  I/O Ports: 0x7000-0x7fff (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 33 (19043 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd0000065Csv0000103Csd000030E7bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #30 (PCI bridge)


xrandr --prop
Screen 0: minimum 8 x 8, current 3840 x 1648, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
BorderDimensions: 4
supported: 4
Border: 0 0 0 0
range: (0, 65535)
SignalFormat: VGA
supported: VGA
ConnectorType: VGA
ConnectorNumber: 4
_ConnectorLocation: 4
non-desktop: 0
supported: 0, 1
LVDS-0 connected primary 1920x1200+0+448 (normal left inverted right x axis y axis) 331mm x 207mm
Backlight: 100
range: (0, 100)
BorderDimensions: 4
supported: 4
Border: 0 0 0 0
range: (0, 65535)
SignalFormat: LVDS
supported: LVDS
ConnectorType: Panel
ConnectorNumber: 0
_ConnectorLocation: 0
non-desktop: 0
supported: 0, 1
1920x1200 59.99*+
DVI-D-0 disconnected (normal left inverted right x axis y axis)
BorderDimensions: 4
supported: 4
Border: 0 0 0 0
range: (0, 65535)
SignalFormat: TMDS
supported: TMDS
ConnectorType: DVI-D
ConnectorNumber: 1
_ConnectorLocation: 1
non-desktop: 0
supported: 0, 1
HDMI-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 880mm x 490mm
BorderDimensions: 4
supported: 4
Border: 0 0 0 0
range: (0, 65535)
SignalFormat: TMDS
supported: TMDS
ConnectorType: HDMI
ConnectorNumber: 2
_ConnectorLocation: 2
non-desktop: 0
supported: 0, 1
2048x1080 59.99 +
1920x1080 60.00* 59.94 50.00 50.00 60.00 50.04
1680x1050 59.95
1440x900 74.98 59.89
1280x1024 75.02 60.02
1280x960 60.00
1280x720 60.00 59.94 50.00
1024x768 75.03 60.00
800x600 75.00 60.32
720x576 50.00 50.08
720x480 59.94 60.05
640x480 75.00 72.81 59.94 59.93

xrandr| grep current
Screen 0: minimum 8 x 8, current 3840 x 1648, maximum 8192 x 8192

3840x2160 should work with 4k@ 30Hz over HDMI. Win7 can do. I had to use this at the moment, because I cannot get the resolution.

you could try something like

Section "Monitor"
    Identifier "HDMI-0"
    DisplaySize 3840 2160

in your xorg.conf.d.


> man xorg.conf

for more details on how to do this.



DisplaySize affects only the logical display density employed, not the display mode. DisplaySize values must be millimeters, not pixels:

# xdpyinfo | egrep 'dimen|ution'
  dimensions:    3840x2160 pixels (678x381 millimeters)
  resolution:    144x144 dots per inch
# xdpyinfo | egrep 'dimen|ution'
  dimensions:    3840x2160 pixels (443x249 millimeters)
  resolution:    220x220 dots per inch

I am now on 15.2. Apparently G03 is not offered any more. HDMI still does not work and using VGA with 1080 on a 4k screen just kills your eyes.

G03 is left at 319 and it appears nvidia’s drivers starting from 359 offered 4K and with 380 4k 60HZ .

So I guess I need a new laptop. Didn’t plan on that.

Or is there any trick to get HDMI working with nouveau

Or has someone a HP compatible ATI MXM I card flying around? /

The only mention in this thread of the totally FOSS upstream default modesetting DDX that I use with all NVidia GPUs instead of the old technology, reverse-engineered nouveau DDX is my #2 post. Is there something stopping you from trying it instead of nouveau?

After reading https://www.tweaktown.com/tweakipedia/89/much-vram-need-1080p-1440p-4k/index.html and https://www.techpowerup.com/gpu-specs/quadro-fx-770m.c1436 the 2048x1080 limit suggests to me a gfxcard with 512M VRAM where more is needed to support 4k, but why Windows can do 3840x2160 I cannot imagine, unless with only 256 or 64k colors instead of 16M or more.

2048x1080 limit goes from HDMI 1.4 or less.

Needed video RAM for simple 2D, not gaming:

19201080 = 2073600 pixels.
1080*4bytes = 8294400 bytes = 6.73 Mbytes.

For 4k: 384021604bytes = 33177600 bytes = 31.64 Mbytes.

You may get 4k with refresh rate = 30 Hz, or more with YCbCr 4:2:0 coding with HDMI 1.3-1.4.

Use newer hardware for a 4k monitors (HDMI 2.0+, DP 1.2+).

Supposedly in old laptop HDMI port connected to Intel graphics, not Nvidia.