Mismatch between BIOS and UEFI boot on upgrade 15.2 > 15.3

First some background. I am 80years old and have been using OpenSuse for more years than I can remember, I have never been able to get to master the command line and rely entirely on the graphical user interface. My current PC is dual boot with two hard drives the primary had OpenSuse Leap 15.2 installed and the secondary Windows 10. I have never had any problems with updating my OpenSuse OS until a couple of days ago and as a result have got a little lax with my backups. I decided to update to Leap 11.3(a little late perhaps!), downloaded and burned the iso to DVD, then tried to install as an update. Everything seemed to go O.K. until at the end I got this message:
“Cannot upgrade boot loader because of mismatch of the boot technology. The upgraded system was using legacy BIOS boot whilst the installation medium has been booted using EFI boot.
This scenario is not supported the upgraded system may not boot or the upgrade process can fail later”

Needless to say I now cannot access my Linux hard drive and have been groping for some solution without success, am having to use Windows at present to communicate.
Is there anything I can do to salvage the situation please.
I perhaps had a false sense of security but at no time did l see any warning with regard to an EFI requirement.


I changed the title of this thread to something that informs about what the subject is.

From what you tell, I deduct that for the upgrade you used a 15.3 installation medium and there used the Upgarde function.

You booted the installation medium (DVD or USB-stick) in EFI mode, while the Windows system is a BOIS booted one. And your old `15.2 also was a BIOS booted one. Mixing the two in a multi-booting environment can not work. IMHO the only thing you can do is starting fresh with that installation medium, but booting it in BIOS mode.

Thank you Henk for that information.
I have checked the DVD I produced and see that it only has an EFI boot file on it. I did not see a choice of boot versions to download so how do I find the correct version to download?

The DVD does both Legacy and UEFI boot, when you boot the system press whatever hardware key eg F12 to get to the BIOS boot menu, there should be in the list a UEFI boot and a Legacy boot option?

Do you have a 8GB or bigger USB device you could use for the install medium, rather than DVD?

As Malcolm says, the DVD can be booted in both modes.

BTW, it is a bit late advice, but IMHO you would have been better of when you would have used the “online upgrade” method to upgrade. Because that does not require a boot from a medium, it only update the software packages and as a consequence would have created the Grub files seeing BIOS as the only method used on the system

Success, thank you both for your help. I am now back using OpenSuse.
It was F12 that did the trick not with a choice of BIOS or EFI but it allowed me the choose the drive I wished to boot. I don’t know how it worked but it did, I may have to hit F12 every time I start up but for the time being I can live with that.
Thanks again.

Can you show the output from;

efibootmgr -v

Should be able to set the boot properly from the above output.


I have a somewhat elderly Lenovo Laptop (G505s with an AMD GPU and the absolutely last BIOS version for the thing published by Lenovo), which around about Leap 15.3 suddenly stopped supporting Secure Boot.

  • After many attempts to get the latest openSUSE EFI Keys (also the one needed by Oracle’s VirtualBox) loaded into the Laptop’s BIOS/UEFI «1000 times around the houses with “mokutil”», I’ve given up and, currently use the thing with Secure Boot disabled.
  • The default factory EFI Keys for Microsoft and Ubuntu are still present in the BIOS but, it ain’t accepting the current openSUSE keys …
  • I still have a copy of the last Lenovo BIOS for the thing but, I’ll have to install Windows on the box to re-flash the BIOS – no non-Redmond (Windows) BIOS flashing utilities – AFAIK, there was never a version of the BIOS which could be flashed via DOS …

The thing currently has it’s 3rd HDD – meaning that, when it finally begins to exhibit too many hardware failures and/or the screen dies, I’ll begin looking for a more modern replacement «with a BIOS flashing utility built into the BIOS» …

I suppose this is a pointless question, but are you sure you can’t flash from USB directly in BIOS setup somewhere? I have older PCs than your laptop that can, though none Lenovo.

The G505s was a little bit special – AMD GPU plus a BIOS update .exe that only ran under Windows 8.1 → <https://support.lenovo.com/de/en/downloads/ds038577-bios-update-for-windows-8-32-bit-64-bit-windows-81-32-bit-64-bit-lenovo-g405s-g505s&gt;

Installing the package in Windows

  1. Locate the file winflash(3.00).exe that has been downloaded.
  2. Double click the winflash(3.00).exe icon.
  3. Click install
  4. Click flash bios
  5. Press Enter to start flashing. During the process, you are advised not to turn off the computer.
  6. When the update finishes, the computer will automatically reboot for the changes to take effect.
  7. If the hot key not work without Fn key after flash BIOS, this SOP describes how to enable hot key mode
    Step 1: Press power button to boot, then press F2 key enter BIOS setup.
    Step 2: Select sub menu to Configuration
    Step 3: Select to Hotkey Mode item and then press enter
    Step 4: Select Enabled then press enter
    Step 5: Press F10 save and exit, then select Yes then press enter.

Updated Information:

Latest Version BIOS fixed all merged issues from previous.


Just to be certain, I tried running the BIOS .exe in DOSBox –

This program cannot be run in DOS mode.


For the G505S, Lenovo was trying to be “Windows only” …

Some “.EXE” files are .zip files in disguise. Sometimes changing the file name from yada.exe to yada.zip will allow the content to be extracted with anything that can open a .zip file.

Linux and UNIX® never tell lies –

 > file 83cn35ww.exe winflash\(3.00\).exe 
83cn35ww.exe:       MS-DOS executable, COFF for MS-DOS, DJGPP go32 DOS extender
winflash(3.00).exe: MS-DOS executable, COFF for MS-DOS, DJGPP go32 DOS extender

Neither does GNOME Archive Manager…


Has anyone tried the firmware manager tool to see if it’s available, or use this for the update?

Screenshot from 2022-04-13 11-58-10.png

What does it report for the three .exe files once they have been extracted from winflash(3.00).exe?

Just the data… example;


Screenshot from 2022-04-13 12-20-19.png

I have a Lenovo G570 here, I see a bootable BIOS update CD for my system (even though it says a T460?);


KDE Plasma Ark doesn’t support the file format but, the following indicates that, “p7zip” provides a CLI file archiver which does the trick –

 > 7zr l winflash\(3.00\).exe

7-Zip (a) [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=de_DE.UTF-8,Utf16=on,HugeFiles=on,64 bits,8 CPUs AMD Ryzen 5 3400G with Radeon Vega Graphics     (810F81),ASM,AES-NI)

Scanning the drive for archives:
1 file, 3501888 bytes (3420 KiB)

Listing archive: winflash(3.00).exe

Path = winflash(3.00).exe
Type = 7z
Offset = 421576
Physical Size = 3080312
Headers Size = 429
Method = LZMA:12m BCJ
Solid = +
Blocks = 2

   Date      Time    Attr         Size   Compressed  Name
------------------- ----- ------------ ------------  ------------------------
2008-01-15 08:25:00 ....A       105886      2172002  Ding.wav
2014-01-08 08:54:33 ....A      5713856               WinVALGC300.bin
2014-01-08 09:45:21 ....A        43416               platform.ini
2012-12-14 07:43:20 ....A       232448       907881  FlsHook.exe
2012-07-02 12:50:50 ....A       225560               FWUpdLcl.exe
2012-12-14 07:43:46 ....A       699392               InsydeFlash.exe
2012-12-14 07:43:16 ....A       195584               FlsHookDll.dll
2012-12-14 07:43:28 ....A       745472               iscflash.dll
2012-07-02 12:50:50 ....A      1892352               xerces-c_2_7.dll
2012-12-14 10:02:34 ....A        40312               iscflash.sys
2012-12-14 10:02:32 ....A        56184               iscflashx64.sys
------------------- ----- ------------ ------------  ------------------------
2014-01-08 09:45:21            9950462      3079883  11 files

AFAICS, InsydeFlash is “Windows only” …