Has anyone successfully used Mirall to install ownCloud on the local computer? I am on OS 12.2 and the installation process stops without actually saying anything other than ‘Installation error’.

I don’t think I am capable to set-up ownCloud my self so this looked like a decent solution, if it had worked.


Did you install from openSUSE repos?



Yes, I installed Mirall from the oss repo.

Pls post

Desktop installed
Detailed install steps
Full error if displayed
If possible, immediately after generating the error any possible syslog info using the following command

tail /var/log/messages


KDE 4.8.5
Mirall installed through YaST

Konsole session:

olav@DDAchtung:~> mirall
QMetaObject::connectSlotsByName: No matching signal for on_checkBoxOnlyOnline_toggled()
* Network is online 
(+) Watcher: "/home/olav/.local/share/data//Mirall" 
    `-> and 1 subdirectories 
* Pending events for "/home/olav/.local/share/data//Mirall" will be processed after events stop for 3 seconds ( "02:44:44" ). 0 events until now ) 
* Setup folders from  "/home/olav/.local/share/data//Mirall/folders" 
Network Location:  "40:4a:03:b7:4e:f6" 
* Processing of event queue for "/home/olav/.local/share/data//Mirall" 
  * Notify 0 changed items for "/home/olav/.local/share/data//Mirall" 
* Setup folders from  "/home/olav/.local/share/data//Mirall/folders" 
 ** Disabling folder sync! 
No configured folders yet, start the Owncloud integration dialog. 
Returning configured owncloud url:  "" 
Current Wizard page changed to  0 
Page_install is  4 
 ** Enabling folder sync! 
Current Wizard page changed to  1 
Page_install is  4 
Current Wizard page changed to  2 
Page_install is  4 
Current Wizard page changed to  4 
Page_install is  4 
Connect to local! 
Install OC on localhost 
starting  "/usr/bin/owncloud-admin"  with args.  ("install", "--server-type", "local", "--root_helper", "kdesu -c", "--admin-user", "olav", "--admin-password", "test") 
checking owncloud-admin  "/usr/bin/owncloud-admin" 
!!  "bzip2: (stdin) is not a bzip2 file.
!!  "tar: " 
!!  "Child returned status 2" 
!!  "
!!  "tar: " 
!!  "Error is not recoverable: exiting now" 
!!  "
!!  "/usr/lib64/ruby/gems/1.9.1/gems/owncloud-admin-0.0.3/lib/installer.rb:91:in `initialize': No such file or directory - /home/olav/.owncloud-admin/tmp/owncloud/config/autoconfig.php (Errno::ENOENT)
        from /usr/lib64/ruby/gems/1.9.1/gems/owncloud-admin-0.0.3/lib/installer.rb:91:in `open'
        from /usr/lib64/ruby/gems/1.9.1/gems/owncloud-admin-0.0.3/lib/installer.rb:91:in `write_admin_config'
        from /usr/lib64/ruby/gems/1.9.1/gems/owncloud-admin-0.0.3/lib/installer.rb:57:in `install'
        from /usr/lib64/ruby/gems/1.9.1/gems/owncloud-admin-0.0.3/lib/cli.rb:95:in `install'
        from /usr/lib64/ruby/gems/1.9.1/gems/thor-0.14.6/lib/thor/task.rb:22:in `run'
        from /usr/lib64/ruby/gems/1.9.1/gems/thor-0.14.6/lib/thor/invocation.rb:118:in `invoke_task'
        from /usr/lib64/ruby/gems/1.9.1/gems/thor-0.14.6/lib/thor.rb:263:in `dispatch'
!!  "   from /usr/lib64/ruby/gems/1.9.1/gems/thor-0.14.6/lib/thor/base.rb:389:in `start'
        from /usr/lib64/ruby/gems/1.9.1/gems/owncloud-admin-0.0.3/bin/owncloud-admin:29:in `<top (required)>'
        from /usr/bin/owncloud-admin:23:in `load'
        from /usr/bin/owncloud-admin:23:in `<main>'
exit code:  1 

The password is displayed in clear text so I just used ‘test’ for this test’s purpose; is this a bit insecure by the way?


 DDAchtung:/home/olav # tail /var/log/messages
Jul  1 02:32:27 DDAchtung dbus-daemon[553]: **** /proc/self/mountinfo changed
Jul  1 02:32:28 DDAchtung kernel:   567.329865] EXT4-fs (sda3): re-mounted. Opts: acl,user_xattr,commit=0
Jul  1 02:32:28 DDAchtung dbus-daemon[553]: **** /proc/self/mountinfo changed
Jul  1 02:32:48 DDAchtung polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.25 [/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
Jul  1 02:34:06 DDAchtung kernel:   665.235409] fuse init (API version 7.18)
Jul  1 02:34:06 DDAchtung dbus-daemon[553]: **** /proc/self/mountinfo changed
Jul  1 02:38:00 DDAchtung systemd-tmpfile[12229]: stat(/run/user/olav/gvfs) failed: Permission denied
Jul  1 02:42:05 DDAchtung su: (to root) olav on /dev/pts/3
Jul  1 02:42:05 DDAchtung su: (to root) olav on /dev/pts/3
Jul  1 02:43:50 DDAchtung su: (to root) olav on /dev/pts/1
DDAchtung:/home/olav # 

My first impressions…

!!  "bzip2: (stdin) is not a bzip2 file.

This is suspicious. This error also causes the next few error lines. Looks to me like this is after at least the first part of the app successfully installed, but this config may either be a further install config file or a User config file. In other words…

  • Locate this file and see if you can manually uncompress it. Of course this requres the bzip2 utilities installed on your system.

It also looks like the application is a ruby gems app.
I have not found anything in YAST/zypper that ensures you have a proper ruby gems environment setup(eg a pattern) before installing this type of application. As part of another ruby app I recently installed, I posted the zypper command I believe that installs all the basic prerequisites

The full page where the above link resides

These all need to be addressed before you can then evaluate what might be in your syslog.

If you can troubleshoot installation in a fully protected environment, you can probably postpone security issues like credentials until later.


Re: My previous post in this thread

Installing ruby / ruby gems prerequisites

Strictly speaking, my zypper command actually installs the requirements to install a ruby <web application>.
Of course, you might modify according to your actual requirements, you can omit apache2 and mariadb (myslql) if not needed, add anything else you might need as necessary.


Thanks TSU, I have been busy but will have a closer look at your posts later.

Sorry, I forgot about this thread, I dropped my attempts to install owncloud this way.

I had a go with KVM (installed winXP with KVM to test with) which really was much easier than I had thought, I had never tried any sort of virtualisation before; so, now I intend to try an image of OwnCloud from SUSE-Studio running inside KVM instead.