Minimal usage

I’m looking to make openSUSE use as little RAM as possible. I’m currently using Xfce as a desktop enviroment and it is working a lot smoother than Gnome or KDE did. But is there anything else i can do like install a stripped down version of Firefox with only the basics installed use only one panel or something like that? I want to keep it quite stylish and minimal.

On that note i am unsure of how to install Xfce themes. I downloaded this theme:
Salu by ~p0ngbr on deviantART
but i dont really know what to do with it tbh.

Also, Debian Media player crashes when i start it comes up with the error message “Fatal Error” I will copy out the error message if it will help.

And yet another problem. I am connected to my router (I type 192.168.1.254 into the address bar and I can connect) but I can not view webpages.

Hi
I would recommend signing up for suse studio and rolling your own :slight_smile:
http://susestudio.com

Disable any services (including startup when you login) you don’t need,
get rid of beagle and associated plugins.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 Milestone 5 (i586) Kernel 2.6.31-rc4-1-desktop
up 0:13, 2 users, load average: 0.07, 0.18, 0.17
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Thanks, it looks useful but unfortunately when i go to sign in with my Novell account it says it is invite only :frowning: but will remember this site and look into it once sign ups open back up and also it doesnt seem to support PPC. But Xfce is working quite well for me now and running smoothly my panel is now just a windows list and right click acts as a menu.

My main issue now is Network access. OpenSUSE is recognizing the network card and connection and as i said before i can connect to the router but i cant view any webpages :(. Also when i try to enter sudo commands into the terminal it asks me for the password and i cannot enter any characters which is strange and happens across all Terminals. I can however use the sudo vi command but i do not know how to save the changes that i have made to a document.

Can you reach the router’s web interface ?

Please copy and paste output of this command:

su -c ifconfig
Enter root password when asked for.

This to see if your machine gets an ip from the router.

OK, now this may seem stupid but i cant type when it asks me for a password the terminal just doesnt let me type and only lets me press enter i can type in other apps so the keyboard isnt broken it just doesnt work.

Hi
There is no screen output (eg *****) when entering the password :wink: Just
enter it, then press enter.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
up 6 days 21:21, 2 users, load average: 0.09, 0.07, 0.09
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Thanks, that was very silly of me to overlook that.

dff@linux-3dx1:~> su -c ifconfig
Password: 
eth0      Link encap:Ethernet  HWaddr 00:15:C1:DB:78:AF  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::215:c1ff:fedb:78af/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1104 (1.0 Kb)  TX bytes:5091 (4.9 Kb)
          Interrupt:51 

eth0:BeBo Link encap:Ethernet  HWaddr 00:15:C1:DB:78:AF  
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:51 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1564 (1.5 Kb)  TX bytes:1564 (1.5 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:15:C1:DB:78:AF  
          inet6 addr: fe80::215:c1ff:fedb:78af/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:12948 (12.6 Kb)

dff@linux-3dx1:~> 

Here you are hope it helps.

I’m looking to make openSUSE use as little RAM as possible.
Uhhh, why would you want that ? 512 RAM or even less ? From 1GB+ there should be no problem, also I am wondering if you know that GNU/Linux has a different way of handling RAM (and memory in general) ?

If you want minimal memory usage, try an icewm session. It should be one of the Session options on your login page.

But truly minimal would be using a shell only. :wink:

You have six linux terminals by default and you can use the program GNU Screen to give you multiplexed terminals (terminals within terminals). There are text only web browsers, email and instant messaging programs. Mplayer even works to play videos; cmus can be a substitute for amarok.

It’s an interesting exercise to use just the terminal tools and you learn a lot. But I need my spreadsheets, charts and other office documents and pdf files for work :stuck_out_tongue: and Gimp and Inkscape to keep me happy. :slight_smile:

Thanks. I’m happy with Xfce. I tried the one you suggested thisoldman and it was just too much for me it wasnt practical. Xfce is the right balance for me. Usage is no longer an issue for me now. It’s my internet connection. I will start a thread today.