minimal BASH-like.... grub>

Hi folks.

In the latest opensuse tumbleweed and leap 15 i can’t boot the system. I was Instaling it houndreds of times before and I’m using opensuse from the Suse 9.1 release, but this time something is wrong with grub and i can’t boot it. When i turn my laptop on, I’m getting only grub minimal BASH-like grub > screen. I presume that someonething is wrong with grub but i can’t figure it out what it is. I can boot it only if I boot instalation usb and when I chose boot from hard disk option. Then it shows me my grub boot menu and I can boot my instaled system.

So folks, does anyone know what’s going on and help me to fix that?

First, once you were up in the desktop, did you try the Yast Boot Loader?

If you mean Boot loader in yast, yeah, i have check it, everything looks normal.

Try again, but make a change, nothing big needed (eg: You could change the timeout up or down a second) to force it to reinstall, see if that helps.

I’ve tried but no use

UEFI or not?

Solutions may differ.

Also, post the output of:

cat /etc/default/grub_installdevice

It is UEFI system.
(sorry for late raplay)

I’v downloaded a latest tumbleweed release and aded ISO as repository and installed a grub from tumbleweed, but no use, it hapens same situation again

Show output of “efibootmgr -v”.

Here is it…

grga@linux-cdtv:~> su
linux-cdtv:/home/grga # efibootmgr -v
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0005,0000,2001,2002,2003
Boot0000* Windows Boot Manager HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Unknown Device: HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0002* Unknown Device: HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\opensuse\grubx64.efi)RC
Boot0003* Unknown Device: HD(7,GPT,733c473a-e522-43c6-9b25-0c3acd20322a,0x3f7a0800,0xfa000)/File(\EFI\opensuse\grubx64.efi)RC
Boot0004* USB HDD: JetFlashTranscend 8GB PciRoot(0x0)/Pci(0x14,0x0)/USB(3,0)/HD(1,MBR,0x790aa574,0xc88,0x1e84)RC
Boot0005* Windows Boot Manager HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\opensuse\shim.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}…4…
Boot0006* Unknown Device: HD(8,GPT,a68881f3-f6ee-411d-9970-df35b7b81a38,0x3f7a0800,0xfa000)/File(\EFI\opensuse\grubx64.efi)RC
Boot0007* opensuse-secureboot HD(7,GPT,733c473a-e522-43c6-9b25-0c3acd20322a,0x3f7a0800,0xfa000)/File(\EFI\opensuse\shim.efi)
Boot0008* ubuntu HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\ubuntu\grubx64.efi)
Boot0009* ubuntu HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot000B* ubuntu HD(2,GPT,442c714c-e786-4ccc-86d0-8aea146e6926,0xe1800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot2001* EFI USB Device RC
Boot2003* EFI Network RC
linux-cdtv:/home/grga # ^C
linux-cdtv:/home/grga #

Thank You…

That’s not something that was created by installer. You never mentioned that you tried to mess with bootloader in the past.

Boot0007* opensuse-secureboot   HD(7,GPT,733c473a-e522-43c6-9b25-0c3acd20322a,0x3f7a0800,0xfa000)/File(\EFI\opensuse\shim.efi)

That may have been created by installer, but it is on another partition (again, you never gave even the minimal information about your system) and is not included in standard boot sequence.

You never mentioned that you had Ubuntu or Windows either.

If you explain your configuration someone may have an idea how to fix it.