MiniDLNA missing hostname in served files.


I’m having some difficulties in running MiniDLNA.
First off what went right:I found the config file in **/etc/sysconfig/minidlna **rather than the /etc/minidlna every guide seems to point to. Although later out I figured out I could have just used the YaST /etc/sysconfig edtior.

  • I’ve managed to use YaST Services Manager to make minidlna start on boot and to launch it.
  • Files are advertised over the network as I can see them on the television/smartphone

What isn’t going right:
Files are not playing, VLC on the smartphone however gives the insightful error message

The location http://:8200/MediaItems/23.mp4" cannot be played

So what appears to be going on is that MiniDLNA is not adding the hostname to the locations it serves. I’ve confirmed that going to “” manually in a browser it does work.
I’ve had the presentation_url in the config file both on its blank value and set to without remedying the problem and it was the closest thing I could find to a ‘hostname’ type of config option.

Does anyone know what I should change to make MiniDLNA serve up proper media urls?

In my old config file “friendly_name” is set to the hostname of my server. Maybe that’s what’s missing. IIRC that worked with VLC.

Mmmh I changed the friendly name to and did a

sudo minidlnad -R
sudo service minidlna restart

I see that the name has changed when I browse using UPnPlay files still however don’t play.

With the same error message/missing host name indication in VLC.

As a little update:
I was some updates behind on my openSUSE install (1684 to be exact - oops) but even after updating everything to the latest version however the problem persists. I seem to have little luck in finding anyone else with the same problem which makes it hard to find a solution. Any suggestions on where besides here I could attempt to find help are welcome :).

Did you try readymedia

Trying to install readymedia (the package is still called minidlna for some reason) I’m getting a warning /usr/sbin/ifconfig being missing. Which sounds like it might be the cause of the issue as that’s probably used to get its IP. And is it can’t it goes missing in the URLs it serves.

Even after installing net-tools-deprecated minidlna is still complaining about missing the ifconfig depency, how do I fix this?

after having installed the net-tools-deprecated I switched back to minidlna from the packman repository and now things are working.

So I guess net-tools-deprecated is a depency even if its not set to be one and is used to get the ip adresss.

If you installed minidlna from an openSUSE repo,
Be sure to submit a bug to

It’s common for older apps to use legacy network tools like ifconfig for network settings discovery (eg vmware used to do this), and as a leading edge distro Tumbleweed has deprecated those tools. The “ip” tools have replaced the legacy network tools for… maybe 6+ years now, and TW made the change maybe 4 years ago? Other openSUSE (eg LEAP) install legacy tools by default for backwards compatibility but as you’ve determined TW does not.