Minidlna error: Media directory "/home/xxx/Filmes" not accessible [Permission denied]

Hello all,

After the last updates of my OpenSuse Tumbleweed the MiniDlna server stopped making streaming of my multimedia files. I have 5 machines with tumbleweed and all of them stopped making multimedia streaming.
The server works only does not list folders and files.
I verified that in all it there is the error:

MiniDLNA.C: 670: Error: Media Directory “V, / Home / My_User / Videos /” Not accessible [Permission Denied]

It seems to me a bug. Does anyone know about this problem?
Any ideas?

Yes. All my machines run current Tumbleweed 20211118 and don’t exhibit this behavior. MiniDLNA works fine on all of them. Thus I presume it’s not a bug.

Without knowing anything about your server configuration, I note that you’re using files located within the user’s /home directory. Maybe the following is applicable?

Media directory not accessible Please note that the default systemd service file enforces the parameter ProtectHome=on. If you intend to share files that reside within the /home/ file system you may want to lessen that restriction. You can achieve this by updating the systemd unit override file (/etc/systemd/system/minidlna.service.d/override.conf)

[Service]
ProtectHome=read-only

https://wiki.archlinux.org/title/ReadyMedia#Media_directory_not_accessible

Similar thread:

Confirmed!

**erlangen:~ #** diff /usr/lib/systemd/system/minidlna.service /etc/systemd/system/minidlna.service 
10c10 
< ProtectHome=true 
--- 
> ProtectHome=read-only 
**erlangen:~ #** 

It’s the OP that needs to share their configuration and verify that all is as it should be.

Running “systemctl edit --full minidlna.service” and “systemctl restart minidlna.service” does the trick.

Does what trick? You’re not the OP.

Problem solved.

Karlmistelberger was right. The file minidlna.service service had the option ProtectHome = True enabled. I changed the option ProtectHome for read-only and everything went back to work.
It is annoying to make these changes to servers without any warning during installation. Luckily there are you.

Thank you all.

Pedro

As I was alluding to as well in post #3.

You’re welcome. Thanks for the feedback. It makes helping other users an even greater experience.