Minecraft Locking Up System

Hello everyone,

Bit of an annoying problem here, and I’m not sure where to start finding a solution. I recently (fresh) installed openSUSE 12.3, an upgrade from 12.2. In 12.2, Minecraft worked fine. However, since I installed 12.3, Minecraft will launch, seem to run fine, I can play for a bit, but then all of a sudden, my computer will completely lock up, and I need to do a hard reset (the keyboard is totally unresponsive). When it locks up, my external monitor will go completely blank, and my laptop monitor will have a skewed version of the image that was on it when the game froze, then slowly fading to black. Sometimes (though not always), the image on the monitor will return momentarily, and I can move my mouse around, but I cannot click on anything, and the keyboard is unresponsive, and after a few seconds it will slowly fade to black again.

I can’t seem to find a more specific trigger for it other than it only happens when playing Minecraft. Sometimes it will happen the minute I get into a game, other times it will let me play for a few minutes (I’ve had as much as probably 10-15 minutes) before locking up. But it always will eventually lock up, given enough time.

I’m playing vanilla Minecraft, no special mods or add-ons or anything.

I don’t even know where to begin troubleshooting this problem. I wasn’t able to find any similar problems on the Internet. Does anyone have any suggestions as to where I should be looking to fix this?

Thanks,

David

Sounds like a video card issue to me. Wild guess, though.
Does it happen regardless of window or full screen mode?
Can you switch terminals (Alt+Ctrl+F1…)?

Uwe

Thanks for your reply, buckesfield.

I can’t change terminals, nope; and I haven’t tried playing in full screen, I usually play windowed. Is it worth trying it full screen?

As for video card troubleshooting, what would be the best way to troubleshoot that?

Tell us the video card and the driver being used

Haha, sorry - guess I should’ve known to post that. Card is Mobility Radeon HD 3400, and I’m using the radeon driver.

You might want to try the AMD/ATI proprietary driver. You will get netter 3D rendering

Thanks for your reply gogalthorp. I tried your suggestion, but then I found out my HD 3450 isn’t compatible with the new proprietary driver, and the legacy proprietary driver isn’t compatible with the Xorg version in openSUSE 12.3! So I might be stuck with the radeon driver.

Any other suggestions to get around this?

Upgrade to kernel 3.11 and use mesa git then add:

radeon.dpm=1 to kernel parameters

Use these two repos:
Index of /repositories/Kernel:/HEAD/standard
Index of /repositories/home:/pontostroy:/X11/openSUSE_12.3

Thanks for your reply, ryanbach. What exactly will your suggestion do? Also, I know what git is but I’ve never used it - what do you mean by ‘use mesa git’?