Milestone 5 + broken package management

Hi,
Package management is broken on fresh installed milestone 5 ( Installed from kde4 livecd ). First zypper could not refresh my repositories, then I tried this workaround: How to circumvent a partly broken zypper - openSUSE Forums
Now my repositories are ok, they are refreshed but I can’t use yast2’s package management anymore.

It is milestone 5’s package management broken or it just happened to me?

Hi
It’s working fine for me, but I did a DVD install for Gnome. Maybe
LiveCD related?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 Milestone 5 (i586) Kernel 2.6.34-rc3-3-desktop
up 5:06, 2 users, load average: 0.45, 0.24, 0.13
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

On a fresh install of milestone 5 KDE live CD I get the following error when attempting to update repos in yast.

defined(%hash) is deprecated at /usr/share/YaST2/modules/URLRecode.pm line 39 (#1)
(D deprecated) defined() is not usually useful on hashes because it
checks for an undefined scalar value. If you want to see if the hash
is empty, just use if (%hash) { # not empty } for example.

(Maybe you should just omit the defined()?)
defined(%hash) is deprecated at /usr/share/YaST2/modules/URLRecode.pm line 53 (#1)
(Maybe you should just omit the defined()?)
defined(%hash) is deprecated at /usr/share/YaST2/modules/URLRecode.pm line 67 (#1)
(Maybe you should just omit the defined()?)
YaST got signal 11 at YCP file /usr/share/YaST2/clients/repositories.ycp:1229
/sbin/yast2: line 468: 5486 Segmentation fault $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS
QColor::setNamedColor: Unknown color name ‘BACKGROUND’
QColor::setNamedColor: Unknown color name ‘FOREGROUND’
QColor::setNamedColor: Unknown color name ‘BACKGROUND’
QColor::setNamedColor: Unknown color name ‘SELECT_BACKGROUND’
QColor::setNamedColor: Unknown color name ‘SELECT_FOREGROUND’

I do too. When I try to install Factory OSS and NON-OSS repos.

What’s up?

I think it works for me from DVD (32-bit with LXDE desktop).

… but I am using the factory-snapshot as my OSS and Non-OS repos as I prefer a stable baseline to write bug reports:


http://download.opensuse.org/factory-snapshot/repo/oss/

and

http://download.opensuse.org/factory-snapshot/repo/non-oss/

But dont’ forget to check out the most annoying bugs: Bugs:Most Annoying Bugs 11.3 dev - openSUSE

You can also log on to bugzilla with your forum user name and forum password and search to see if someone has raised a bug report on this. There is guidance here for that:
Submitting Bug Reports - openSUSE

Don’t forget if you think none of these are relevant, then you should write a bug report.

This appears to be part of a documented issue with M5 64bit and zypper.

Hopefully fixed soon.

I get seg fault error when trying to install the factory-snapshot repos…
Same as with factory repos.

Don’t forget Smart Software package manager works on openSUSE-11.3 Milestone5.

Just download smart, smart-gui, and any dependency it may ask for. There is no big rabbit hole of dependencies here, … just one or two extra apps. When you try to install via rpm command it will tell you what you are missing.

You can find the smart and smart-gui rpms here:

http://download.opensuse.org/repositories/smart/openSUSE_Factory/

I have the 32-bit smart working on openSUSE-11.3 Milestone5 and I believe the 64-bit will also work.

so no need to let a minor hiccup like zypper not functioning well stop one.

There is an issue updating the package list (if you don’t want snapshot but actual factory) on 64bit on yast2 repos.

My proposal was to activate the Head:zypp repo, then to disable factory temporarly and
zypper up -r headzypp
(This I had mistakenly written wrong before in my thread!)

Does smart actualize the package repo yast2 lists through different means than zypper?

I replaced the 64 bit version with the 32 bit version because with my hardware and the programs I use,

I get little advantage from 64 bit and for me the problem is gone.

Smart accesses the rpm database directly. It does not use any yast nor zypper config files.

But it is about syncing package lists of yast2 repos:
https://bugzilla.novell.com/show_bug.cgi?id=595545

I guess it depends on what one is planning to do.

Is one’s purpose to test only zypper ?

Or does one acknowledge the bugs on zypper but still wishes to test the remainder of the 11.3 M5 applications?

If the later, then Smart fills in more than adequately as the Package Management for M5.

Lets be clear, I’m not saying replace zypper for smart in 11.3 GM. I AM saying that users who state they can not test 11.3 M5 because of a zypper package hiccup are IMHO coming to a wrong conclusion, given that Smart more than adequately steps up to the plate for M5.

How to circumvent a partly broken zypper - openSUSE Forums
This link is either broken or the post has been removed. Anyway, I used the Head repos and updated libzypp, zypper and some other yast2 pkgs by downloading them individually and installing with rpm. Now I can use zypper again.

YaST software manager complains that the checksums for all the repos that I have enabled are no longer valid and won’t install any pkgs. I ran nearly 700 MB worth of updates today from the factory repo after I got zypper working again. The kernel is now 2.6.34-rc4-4.