Microsoft Teams stalls on start. Goes on after deleting cache and user files.

In my work I need to use MS Teams to communicate with clients and coworkers working on Windows. I currently use Teams version on openSUSE Tumbleweed.

After a several weeks of not using it I discovered yesterday that I could not start the application anymore. More precisely, the application launched but the process stalled at some point and did not completely start up. As I thought this was a problem with the installation, I uninstalled everything and reinstalled again. Things worked apparently well after that but after a reboot the problem reappeared. After several rounds and lots of head-scratching I finally found out that I could skip the problem by deleting the user files and cache that MS Teams writes in ~/.config/Microsoft and subfolders before starting the application. This is a rather brutal method but works and allows me to use the application. I nevertheless wish there was a better way.
Have any of you experienced this? Have you found a better solution? Happy to hear from it :slight_smile:

PS: I also learned that there are now two flavors of MS Teams: Teams-preview (teams in zypper) and Teams-insider (teams-insider in zypper). Why? What is the difference?

I have the same problem. As workaround i use the version from snap.

Thank you for your comment. I will have a look at that!

I have the same problem and I find a bad trik that work for me:

  • stop teams (if it is running)
  • exec:
  • cd~/.config
  • [FONT=monospace]rm-rfMicrosoft [/FONT]
  • [FONT=monospace][FONT=monospace]rm-rf[/FONT]
    [/FONT][FONT=monospace][FONT=monospace]Microsoft\ Teams\ -\ Preview[/FONT][/FONT] - [FONT=monospace][FONT=monospace][FONT=monospace]rm-rf[/FONT]
    Microsoft\ Teams[/FONT] [/FONT]


  • restart teams
  • you must login again

I do this every startup, the problems seems to be the read of saved info.

Thank you very much! This worked out also for me. I was stuck on this problem since last thumbleweed huge update (Snapshot 20210904).
How to make Opensuse or microsoft aware of this?


I do not know, Mircosoft is not interested on linux, it have many bugs also on Ubuntu… And Open suse do not do nothing I think that is a problem of teams, that write in bad way some files.
So Microsoft is the only that can solve the problem, but is difficult that it will be interested in. You can try to write to microsoft in some way, I do not know how.

Just for the record, teams updated today to version and the problem appears to be solved.

thank you, just what I came here for!