Microsoft Teams : microphone not working


I just installed Microsoft Teams (official RPM package provided by Microsoft) on my workstation running OpenSUSE Leap 15.1 KDE.

Video is working OK, but audio is not working.

I have two microphones : a Blue Snowball Pro microphone (default), and then the one that’s in the webcam.

On the same system I’ve used Jitsi with a Chromium browser perfectly.

A Google search for “microsoft teams linux microphone not working” showed that I’m not the only one with that problem, though I have yet to find a fix.

Any suggestions ?

Install pavucontrol and see, if the micro is shown and teams has the right source.

Yesterday someone has also no microphone, he has added his User to the audio group, logoff and login and all was working.

Maybe this will help you.

OK, after some more experimenting, I managed to get it working perfectly.

I wrote a little article about Teams on OpenSUSE on my tech blog.


And how did you fix it? Mind you, this is an English speaking forum so please explain in English here. Not everyone understands French, as is written on your blog.
Thank you.

Hello guys, I managed to solve the problem for me.

Click on the KDE audio volume tray icon, there are speakers and microphone. At the right hand side of the microphone, there’s a menu with an option ‘Record all audio via this device’. Selecting this option enabled the microphone in the Teams app (we are using the Microsoft supplied RPM).

I know it’s not very detailed but I just wanted to note it down quickly, I’ll add details like versions, etc later.

No such option for Leap 15.1.
More recent KDE is needed: