Running SuSE 10.3 on a new Gateway M-series laptop.

Everything installed like a charm.

Am using KInternet (rather than the usual Network Manager which was spotty connecting using the wireless).

Even the sound works (including the touch sensitive volume control).

Last item on the to-do list:** the mic. Can’t seem to make that work, and couldn’t find any issues with the driver.


00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)

Any help appreciated.


I assume you are using KDE as you are using KInternet, in which case since you don’t mention it, have you enabled the mic channel in Kmix?

KMix has no Mic slider under the Input tab. Only Digital, InMux, and InVol (all turned on).

In fact, the thing that worries me is that in Sound Configuration (YaST), there are no other channels under the Master volume, where the mic etc would normally be.


Can you provide some more information on your hardware/software configuration? … ie …with your PC connected to the internet, please start by copy and pasting the following diagnostic script into a gnome-terminal or konsole with your PC connected to the internet:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

and when prompted for a password enter your root password. Please try to accurately estimate the number of jacks/plug you have when asked (for example, I have 3 i/o sound jacks on my PC), and when the script is complete it will give you a URL. Please post that URL on this thread.

Also, in addition to the above, please copy and paste the following commands one line at a time into a gnome-terminal / konsole and paste here the output of these commands:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Am I correct in assuming that you are using KDE3.5.x ?


tsalsa.txt - nopaste.com (beta)

rpm -qa | grep pulse:


rpm -q libasound2:


uname -a:

Linux mo #1 SMP 2008-06-09 13:53:20 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound:

options snd-hda-intel enable=1 index=0

# u1Nb.EsOev2S5uF7:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Thankyou for that.

Please, the output of the above rpm command also.

I note from the script that your PC has a stac9205. Searching on the alsa web site for the stac9205 gives this: Search results for stac9205 - AlsaProject

Which indicates there are many updates for the stac9205 in version 1.0.15 and 1.0.16 of alsa. Hence it may be useful for you to update your alsa.

I note the ALSA-Configuration.txt file for 1.0.18rc3 of alsa provides these model options for the STAC9205 (which are NOT available in 1.0.14 of alsa):

	  ref		Reference board
	  dell-m42	Dell (unknown)
	  dell-m43	Dell Precision
	  dell-m44	Dell Inspiron 

While they are listed for the “Dell”, its possible one of them will work in your laptop for the mic.

To update your alsa, with your PC connected to the internet, in a konsole or gnome-terminal, after first typing “su” (no quotes, enter root password) to obtain root permissions, THEN copy and paste in sequence (one at a time) the following six commands:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_10.3/ multimedia 
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_10.3_Update/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

Then restart your PC and test your sound.

If still no sound, then edit your /etc/modprobe.d/sound file with an edit like:
options snd-hda-intel model=dell-m42 enable=1 index=0

u1Nb.EsOev2S5uF7:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
and then restart your sound with: su -c ‘rcalsasound restart’ and test your sound and mic.

If that fails then replace “dell-m42” with “dell-m43”, and then restart your sound with: su -c ‘rcalsasound restart’ and test your sound and mic.

If that fails then replace “dell-m43” with “dell-m44”, and then restart your sound with: su -c ‘rcalsasound restart’ and test your sound and mic.

Hopefully one of those will work.


Thanks for all your help!

Sorry, I had forgotten that one.

rpm -qa | grep alsa:


Regarding your later post:

Then restart your PC and test your sound.

I do have sound right now.** I wouldn’t like to mess that up. If I try all the things that you suggest in your post and somehow lose the sound, will there be a way back short of reinstalling the whole OS?

Again, thanks for the help!


If installing the rpms for the latest alsa version (via the zypper commands) does not work, then simply put in your installation CD/DVD and “roll back” to (ie install) the older alsa versions that come with your openSUSE-10.3 CD/DVD.

If you put edits in the /etc/modprobe.d/sound file that do not work, then simply remove the edits.

Thanks oldcpu!

My mic works now (albeit a bit on the low side). I am missing a the mic boost switch in KMix. I updated the alsa drivers but didn’t yet try any of the edits in the /etc/modprobe.d/sound file. I might try that next if I feel courageous enough. In any case, your help is greatly appreciated!