Microphone won't work. Please help.

Hello there.

I can’t and I can’t setup opensuse 11.1 so microphone would work.
Everytime I start Krecord and try to record myself and after recording to listen myself I get message: can’t open soundcard: Device or resource busy.

Why is that ? How can I fix this ?

Hei,

Does your microphone work on your computer, do you hear yourself in your speakers when talking into it? I may suggest to use another application in any case, maybe try with audacity which should be able to run without using jack server. It is more complex but not very difficult to use I believe, haven’t much experience with it myself though.

Cheers,
Olav

First of all F_Sauce tahnk you for your replay.

No, audacity also won’t record anything. I’ve also tried Ekiga and Skype. I can’t use my microphone on my headset since I’ve upgraded (clean install) to 11.1

Any ideas of how to figure it out if my sound card is properly supported ? Maybe I have bad drivers, I dunno…

Try using a more simple command to test your mic. When I test my mic, I typically use a simple arecord command. ie something like
arecord -d 10 myrecording.wavwhere in that example the “-d 10” controls the length of the recording to be 10 seconds. I chose the arbitrary file “myrecording.wav”. You will need to substitute your own wav file there.

You also need to pay close attention to your mixer, as there can be confusing controls inside the mixer for controlling one’s mic. Are you using kde3 or kde4 ? If you are using kde4, you can make visible the necessary controls for the mic in kmix by using the approrpiate kmix menu items (I’m not on a Linux PC right now, so I can’t say exactly what kmix menu item … it may be called “channel” ).

If you fail miserably, you could post your mixer settings. One way to do that is to post the output URL provided when running the following command with root permissions in a konsole:
/usr/sbin/alsa-info.sh
you may need to run this twice, … the first time to update the script and the second time to create the URL from the script.

Note if some other device appears to have seized your audio, you can get a handle on that by running the “lsof” command. Basically, when things are running nominally, run this command:lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*and save in a text file the output. Then when things do not run properly, run the file again, and compare the two outputs. That can sometimes give an indication as to what device has seized one’s mic or one’s audio.

It clearly indicates that your microphone is not properly installed.

with arecord I couldn’t record anything, this is what I get when recording with arecoord and trying to play this file with mplayer:

arecord test.wav
Recording WAVE 'test.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
^CAborted by signal Interrupt...                                                                        
frojnd@linux-f3gn:~> mplayer test.wav 
MPlayer dev-SVN-r27637-4.3-openSUSE Linux 11.1 (i686)-Packman (C) 2000-2008 MPlayer Team                
CPU: Genuine Intel(R) CPU           T2250  @ 1.73GHz (Family: 6, Model: 14, Stepping: 8)                
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1                                             
Compiled with runtime CPU detection.                                                                    
Can't open joystick device /dev/input/js0: No such file or directory                                    
Can't init input joystick                                                                               
mplayer: could not connect to socket                                                                    
mplayer: No such file or directory                                                                      
Failed to open LIRC support. You will not be able to use your remote control.                           

Playing test.wav.
Audio only file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 8000 Hz, 1 ch, u8, 64.0 kbit/100.00% (ratio: 8000->8000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [alsa] 48000Hz 1ch u8 (1 bytes per sample)
Video: no video
Starting playback...
A:  -0.0 (unknown) of 0.0 (unknown) ??,?%

Exiting... (End of file)

I’m using KDE 4.2 and I’ve tried to test all kinds of channels… interstinh is that under alsamixer I don’t have any microphone channel: http://www.shrani.si/f/3C/6Y/plTFFXV/posnetek6.png

I had to run /usr/sbin/alsa-info.sh twice as u told me, here is the info: http://www.alsa-project.org/db/?f=b326954577d273f8f07122c5404a78e532e5bb35

The output of lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
is:


lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/frojnd/.gvfs
      Output information may be incomplete.
COMMAND     PID   USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
knotify4  12270 frojnd  mem    CHR  116,4          4355 /dev/snd/pcmC0D0p
knotify4  12270 frojnd   12r   CHR  116,2      0t0 3923 /dev/snd/timer
knotify4  12270 frojnd   13u   CHR  116,4      0t0 4355 /dev/snd/pcmC0D0p
knotify4  12270 frojnd   14u   CHR  116,8      0t0 4416 /dev/snd/controlC0
kmix      12304 frojnd   10u   CHR  116,8      0t0 4416 /dev/snd/controlC0
amarokapp 12307 frojnd   14u   CHR  116,8      0t0 4416 /dev/snd/controlC0

Things are still NOT_normal since I didn’t have a chanece to setup properly my microphone (I’ve two mics but noone will record anything)

P.S. I was in da mountains that’s why my reply has such a long response time.

Your mixer settings are not good. Now there may be other problems as well, but until we sort your mixer settings, I do not think I should waste your time with other suggestions. Note this from your PC (from the diagnostic script):

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xefffc000 irq 21’
Mixer name : ‘SigmaTel STAC9200’
Simple mixer control ‘PCM’,0
Front Left: Playback 147 58%] -21.60dB]
Front Right: Playback 147 58%] -21.60dB]
Simple mixer control ‘IEC958’,0
Mono: Playback on]
Simple mixer control ‘IEC958 Default PCM’,0
Mono: Playback on]
Simple mixer control ‘Capture’,0
Front Left: Capture 0 0%] [0.00dB] off]
Front Right: Capture 0 0%] [0.00dB] off]
Simple mixer control ‘Digital’,0
Front Left: Capture 19 16%] -20.50dB]
Front Right: Capture 19 16%] -20.50dB]
Simple mixer control ‘Input Source’,0
Item0: ‘Mic’
Simple mixer control ‘Mux’,0
Front Left: Capture 0 0%] [0.00dB]
Front Right: Capture 0 0%] [0.00dB]Note your mic is either off, or has levels that are FAR FAR too low. Also, you have digital audio (IEC958) switched ON. Is that absolutely necessary for our sound to function? Your PCM volume is also very low. … are you happy with that setting?

I note you are using kde-4.2 , but you are running alsamixer.

Have you tried kmix? That is typically the mixer that users will use when running KDE.

oldcpu: I’ve added all those channels: MUX, DIGITAL, CAPTURE (also chcked button “recording”:
http://www.shrani.si/f/3X/Yd/2TYBC9ja/posnetek7.png

So now THERE IS SOUND :slight_smile: only that sound is wery disturbing: HERE is hosted a sample that I’ve created, but aware of some static involved.

Hm I just don’t know how to loose this annoying extra static…

Do you have any ideas why the sound isn’t “clean” ?

I had the same problem. The solution for me was to go into kmix, Configure Channels…, add:

  • Capture
  • Capture 2
  • Input Source
  • Input Source 2

I then set the Captures to Max, and the Input Sources on Mic.

Hope that helps.