Microphone volume very low when routed through Pulseaudio

I’ve just installed openSUSE 13.2 on a Lenovo G50-30, which has an onboard Intel sound device. (Check my alsa-info if you want more details.) I discovered that recording from the internal microphone via Pulseaudio yields very low volume—the sound is almost inaudible. Turning the input capture level all the way up using pavucontrol has no effect.

I’m pretty sure that the problem is with Pulseaudio, not with the hardware itself, because using ALSA’s arecord to record from the internal microphone (e.g., arecord -D hw:0,0 -vv -f cd ~/test.wav) works fine.

This problem means that, short of killing or uninstalling Pulseaudio, it’s impossible to use certain audio-capturing applications such as Skype.

Does anyone know of a solution or workaround?

Hmmm…does the following work for you?

Launch pavucontrol >> Input Devices >> Unlock the sliders for the for the internal mic (so the right and left are not locked together), then drag the right one to zero. See if that helps.

I got this suggestion from here.

Since you mentioned Skype as having issues, you might want to check that Options >> Sound Devices >> “Allow Skype to automatically adjust my mixer levels” is not checked. That can impact on PA too.

I notice a lot of sound issues in the threads within a short amount of time and wonder what may be going on. I, too, am having a similar (but not quite the same) problem as the OP in this thread, except the mic works fine in Skype (as long as the checkmark in the Skype dialogue is set to allow it auto-adjust the sound levels). But, there are other issues elsewhere.

I have not yet decided to actually post my sound problem details – I am going to do my own looking, for awhile – but thought that I should add the comment about the growing proliferation of sound problems.

My problems appear to be tied in with PulseAudio, as well.

For reference in solving this user’s thread, I should mention:

I am running openSUSE 13.1
KDE desktop
Built-in (onboard, not cpu) Intel sound device

I’m using openSUSE 13.1/KDE as well, but haven’t observed any strange or unexpected behaviour, but I’m no power user with respect audio. I did reinstall Skype today just to test it’s behaviour on my fully-updated system, but nothing unusual observed. Interesting that you found that you need to allow Skype to adjust sound levels. Reverse to suggestions that I’ve read about previously. I guess this does depend on the hardware in question, and how PA settings can be affected by that.

FWIW, I have

inxi -A
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel 
           Sound: Advanced Linux Sound Architecture v: k3.11.10-29-desktop

One possible explanation is your mic boost is too low:


Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

I recommend 65% instead of 0%.

Another possibility is this can be explained by pulse audio volume control (pavucontrol) having a low setting for your mic.

I recommend you install pavucontrol and use it to tune your mic record levels on an application basis.

I wondered about that too, but as the OP referred to an internal mic I thought the following was applicable


Simple mixer control 'Internal Mic Boost',0
   Capabilities: volume
   Playback channels: Front Left - Front Right
   Capture channels: Front Left - Front Right
   Limits: 0 - 3
   Front Left: 3 [100%] [36.00dB]
   Front Right: 3 [100%] [36.00dB]

Still, maybe it does come into play here?

Honestly, I’m not sure if it relevant. Running pavucontrol may help thou. I have an old blog entry on using pavucontrol here: Pulseaudio Basics for openSUSE with pavucontrol - Open Chat - openSUSE Forums which has a section on using the mike with pulse audio, that the OP may find of use.

No, I’m afraid that doesn’t help.

This setting also has no effect on the problem.

I think the info you quoted is for the external microphone, not the internal microphone. The external microphone works fine with these settings.

Another possibility is this can be explained by pulse audio volume control (pavucontrol) having a low setting for your mic.

I recommend you install pavucontrol and use it to tune your mic record levels on an application basis.
In my original post I said that I already used pavucontrol to increase the internal microphone capture level. This had no effect on the problem.

Its difficult to understand if pavucontrol was configured correctly as no script provides that output. I know of no easy way to have the user provide data for a Pulse Audio Quality Check, which is especially if they do not know all the ins and outs of pavucontrol. I’ve participated in a number of threads where users strongly claimed to have configured pavucontrol, but then did not understand one can configure it on an application level or they missed some other aspect … Hence I think it useful to provide a confidence check on this.

What are your pavucontrol configuration tab settings ? What are the ‘Output Devices’ settings ? What are your pavucontrol ‘Recording tab’ settings when running your application ? What is specified for ‘show’ ? Can you provide screen prints of each ?

A further suggestion would be while trying to get the internal mic to work (as you note the external works fine) is to disable the auto mute:


Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'

You can re-enable it as appropriate when using the known functional external mic.

Internal mics also tend to be digital . I note IEC958 is disabled. Does it need to be enabled for your PC hardware for the Internal mic to work ? I don’t know the answer - rather I am just asking to ensure you know the answer for your hardware (as everyone’s hardware is different)


Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

I was never able to solve this issue (and had overlooked the last post by oldcpu here asking for further details). I recently upgraded the system to openSUSE Leap 42.2 (with PulseAudio 9.0) and the problem persists: the internal microphone volume is almost inaudible when recording in PulseAudio applications, but behaves completely normally when recording in ALSA applications.

There is a single setting “Profile” which is set to “Analog stereo duplex”. (Or at least, I think so – the account I’m logged into has KDE set to display everything in Russian. I launched pavucontrol with LANG=en, but it’s still displaying the contents of most drop-down boxes in Russian.)

What are the ‘Output Devices’ settings ?

There is a setting “Port” with a value which I assume is “Speaker”. The associated volume is 100%.


In case you’re interested in ‘Input Devices’ as well, there is a setting “Port” with the value “Internal microphone”. The volume is 100%.

What are your pavucontrol ‘Recording tab’ settings when running your application ? What is specified for ‘show’ ? Can you provide screen prints of each ?

The “Show” setting is set to “All streams”. When I place a Skype call, then Skype appears here, with the volume set to 100%.

A further suggestion would be while trying to get the internal mic to work (as you note the external works fine) is to disable the auto mute… I note IEC958 is disabled. Does it need to be enabled for your PC hardware for the Internal mic to work ?

I can certainly try these. Which files do I need to edit?

Suggests to me maybe a configuration/cache file in your home may be the problem try a different user if that works remove all pulse config and cache files from your home

I had already tried deleting ~/.config/pulse and that didn’t solve the problem. I’m not aware of PulseAudio using any cache directory; if you know otherwise, let me know where I can find it and I’ll clear it.

There is a .pulse directory

Not on my system there isn’t.

I don’t know how phonon has evolved between kde 13.2 and leap 42.2 but on leap alsa doesn’t do anything useful at all but is still about. You should see a mic volume control in the pulse audio volume control also a recording one if you have a recording application, just as the sound volume control is doubled up the 2nd one reflecting application settings. I usually set the basic pulse ones at 100%

The way I found out that alsa wasn’t doing anything was to install alsa mixer, play some music and check if the volume control did anything. It didn’t unless I reduced it to zero which muted the output - so at zero it was probably directly telling pulse to mute.

I then installed pavucontrol - the pulse volume control and all of the controls in that did what they should.

One problem I have had in the past was an application changing pulses basic volume control rather than the application one so if I adjusted that apps volume lower the sound level dropped off when other apps were playing. Mplayer did this from memory. It shouldn’t and there may be others.

Several things can be done in yasts sound section. Auto detect and set up via edit - making sure you select the one that you use if there is more than one. Also the “other” button bottom right… Volume brings up a whole host of them. It will also set up pulse audio - just in case that has messed up some how. For me the test sound buttons here don’t generate any sound. Probably because it’s assuming I use the analogue output from the card. I use a digital one. The test reached via set up did produce sounds. That may be playing on all channels.

Looking at the volume settings in yast is probably the best thing to look at first and if the ones you use aren’t at 100% set them to that.

John

Can’t edit my last post but I just looked at phonon settings. It’s changed since I last looked. Might be because of the phonon gstreamer plug in. I tried vlc for while. Under audio volume applications it shows alsa playback volume that was at 80% and this alsa control does function. It’s now at 100%. The output device controls mimic the ones on the desktop. I believe these 100% settings are aimed at best dynamic range and can be set higher in some places but best not to.

I hate software that has changed since I last looked at it.

John

Not quite true. PulseAudio is a sound server implementation that sits above the ALSA layer, albeit the latter is reduced to essentially providing kernel layer support (drivers) for the audio hardware.

https://upload.wikimedia.org/wikipedia/commons/0/00/Pulseaudio-diagram.svg

I can only mention what I found deano. Alsa mixer making no difference to sound levels at all other than when the vol is set to zero it muted it. It was driving me nuts trying to track down my particular problem - all of those grunts rather than clean sound all of the time. Pavucontrol was mentioned in another thread. Once I installed that things made more sense. All of the vol controls worked and the 2ndry one tracked phonon either way. It could be adjust in pavucontrol or phonon and the both matched which ever was used.

I’m not sure how my current phonon back end came about. It don’t think it was alsa gstreamer. I think it just said gstreamer with the option of vlc which is still there and it seems preferred by upstream. I intend to install leap 42.2 on a low memory netbook at some point out of curiosity. As 13.2 ran ok on it I think leap will. One thing I will be curious about is how phonon was originally set up by a fresh install.

;)All good clean fun I suppose. I have to test sound with pink floyd when things aren’t as they should be to keep me feeling mellow but it makes me feel much worse if there is no sound.

John