Microphone problem Alsa / Pulse audio

Hello.

I have some microphone problems. I can’t record anything. (I’m using openSUSE 11.3)

My sound card was detected almost correctly (at least the chip-set was i think). I have an Asrock motherboard (k7upgrade880, with a Southbridge: VIA 8237 | Audio: CMedia CMI9761 6 channel AC’97.

I ran these commands so far with these results - while i was following the audio troubleshooting guide (SDB:Audio troubleshooting - openSUSE:slight_smile:

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.22.1.

cat /proc/asound/modules
0 snd_via82xx

cat /proc/asound/cards
0 [V8237 ]: VIA8237 - VIA 8237
VIA 8237 with CMI9761A+ at 0xd000, irq 22

But i have NO audio playback problems - movies, games, music all play well.
And the Microphone guid has a broken link :frowning:

I tried to change my 50-sound.conf file (i read it on a forum, I’m new to linux troubleshooting) from this:
options snd slots=snd-via82xx
to this:
options snd slots=snd-via82xx position_fix=1
But that did not work either. I did not get any sound with the last line.

Any suggestions, what kind of information you guys need to help whit my problem? Or some guides that i can follow?

Thanks.

When you are using Pulse Audio, start pavucontrol (control volume of Pulse Audio in the Multimedia category of the menu) and check in the input tab if the right microphone is selected. You’ll see automatically if it works in this application.

Also, check with alsamixer that all the volume related to the mic are at a right level.

I’m sorry to read your mic does not work. My first recommendation is not to play with things like 'position_fix=1" unless you really know what you are doing.

… Installing ‘pavucontrol’ and then running ‘pavucontrol’ is IMHO a good start IF you are using Pulse with Gnome. If using KDE in 11.3 its not such a good idea, … it has an ‘input device’ tab and a ‘recording’ tab. While trying to record sound, you can try to tune with that.

When testing your mic, use a simple terminal command such as:

arecord -vv -f cd test.wav 

and then try to tune with pavucontrol (with Gnome). You can test if the recording working by simply playing back “test.wav”.

If that does not work, then please provide the information that is requested to be provided in our multimedia stickie: Welcome to multimedia sub-area

To save you trying to figure out the part to post, I’ll quote the salient sections from the stickie for you:

please post …providing in your post the following information:

/usr/sbin/alsa-info.sh  

and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
.
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.comand press SUBMIT on that site and again post here the URL/website-address it provides.

.
… some clarification on running the script “alsa-info.sh” … when you run:

/usr/sbin/alsa-info.sh 

you should get something like this (if it asks for an update, select NO):
http://thumbnails33.imagebam.com/9280/a5973e92794041.jpg](http://www.imagebam.com/image/a5973e92794041)

followed by this (select the SHARE/UPLOAD option):
http://thumbnails30.imagebam.com/9280/5e84f992794044.jpg](http://www.imagebam.com/image/5e84f992794044)

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :
http://thumbnails32.imagebam.com/9280/214da092794048.jpg](http://www.imagebam.com/image/214da092794048)

followed by this (where in RED is the URL).
http://thumbnails23.imagebam.com/9280/d9858092794051.jpg](http://www.imagebam.com/image/d9858092794051)

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload
which will create the file /tmp/alsa-info.txt. Copy that file and paste it on [Pastebin.com](http://pastebin.com/) and press submit. That will give you a URL address. Please post that URL here.
 

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

I checked both pavucontrol and alsamixer. In pavucontrol i checked all posibilities, and still no luck. In alsamixer i cant change the microphone volume at all.

The script result:
http://www.alsa-project.org/db/?f=f280992e5a3658462cd69ec4176f14934795833d

And the command results:

rpm -qa ‘alsa
alsa-firmware-1.0.23-1.2.noarch
alsamixergui-0.9.0rc1-746.1.i586
alsa-plugins-1.0.23-1.9.i586
alsa-utils-1.0.23-1.8.i586
pyalsa-1.0.22-1.8.i586
alsa-plugins-pulse-1.0.23-1.9.i586
alsa-oss-1.0.17-29.2.i586
alsa-1.0.23-2.12.i586
bluez-alsa-4.64-2.10.i586

rpm -qa ‘pulse
pulseaudio-esound-compat-0.9.21-10.3.1.i586
pulseaudio-0.9.21-10.3.1.i586
pulseaudio-module-zeroconf-0.9.21-10.3.1.i586
pulseaudio-module-gconf-0.9.21-10.3.1.i586
pulseaudio-module-lirc-0.9.21-10.3.1.i586
alsa-plugins-pulse-1.0.23-1.9.i586
libpulse0-0.9.21-10.3.1.i586
libpulse-mainloop-glib0-0.9.21-10.3.1.i586
pulseaudio-module-bluetooth-0.9.21-10.3.1.i586
libpulse-browse0-0.9.21-10.3.1.i586
pulseaudio-module-x11-0.9.21-10.3.1.i586
pulseaudio-utils-0.9.21-10.3.1.i586

rpm -q libasound2
libasound2-1.0.23-2.12.i586

uname -a
Linux linux-l58b 2.6.34.7-0.7-default #1 SMP 2010-12-13 11:13:53 +0100 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-via82xx

Ssy1.Ygdz0JkHI56:K7VT6 motherboard

alias snd-card-0 snd-via82xx

Hope this helps shed some light on my problem.

Oh, by the way, I’m using gnome desktop 11.3 distro.

Thanks for the information. The diagnostic script tells me you are running a 32-bit openSUSE-11.3 with the 2.6.34.7-0.7-default kernel, also with alsa version 1.0.22.1 (driver) and alsa version 1.0.23 (utilities) on a K7Upgrade-880 with a C-Media Electronics CMI9761A hardware audio codec. I checked the ALSA-Configuration.txt file to see if had any guidance for that hardware audio codec and did not find any.

I checked your mixer settings to see if it is properly setup for recording, and it does appear it may be possible to tune better …


**!!Amixer output**
!!-------------
**
!!-------Mixer controls for card 0 [V8237]**
Card hw:0 'V8237'/'VIA 8237 with CMI9761A  at 0xd000, irq 22'
  Mixer name	: 'C-Media Electronics CMI9761A '
**Simple mixer control 'Line',0**
  Front Left: Playback 0 [0%] -34.50dB] [off] Capture **[off]**
  Front Right: Playback 0 [0%] -34.50dB] [off] Capture **[off]**
**Simple mixer control 'Mic',0**
  Front Left: Playback 31 [100%] [12.00dB] **[off]** Capture [on]
  Front Right: Playback 31 [100%] [12.00dB] **[off]** Capture [on]
**Simple mixer control 'Mic Boost ( 20dB)',0**
  Mono: Playback [on]
**Simple mixer control 'Mic Select',0**
  Items: 'Mic1' 'Mic2'
  Item0: 'Mic1'
**Simple mixer control 'IEC958',0**
  Mono: Playback [on] Capture **[off]**
**Simple mixer control 'Aux',0**
  Front Left: Playback 0 [0%] -34.50dB] **[off]** Capture **[off]**
  Front Right: Playback 0 [0%] -34.50dB] **[off]** Capture **[off]**
**Simple mixer control 'Mono Output Select',0**
  Items: 'Mix' 'Mic'
  Item0: **'Mix'**
**Simple mixer control 'Capture',0**
  Front Left: Capture 0 **[0%]** [0.00dB] [on]
  Front Right: Capture 0 **[0%]** [0.00dB] [on]
**Simple mixer control 'Mix',0**
  Front Left: Capture **[off]**
  Front Right: Capture **[off]**
**Simple mixer control 'Mix Mono',0**
  Front Left: Capture **[off]**
  Front Right: Capture **[off]**
**Simple mixer control 'Input Source Select',0**
  Items: 'Input1' 'Input2'
  Item0: 'Input1'
**Simple mixer control 'Input Source Select',1**
  Items: 'Input1' 'Input2'
  Item0: 'Input1'

I don’t know which capture controls need to be unmuted, but I note that the Mon Mic is NOT selected, but rather a mixer input (for recording) is selected. And that mixer input has capture OFF. I don’t know how relevant that is.

I did read somewhere (via surfing for the CMI9761A) that this device is very sensitive to inappropriate capture settings being set: No microphone input with alsa 1.0.20 with an CMI9761A+ chip on-board

I note the IEC958 capture is OFF, I assume that is a digital capture. Does your motherboard use a digital or analog capture?

Further, when testing for mic record functionality, I recommend you use a simple terminal command:

arecord -vv -f cd test.wav 

talk in to the mic, check the pavucontrol settings (and alsamixer) and then after some recording, press to stop recording, and play back the test.wav file with a media player.

The mixer suggests a Mic1 and a Mic2, and the script provides:


ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

which suggests 2 input devices. I assume you have then a front jack and a rear jack on your PC for the mic ? I also assume this is not a USB mic.

Updating alsa

If after turning with the mic and unmuting the various capture controls you still do not succeed, you could try an alsa update, but I’m not so convinced that will work as I have read no indication of an alsa update in this area.

To update one could follow the guidance here: SDB:Alsa-update - openSUSE and update alsa-firmware, alsa-plugins, alsa-utils, pyalsa, alsa-plugins-pulse, alsa-oss, alsa, libasound2. There are also many pulse updates there, but I have never recommended updating them (as I have NEVER read of a case where such a pulse update helped).

After updating those, check the version number. If the version number did not change, then you do not understand how YaST software management works, and you need to try again to update.

Also install alsa-driver-kmp-default for the 2.6.34.7-0.7 kernel you have installed.

Thanks for the replies.
Do i need to edit the alsa.conf file, and if so where can i locate it, i searched for it in the /usr/sbin and /etc folders but did not find it. Maybe you could guide me, where to find the file, that i need to edit?

P.S
I tried running alsaconf as root but it did not detect my sound card. I than got a bit scared - i lost all sound - but after restarting the sound server it worked again.

No you should NOT edit the alsa.conf file. Other distributions may do that but NOT openSUSE.

alsaconf was depreciated a long time ago. It does NOT work with any recent openSUSE version.

Why are you looking at editing a file?

If I had thought there was a file to edit, I would have recommended such.

Did the update to alsa fail ?

Can you specify how can i change the settings that you marked with red? Can i do that at all?

I don’t know about a front microphone jack, but maybe there is a cable plugged in on the motherboard that i’m not aware of.

I installed the kernel module, but that did not help.

I verified the installation in the Yast Software Manager and the version indicators font color is red. I suppose that is bad, but i’m not shore.

As you mentioned it would not help to update the alsa, so i did not do that.

Yes of course. Those are mixer settings. Change them in your mixer. THAT depends on your desktop. In gnome you can use alsamixer, amixer and pavucontrol. amixer is tricky to use because it needs precise syntax and I don’t know the syntax. That is ONE reason why I avoid the gnome desktop and prefer KDE.

Don’t stop 1/2 way. If you are going to update the kernel module then you should update the remaining alsa apps and libasound2. The guide is QUITE CLEAR on that. If you are going to innovate and go ‘your own way’ make sure you know EXACTLY what you are doing and EXACTLY how the alsa driver works. Why deviate?

I don’t know what you mean. How about posting the output of:


rpm -qa '*alsa*'
rpm -q libasound2 

Now I’m confused. You just told me you did update with the alsa-kernel module. So did you or did you not?

I was not that clear, i did install the alsa-driver-kmp-default packadge, i folowed the guide for updating alsa (SDB:Alsa-update - openSUSE), but i think i have all the updates available for 11.3. I have the update repository added to my repo-list, but did not find any update for the libasound2. Maybe i missed something.

Here is the output of the two commands you specified.

rpm -qa ‘alsa
alsa-tools-gui-1.0.24.1-20.1.i586
alsa-plugins-1.0.23-1.9.i586
pyalsa-1.0.22-1.8.i586
alsa-oss-1.0.17-29.2.i586
alsa-1.0.23-2.12.i586
bluez-alsa-4.64-2.10.i586
alsa-utils-1.0.23-1.8.i586
alsa-plugins-pulse-1.0.23-1.9.i586
alsa-driver-kmp-default-1.0.24.20110409_k2.6.34.7_0.7-1.1.i586
alsa-firmware-1.0.23-1.2.noarch
alsamixergui-0.9.0rc1-746.1.i586

rpm -q libasound2
libasound2-1.0.23-2.12.i586

Many thank for your cooperation and help.

Thats the ONLY app you succeeded in updating.

The remainder:


alsa-plugins-1.0.23-1.9.i586
pyalsa-1.0.22-1.8.i586
alsa-oss-1.0.17-29.2.i586
alsa-1.0.23-2.12.i586
bluez-alsa-4.64-2.10.i586
alsa-utils-1.0.23-1.8.i586
alsa-plugins-pulse-1.0.23-1.9.i586
...
alsa-firmware-1.0.23-1.2.noarch
...
libasound2-1.0.23-2.12.i586

were NOT updated.

That can and quite possibly IS causing a problem. Possibly contributing to your mic problem still being present.

I think if you had accurately followed the guide, you WOULD have updated those. Please try again. Note the guide EVEN gives pictures showing how to use YaST to do the update. Do NOT innovate here with a different update method. Just follow the guide.

Good luck !

The problem was that the main repository was enabled, after disabling it, i’w got the majority of

Here is the new output.
alsa-tools-gui-1.0.24.1-20.1.i586
alsa-oss-1.0.17-56.3.i586
alsa-utils-1.0.24.2-33.1.i586
bluez-alsa-4.64-2.10.i586
alsa-plugins-1.0.24-36.1.i586
pyalsa-1.0.22-13.1.i586
alsa-driver-kmp-default-1.0.24.20110409_k2.6.34.7_0.7-1.1.i586
alsa-1.0.24.1-85.1.i586
alsamixergui-0.9.0rc1-746.1.i586
alsa-plugins-pulse-1.0.24-36.1.i586
alsa-firmware-1.0.24.1-11.2.noarch

libasound2-1.0.24.1-85.1.i586

Sadly it did not help.

The alsa-oss-1.0.17-56.3.i586 version is the newest that i can find in the in the specified repositories. The pyalsa, as far as i know is some kind of python module, i don’t know, where to update that - or is that relevant at all?

I think i have to face the fact that my hardware is not supported 100%.

I tried my cheap usb webcam with incorporated mic, and surprisingly it works (the sound is too low, but it works).

Thank your for your help oldcpu, thumbs up for your work, you are doing a great job.

Maybe yes, maybe no.

Its interesting , thou, that the cheap webcam mic can be made to work, as those can be difficult.

I can take another look at your mixer configuration IF you post the output URL/address provided by running the diagnostic script:

/usr/sbin/alsa-info.sh 

or BETTER if you wish to get the best help available, you can write a bug report on openSUSE-11.3 component sound, with a bug title something like “internal mic with C-Media Electronics CMI9761A does not work”. There is guidance for writing bug reports here: openSUSE:Submitting bug reports - openSUSE You can use your openSUSE forum username and password when logging on to bugzilla. This will bring the bug/problem to the attention of the SuSE-GmbH packager of sound, who is also a developer of the alsa sound driver. If anyone can get this to work he can. He can even modify the alsa sound driver as necessary (for some cases). Attach to your bug report the file /tmp/alsa-info.txt that you get by running:

/usr/sbin/alsa-info.sh --no-upload 

and ensure your bug report has all the salient information. The SuSE-GmbH packager will NOT read a forum thread, so it is important your bug report be as complete as possible. Then after writing the bug report, every few days check on its status. As soon as he replies, you have his attention, at which time the sooner you reply to his clarification requests/suggestions the better. Be certain each time you reply that you clear the bug report from “NEED INFO” (this will make more sense once you see this happen).

As I noted, he is an alsa sound developer and if he fixes this, ALL Linux distributions will benefit from your bug report and work with the SuSE-GmbH packager (who is an alsa driver developer).

Good luck.

Here is the new output.

http://www.alsa-project.org/db/?f=52bbf02758522693c9dfa5071155ef3ef0bb1e09

I will try to report the bug if i can get have a bit of extra time on my hands. Thank you very much.

Double check your mixer settings. I note:


!!Amixer output
!!-------------
**!!-------Mixer controls for card 0 [V8237]**
Card hw:0 'V8237'/'VIA 8237 with CMI9761A  at 0xd000, irq 22'
  Mixer name    : 'C-Media Electronics CMI9761A '
**Simple mixer control 'Line',0**
  Front Left: Playback 0 [0%] -34.50dB] [off] Capture **[off]**
  Front Right: Playback 0 [0%] -34.50dB] [off] Capture **[off]**
**Simple mixer control 'Mic',0**
  Front Left: Playback 31 [100%] [12.00dB] **[off]** Capture [on]
  Front Right: Playback 31 [100%] [12.00dB] **[off]** Capture [on]
**Simple mixer control 'Mic Boost ( 20dB)',0**
  Mono: Playback [on]
**Simple mixer control 'Mic Select',0**
  Items: 'Mic1' 'Mic2'
  Item0: 'Mic1'
**Simple mixer control 'Phone',0**
  Front Left: Capture [off]
  Front Right: Capture [off]
**Simple mixer control 'IEC958',0**
  Mono: Playback [on] Capture **[off]**
**Simple mixer control 'IEC958 Capture Monitor',0**
  Mono: Playback **[off]**
**Simple mixer control 'IEC958 Capture Valid',0
**  Mono: Playback **[off]**
**Simple mixer control 'IEC958 Output',0**
  Mono: Playback [off]
**Simple mixer control 'IEC958 Playback AC97-SPSA',0**
  Mono: 3 [100%]
**Simple mixer control 'IEC958 Playback Source',0**
  Capabilities: enum
  Items: 'AC-Link' 'ADC' 'SPDIF-In'
  Item0: 'AC-Link'
**Simple mixer control 'Aux',0**
  Front Left: Playback 0 [0%] -34.50dB] **[off]** Capture **[off]**
  Front Right: Playback 0 [0%] -34.50dB] **[off]** Capture **[off]**
**Simple mixer control 'Mono Output Select',0**
  Items: 'Mix' 'Mic'
  Item0: **'Mix'**
**Simple mixer control 'Capture',0**
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
**Simple mixer control 'Mix',0**
  Front Left: Capture [off]
  Front Right: Capture [off]
**Simple mixer control 'Mix Mono',0**
  Front Left: Capture [off]
  Front Right: Capture [off]

Practically everywhere I look in the mixer, the capture is OFF. So you need to try different setting combinations.

Note also that an internal mic tends to be a digital mic, which could mean an IEC958 mic and you may need to switch that ON.