Microphone not working ( sony VAIO)

I have a sony vaio (PCG 3F1M) with opensuse 11.2 installed on my machine. I am a new user of linux. And I was using windows vista before this. I was able to use my internal microphone in vista but I am unable to use it in opensuse 11.2. If I attach an external microphone then it works fine.

I tried recording by

arecord -d 10 myrecording.wav

and also tried checking some the mixer settings by


and the settings are

Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Front Left: Playback 85916 [131%] [on]
Front Right: Playback 85916 [131%] [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 17437 [27%] [on]
Front Right: Capture 17437 [27%] [on]

i’ll be really thankful if some one can help me out.

Well done on getting this far.

Getting internal mics to work on Linux can be difficult. Dependent on the wiring, it could be the mic is associated with your web cam, and its possible you need the web cam driver to get the internal mic functioning … and maybe not.

Its also possible your internal mic is a digital (as opposed to an analog mic). It would be useful if you knew which. Also, are you a Gnome or KDE user? Gnome will for certain have the extra complexity of pulse audio added. KDE may not.

Now for some general advice, suggestions, and information requests …

To test your mic I now recommend this command

arecord -vv -fdat foo.wav

I can also play back the recording with xine or mplayer or xmms (or any audio playback program). There is some guidance here: Microphone - openSUSE

The benefit of such a simple test, is there is no other software inbetween, where there could a problem with the software (as opposed to the hardware configuration, or the mixer configuration).

Embedded (integrated) mics are always difficult to debug.

For openSUSE-11.2, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It may ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will ask if you wish to SHARE/UPLOAD the information. Please select that. It will then post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf… with that information I may be able to make a recommendation.