Microphone not recognised Asus G1S / intel-hda

Hi,

I’m trying to make the microphone work on an Asus G1S. Neither the internal analog microphone nor the external one is recognized.

50-sound.conf in Modprobe.d has :

options snd slots=snd-hda-intel

u1Nb.ULiNFUWt9WF:Asus M51S series

alias snd-card-0 snd-hda-intel
and the codecs are :

 head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC660-VD

==> /proc/asound/card0/codec#1 <==
Codec: Motorola Si3054

I tried nearly every model configuration I could find in the alsa configuration guide:

ALC861VD/660VD
 3stack    3-jack   //    3stack-dig    3-jack with SPDIF OUT   //    6stack-dig    6-jack with SPDIF OUT   //    3stack-660    3-jack (for ALC660VD)     //  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)   //    lenovo    Lenovo 3000 C200   //    dallas    Dallas laptops  //     hp        HP TX1000   //    auto        auto-config reading BIOS (default) 

and even :

ALC861/660 
      3stack    3-jack    //   3stack-dig    3-jack with SPDIF I/O    //   6stack-dig    6-jack with SPDIF I/O    //   3stack-660    3-jack (for ALC660)   //    uniwill-m31    Uniwill M31 laptop   //    toshiba    Toshiba laptop support    //   asus        Asus laptop support    //   asus-laptop    ASUS F2/F3 laptops     //  auto        auto-config reading BIOS (default)

but it didn’t work.

I read on a forum that “Lenovo” could work with Asus G1, but on my G1S it gives no sound at all.

I wonder if I should not add some options to this first line, as “enable=1 index=0” or “position_fix=1” but I do not know what nor how to try anymore.

My alsa script is here:
Cijoint.fr - Service gratuit de dépôt de fichiers

Thank you if you have some more ideas. Thank you.

And, well, I’m not using Pulse audio. But some lib32 for skype.

rpm -qa ‘alsa
alsa-oss-1.0.17-29.2.x86_64
alsa-plugins-jack-1.0.23-1.9.x86_64
alsa-oss-32bit-1.0.17-29.2.x86_64
alsa-tools-gui-1.0.23-1.8.x86_64
alsa-plugins-1.0.23-1.9.x86_64
alsa-docs-1.0.23-2.12.noarch
alsa-tools-1.0.23-1.8.x86_64
alsa-utils-1.0.23-1.8.x86_64
alsa-1.0.23-2.12.x86_64
alsa-plugins-jack-32bit-1.0.23-1.9.x86_64
alsa-plugins-32bit-1.0.23-1.9.x86_64
pyalsa-1.0.22-1.8.x86_64
alsamixergui-0.9.0rc1-746.1.x86_64
alsa-firmware-1.0.23-1.2.noarch

bernard@portable_bernard:~> rpm -qa ‘pulse
libpulse0-0.9.21-10.1.1.x86_64
libpulse-mainloop-glib0-0.9.21-10.1.1.x86_64
cmus-plugin-pulse-2.3.3-1.pm.3.2.x86_64

rpm -q libasound2
libasound2-1.0.23-2.12.x86_64

uname -a
Linux portable_bernard.site 2.6.34.7-0.5-desktop #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf
options snd-hda-intel model=asus-laptop

u1Nb.ULiNFUWt9WF:Asus M51S series

alias snd-card-0 snd-hda-intel

Thanks for all the information.

This laptop has been around for a while. So it should ‘just work’.

I note a 64-bit openSUSE-11.3 with the ‘stock’ alsa-1.0.22/1.0.23 with the 2.6.34.7-0.5-desktop kernel. As you note the hardware audio codec is a Realtek ALC660-VD.

Please, do not use Skype for testing your mic. That introduces too many unknowns. Please use the basic ‘arecord’.

Hence for testing a mic, I recommend you use a terminal with this command:

  arecord -vv -fdat foo.wav

“foo.wav” is an arbitrary name I made up. Instead you could call it whatapain.wav or whichwaythewindblows.wav or anything …

Now reference your mixer, I note
Simple mixer control ‘Mic Boost’,0
Capabilities: volume penum
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch penum
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 17 [55%] [12.00dB] [on]
Front Right: Capture 17 [55%] [12.00dB] [on]You need the boost maximum, and you need capture at maximum, until recording is established. Now at the maximum levels there will be horrible distortion, so once you establish the mic works, then and only then back off to lower boost/capture levels.

In case there were updates to the ALC660-VD, I did a search on the alsa web site and noted there was an update from version 1.0.22 to 1.0.23 of alsa which you may not have …

ALSA: hda - Fix missing capture mixer for ALC861/660 codecs

- ALSA: hda - Fix missing capture mixer for ALC861/660 codecs 
The capture-related mixer elements are missing with ALC861/ALC660 codecs 
when quirks are present, due to missing call of set_capture_mixer(). 
Reference: Novell bnc#567340 
http://bugzilla.novell.com/show_bug.cgi?id=567340 

and if that is the case, you may need to update alsa not from the nominal openSUSE sites, but rather from the SuSE-GmbH packagers special repository for alsa.

There is guidance here for updating alsa (note the kernel version numbers are a bit off on that page, but don’t let that discourage you - I need to update that wiki) where that update might provide the extra controls you need to get the mic record working properly.

Hi oldcpu,

Thank you for your rapid and encouraging answer.

I’m not anymore in front of the computer, that isn’t mine. I’ll translate your instructions and send them to the owner of the computer.

Just to be sure, I understood it well: for the kernel 2.6.34.7-0.5-desktop, we’ll have to type this in order to install the Alsa update:

zypper ar [Index of /repositories/multimedia:/audio:/KMP/openSUSE_11.3_Update](http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.3_Update/) multimedia        
 zypper install alsa-driver-kmp-desktop 
zypper rr multimedia 

The ‘multimedia’ mention is needed after the ‘zypper ar’ command? I ask that because I wont be the one typing this and it would be more delicate to step backward.

Thank you very much.

PS : I just noticed I have the same trouble on my own VAIO. I’ll try to get out by myself now before bothering you again for this one.

Yes, the commmand will fail if you do not assign it a name. I proposed to call it “multimedia” but instead you could call it “thedarnthingfails” if you wish. ie

zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.3_Update/ thedarnthingfails        
zypper install alsa-driver-kmp-desktop 
zypper rr thedarnthingfails 

But note that is NOT the only update needed !! One needs to update all their alsa apps, such as alsa, alsa-utils, alsa-oss, alsa-plugins, libasound2, etc … And after one thinks they have updated the alsa apps, check the version numbers. If the version numbers have not changed then they update failed and one needs to try again. There are images in the alsa update guide showing how to do the update. One MUST pay attention to the selection in the version tab of the illustrated page.

Okay. I think I got the point.
Thanks a lot for being so didactic.

Hi ! nearly two months passed before I came back to my parents and tried to make this update.

The first step was ok, I mean I could update all alsa-apps, such as alsa, alsa-utils, alsa-oss, alsa-plugins, libasound2, etc … I checked their numbers and it succeeded.

Now when I try the second step, i.e. alsa driver-kmp-desktop, it says I have to downgrade my Kernel. Shall I ? At this point, I’ve no sound anymore.

Thanks you for your answer.

It will give you that statement (downgrade kernel) if you select the WRONG rpm or the wrong software repository. Hence I suspect you selected the WRONG rpm or the wrong repository !

Please double check.

I may be able to provide a recommendation if you provide the output of:

rpm -qa '*alsa*'
uname -a
rpm -qa '*kernel*' 

Hi oldcpu !

Thanks a lot for being here again ! it’s very nice of you.

Here is the output you’re asking for:

bernard@portable_bernard:~> rpm -qa ‘alsa
alsa-plugins-1.0.23-33.7.x86_64
alsa-docs-1.0.23-78.1.noarch
alsa-tools-1.0.23-11.2.x86_64
alsa-tools-gui-1.0.23-11.2.x86_64
pyalsa-1.0.22-6.2.x86_64
alsa-oss-1.0.17-56.2.x86_64
alsa-plugins-jack-1.0.23-33.7.x86_64
alsa-plugins-32bit-1.0.23-33.7.x86_64
alsamixergui-0.9.0rc1-746.1.x86_64
alsa-firmware-1.0.23-8.1.noarch
alsa-utils-1.0.23-39.1.x86_64
alsa-oss-32bit-1.0.17-56.2.x86_64
alsa-plugins-jack-32bit-1.0.23-33.7.x86_64
alsa-1.0.23-78.1.x86_64

bernard@portable_bernard:~> uname -a
Linux portable_bernard.site 2.6.34.7-0.5-desktop #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 x86_64 x86_64 x86_64 GNU/Linux

bernard@portable_bernard:~> rpm -qa ‘kernel
kernel-firmware-20100617-2.2.noarch
kernel-desktop-2.6.34.7-0.5.1.x86_64
kernel-desktop-base-2.6.34.7-0.5.1.x86_64

Thank you again. I’ll try again by myself this afternoon, anyway.

OK, your PC’s alsa app versions look ok. If you did not so so, also do not forget you must also update “libasound2” from the same repository in which you obtained the updates for the “alsa” applications.

Now reference the alsa-driver-kmp-desktop rpm, the respository to use is this one:

http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.3_Update/x86_64/

Be cautious thou, it appears there are two alsa-driver-kmp-desktops, and it is possible that a kernel update coming soon (I am puzzled by their being a 2.6.34.7-0.5-3 version and a 2.6.34.7_0.5-131 version).

Hi olcpu,

It worked. Thank you very much. Skype seems to work great now.

I want to get pulseaudio now with pavu-control. I’ve to re-open the first repository to get it from there. But now I know how to.

Thank you. My problem is now solved.

Congratulations. Don’t forget though, when there is a kernel update, the sound/mic may break, and you will need to update alsa-driver-kmp-destkop to match the updated kernel.

Is there any way you can set up this PC for remote access/maintenance ?

I maintain my mother’s openSUSE-11.3 PC for her remotely a continent away. She lives in Canada. I live in Europe. One to two times/month I will log on to her PC and update the software. Sometimes if she has a problem, I will logon sooner, and help her with her desktop.

Is there any way you can set up this PC for remote access/maintenance ?

I planed to use Teamviewer, but maybe there is something better? I must leave on thursday so that I’m afraid I can’t do much more configuration here.

There is something in Yast security snapshots that I’m not sure I understand. Do I have to change all these items concerning the remote access or is it something else?

The “multimedia:/audio:/KMP/openSUSE_11.3_Update” repository shouldn’t remain open, should it ?

Thank you.

Team viewer is an acceptable way to get established, after which you can then access remotely and put in place something better. The advantage of teamviewer, is it will go through the firewall, where often with other solutions the firewall is the biggest barrier.

In my case, I have setup my mother’s router firewall such that all incoming ssh and vnc requests are sent to the appropriate ssh and vnc ports on my mother’s PC on my mother’s LAN. My mother has two connections on her LAN, her PC and her TV. Sometimes she will have a wireless connection from a friend. And then I tuned the firewall on her openSUSE to allow ssh and vnc connections. It was important to start the ssh daemon on her PC (so her PC could be an ssh server to my remote connections).

Then I typically connect via:

  • vnc (which I pipe thru ssh for better security)
  • nx
  • ssh

But these approaches all require some knowledge, and between now and Thursday its a bit tight to sort that. So for now maybe just teamviewer.

Is there any way in which you can test your connection from another PC, such as your laptop if you have one (say connected at an internet cafe) to the PC you are supporting ? That way you are still in town to tune things, if it does not work.

I recommend you disable it.

If you can get remote access established, you can do all of this remotely.

I’m afraid not. Here in the countryside there is no cybercafe and the neighbours are away for Christmas.

That’s why I thought that Team Viewer was the best way.
I tried inside the house through a Netgear switch… and I can see the screen and interact with the mouse although the mobile taskbar does not appear when the mouse gets down the screen. But I can open krunner or a terminal via a right click.

However, thanks a lot for your support and your encouragement. :shake: