Microphone no longer recognized

NOTE: Sound works fine. Just no mic/recording devices detected. I first noticed this about a week ago when trying to use discord. I haven’t had any issues with sound or microphone for a very long time.

arecord -d 10 myrecording.wav
ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
arecord: main:828: audio open error: No such file or directory

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel PCH], device 0: ALC3229 Analog [ALC3229 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel PCH], device 1: ALC3229 Digital [ALC3229 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pacmd list-sources
No PulseAudio daemon running, or not running as session daemon.

inxi -Fxznr
**System:    Kernel:** 5.3.18-lp152.75-default x86_64 **bits:** 64 **compiler:** gcc **v:** 7.5.0 **Console:** tty 1 **Distro:** openSUSE Leap 15.2  
**Machine:   Type:** Laptop **System:** ASUSTeK **product:** G750JM **v:** 1.0 **serial:** <filter>  
           **Mobo:** ASUSTeK **model:** G750JM **v:** 1.0 **serial:** <filter> **UEFI:** American Megatrends **v:** G750JM.206 **date:** 04/02/2014 


**Audio:     Device-1:** Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio **driver:** snd_hda_intel **v:** kernel **bus ID:** 00:03.0  
           **Device-2:** Intel 8 Series/C220 Series High Definition Audio **vendor:** ASUSTeK **driver:** snd_hda_intel **v:** kernel  
           **bus ID:** 00:1b.0  
           **Sound Server:** ALSA **v:** k5.3.18-lp152.75-default


dmesg | grep -C1 -E 'ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel'
    0.260673] ACPI: Added _OSI(Linux-Dell-Video)
    0.260673] ACPI: Added _OSI(Linux-Lenovo-NV-**HDMI**-Audio)
    0.260673] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
--
    0.303042] pci 0000:01:00.0: reg 0x30: [mem 0xed000000-0xed07ffff pref]
    0.303051] pci 0000:01:00.0: Enabling **HDA** controller
    0.303215] pci 0000:00:01.0: PCI bridge to [bus 01]
--
    1.603622] Freeing initrd memory: 16288K
    1.624425] PCI-DMA: Using **sof**tware bounce buffering for IO (SWIOTLB)
    1.624426] **sof**tware IO TLB: mapped [mem 0x56f0b000-0x5af0b000] (64MB)
    1.624531] RAPL PMU: API unit is 2^-32 Joules, 4 fixed counters, 655360 ms ovfl timer
--
    1.687853] integrity: Loading X.509 certificate: UEFI:db
    1.687874] integrity: Loaded X.509 cert 'Micro**sof**t Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
    1.687875] integrity: Loading X.509 certificate: UEFI:db
    1.687896] integrity: Loaded X.509 cert 'Micro**sof**t Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
    1.687897] integrity: Loading X.509 certificate: UEFI:db
--
    8.748106] asus_wmi: Number of fans: 1
    8.781759] **snd_hda_intel** 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    8.785933] cryptd: max_cpu_qlen set to 1000
--
    8.950618] iTCO_wdt: Found a Lynx Point TCO device (Version=2, TCOBASE=0x1860)
    8.951425] input: **HDA** Intel **HDMI****HDMI**/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/**sound**/card0/input27
    8.951459] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
    8.951484] input: **HDA** Intel **HDMI****HDMI**/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/**sound**/card0/input28
    8.952502] input: **HDA** Intel **HDMI****HDMI**/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/**sound**/card0/input29
    8.952560] input: **HDA** Intel **HDMI****HDMI**/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/**sound**/card0/input30
    8.952620] input: **HDA** Intel **HDMI****HDMI**/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/**sound**/card0/input31
    8.953618] **snd_hda_codec**_realtek hdaudioC1D0: autoconfig for ALC3229: line_outs=2 (0x14/0x17/0x0/0x0/0x0) type:speaker
    8.953620] **snd_hda_codec**_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    8.953622] **snd_hda_codec**_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
    8.953623] **snd_hda_codec**_realtek hdaudioC1D0:    mono: mono_out=0x0
    8.953624] **snd_hda_codec**_realtek hdaudioC1D0:    dig-out=0x1e/0x0
    8.953625] **snd_hda_codec**_realtek hdaudioC1D0:    inputs:
    8.953626] **snd_hda_codec**_realtek hdaudioC1D0:      Mic=0x18
    8.953627] **snd_hda_codec**_realtek hdaudioC1D0:      Internal Mic=0x12
    8.963042] audit: type=1400 audit(1621901790.767:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lsb_release" pid=775 comm="apparmor_parser"
--
    8.990941] audit: type=1400 audit(1621901790.795:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="syslogd" pid=802 comm="apparmor_parser"
    8.997830] input: **HDA** Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/**sound**/card1/input32
    8.997899] input: **HDA** Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/**sound**/card1/input33
    9.000877] audit: type=1400 audit(1621901790.807:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="syslog-ng" pid=809 comm="apparmor_parser"

Any and all assistance is greatly appreciated.

Thanks,

~~ Curtis

I’ve edited your post using [noparse]

...

[/noparse] tags around the output to make it more readable.

Is it a deliberate choice on your part to not have PulseAudio running? Which desktop environment are you using?

Check

sudo setup-pulseaudio --status

FWIW, it can be enabled with

sudo setup-pulseaudio --enable

What is reported by the following?

arecord -l

deano_ferrari –

Thanks for the clean up. Wasn’t aware of those tags.

I am using KDE. Have been for years.

I haven’t deliberately installed or uninstalled pulse audio.

arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: HDMI [HDA Intel PCH], device 0: ALC3229 Analog [ALC3229 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
sudo setup-pulseaudio --status
[sudo] password for root:  
enabled

It shows as enabled, but for some reason wasn’t running in your opening post. It might be useful to examine the journal for pulse errors (if any)…

sudo journalctl -b |grep pulse
ps -e |grep pulse

If not already active, you could start manually (as regular user) with

pulseaudio -vvv

and note any errors.

The following guide shows to to run the alsa-info.sh diagnostic script which can yield useful info about the user’s sound system…
https://en.opensuse.org/SDB:Audio_troubleshooting#First_method_to_run_script
The general idea is to run it and let it upload the output to an online server. You can share the link to it here, so that others can review further.

PulseAudio relies on having functioning hardware and the ALSA (kernel) layer working. If the diagnostic script shows no problems, PA can be investigated for issues…
https://en.opensuse.org/SDB:Audio_troubleshooting#STEP-7:_PulseAudio_problems

deano_ferrari –

Thanks for the continued assistance. I really appreciate the insights.

curtis@certus-lt01:~> sudo journalctl -b |grep pulse
May 26 20:46:07 certus-lt01 plasma_session[2399]: org.kde.plasma.session: Starting autostart service  "/etc/xdg/autostart/**pulse**audio.desktop" ("/usr/bin/start-**pulse**audio-x11")
May 26 20:46:07 certus-lt01 dbus-daemon[1289]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service' requested by ':1.30' (uid=1000 pid=2454 comm="/usr/bin/**puls**
eaudio --daemonize=no ")
May 26 20:46:07 certus-lt01 rtkit-daemon[2475]: Successfully made thread 2454 of process 2454 (/usr/bin/**pulse**audio) owned by 'curtis' high priority at nice level -11.
May 26 20:46:08 certus-lt01 rtkit-daemon[2475]: Successfully made thread 2499 of process 2454 (/usr/bin/**pulse**audio) owned by 'curtis' RT at priority 5.
May 26 20:46:08 certus-lt01 rtkit-daemon[2475]: Successfully made thread 2509 of process 2454 (/usr/bin/**pulse**audio) owned by 'curtis' RT at priority 5.
May 26 20:46:08 certus-lt01 dbus-daemon[2258]: [session uid=1000 pid=2258] Activating service name='org.gnome.GConf' requested by ':1.32' (uid=1000 pid=2510 comm="/usr/lib/**pulse**/gconf-helper ")
May 26 20:46:11 certus-lt01 plasmashell[2429]: org.kde.plasma.**pulse**audio: No object for name "alsa_output.pci-0000_00_1b.0.analog-surround-40.monitor"
May 26 21:05:07 certus-lt01 rtkit-daemon[2475]: Successfully made thread 5600 of process 5600 (/usr/bin/**pulse**audio) owned by 'curtis' high priority at nice level -11.

curtis@certus-lt01:~> pulseaudio -vvv                
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 13.0-rebootstrapped
D: [pulseaudio] main.c: Compilation host: x86_64-suse-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -
g -fPIE -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-a
rith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-string
s -Wno-unused-parameter -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 5.3.18-lp152.75-default #1 SMP Wed May 5 09:22:56 UTC 2021 (16c42c8)
D: [pulseaudio] main.c: Found 8 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Running from build tree: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is d3789828821a4dafb76bb4370325ee46.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/curtis/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-13.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: **Daemon already running.**
E: [pulseaudio] main.c: **pa_pid_file_create() failed.
**

Your ALSA information is located at http://alsa-project.org/db/?f=1a2e4ec57a438142ce4ceff56f39f669cf633b32

I’m no sound guru, but happy to try to help where I can. At the very least, the requested info might help others to assist further.

ulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [PCH            ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xedc14000 irq 35
 1 [HDMI           ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xedc10000 irq 36


!!PCI Soundcards installed in the system
!!--------------------------------------

00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
    Subsystem: Intel Corporation Device [8086:2010]
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 05)
    Subsystem: ASUSTeK Computer Inc. Device [1043:157d]


!!Modprobe options (Sound related)
!!--------------------------------

snd_hda_intel: id=PCH,HDMI index=0,1
snd_hda_intel: id=PCH,HDMI index=0,1

The output you’ve shared shows that PulseAudio running. It also shows two sound cards present. The config fie shows a double entry for setting the sound card order explicitly. (One of the entries could be removed but likely not impacting here.)

Your mic appears to be off…

Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] -34.50dB] [off]
  Front Right: Playback 0 [0%] -34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

Interesting.

Not sure how this could have happened. I did install updates about a week back that included alsa packages.

I would like to know if this update caused this and how to correct it.

Thanks,

~~ Curtis

Try adjusting the mic level via KDE mixer (or pavucontrol).

BTW, are you still getting the same error with arecord as per your opening post?

Well…

I started looking a bit closer at pulse audio…The GUI…and what do you know…there are a bunch of profiles for Built-in Audio (Advanced Tab).

Three which have input. I chose one. It works now…

Thanks for the assistance and guidance.

I don’t know if this thread gets closed…or how it works. But looks like I am good now.

~~ Curtis

Great. I was going to suggest that you look at the PulseAudio config via pavucontrol. Anyway, glad to gave been of guidance. :slight_smile:

I don’t know if this thread gets closed…or how it works. But looks like I am good now.

~~ Curtis

No, it doesn’t get closed (or marked as resolved) as such, but your comments will show that it is, and you can always edit the title in your final reply to show that it is solved as far as you’re concerned. :wink: