Microphone does not work in skype

Thank you for your willingness to help.

Well, I tried. But Realtek drivers are beyond my expertise. A time consuming search of our forum would indicate a LOT of our users have had problems with those drivers.

Maybe Realtek can help you.

This is not a Realtek issue. I use hda-intel but don’t have Realtek hardware:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: ASUSTeK Computer Inc. Device 1153
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Memory at febfc000 (64-bit, non-prefetchable) [size=16]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

I experience exactly the same problem. The sound is being recorded if I select the right mic (“default” will pick the wrong device and not record anything) but the sound is distorted. The distortion sounds like the sound has been slowed down after sampling, i.e. I hear myself with a very deep, slow voice that is completely impossible to understand.

Anyway, this is not an openSUSE issue, either, as I use Gentoo ~x86. What I haven’t been able to figure out is, if this is an ALSA or a Skype issue. Skype used to work long time ago but I might have updated both ALSA and Skype since it last worked. A new kernel made no difference but I found out later that that actually downgraded from ALSA and 1.0.21. Anyway, neither version seemed to work.

My current version of Skype is and my last upgrade was from I strongly suspect that this version change in Skype broke it. :frowning:

So, no solutions. Just a heads up on the validity of this complaint. :)[/size]

thanks for the input.

Its very difficult to provide support when a different baseline driver is being used and input from users like your self who are using a baseline driver is definitely helpful.

There is a Skype bug report which I believe has to do with this, too. The problem seems to affect a number of devices possibly not even all of them based on hda-intel.



I had exactly the same problem - sound was very, very dirty… I use openSUSE 11.2 and I installed skype- After trying to change and verify various settings in KMix, KRecord and Audacity (all worked fine with my microphones), I finally decided to install PulseAudio. I break an installation pattern, but the microphone works pefrectly and sound is clean!

Running openSUSE 11.3_64 with kernel update, I had very similar problem. Skype seemed to work ok except mic input was very dirty. I adjusted and readjusted for several hours with no results until I found reference to Pulseaudio. Installed and on 1st try , all is good.

System is Toshiba U500 notebook using internal mic and speakers.

I have the same problem too. I fixed it by using the previous version of Skype that gave me the choice of using OSS instead of ALSA (different download), and that works for me. Using OSS the sound is perfect. But, maybe I should try PulseAudio too? It seems to work for others, and it would be nice to be able to upgrade to the newer version of Skype.

I got the microphone to work in Skype by getting pavucontrol and switching from mic 1 to mic 2 and back again. Unfortunately, this has to be done every time the system is restarted. Skype never showed any devices other than Pulseaudio, so I had to try and make it work. Any ideas on making this permanent so the back and forth thing is not needed?

I had the exact same issue using Skype with ALSA before. Since I’ve upgraded to OpenSUSE 11.4 and started using PulseAudio everything works as it should. The problem seems to be with Skype + ALSA, since Skype + OSS worked just fine before. My recommendation is to either use the older version of Skype (the OSS version), or install PulseAudio. PA solved everything for me.[/size]