Microos Installation

Hi,
I decided to give Microos a try and attempted to install it with kalpa-plasma on my desktop. The computer is a multiboot with Tumbleweed, Win10, and WinXP. It has three hard drives, one of which has 58GB unallocated space. I intended to install Microos on that unallocated space, but the installation program doesn’t recognize that space on the partition and wants to take over the complete hard drive space already allocated to Tumbleweed.

Question 1: How may I get Microos to recognize the unallocated space on the hard drive and direct it to install on that space?

Question 2: What partition mount points will I need to designate in the Microos installation?
a. I presume that I will need to designate the unallocated space as a BTFS file system mounted as root. Is this correct?
b. I presume that I will need to designate the present /boot/efi partition as /boot/efi so the Microos install program will write to it in order to get Microos to boot. Is this correct?
c. Do I need to designate the present swap partition as /swap for the Microos system installation?

It seems that the expert partitioner tool in Microos is reduced in function to simplify installation, but it presumes one will use an entire hard disk for the installation. I don’t wish to do that. I look forward to your response and instruction.

Thanks

In my first post I forgot to mention that I tried to install this two ways. I first tried to install using the selfinstaller download. That didn’t work because it didn’t recognize the unallocated space on the hard drive. Next I downloaded the iso and tried to install Microos with the regular iso, thinking I could use the expert partitioner to recognize the unallocated space. That also didn’t work, the expert partioner doesn’t recognize the unallocate space. In both attempts the installation program would only recognize the remainder of the hard drive where Tumbleweed is installed, and wanted to overwrite the entire hard drive for Microos installation.

@Munguasafiwe Correct, these are designed for single install and use the whole device… Multi-boot is not supported.

1 Like

Thanks for the information. I suppose there is a reason for that. I’ll have to try it in a VM if I wish to understand the new concept better. I think that would work as I don’t have a hardware computer to dedicate to it.