MicroOS does not have video after boot

Hi there.
The device is a RaspBerry Pi 3+.

This is my first attempt to run MicroOS on RaspBerry Pi 3+.
I am planning to use it on several hundred of RBPi devices to replace the current solution based on Arbiam.

The boot went fine until the message on console:
“Starting dracut initgroup hook…” (without ‘OK’) when I got a black screen and a few seconds later I got a “No Signal” message from monitor.

I use combustion script to create an user for my own, set password using openssl | chpasswd for root an my own user, install ssh keys for both, add myself to sudoers.d and start sshd.
Everything worked (not on first attempt, of course, LOL)

But I still have no video output on HDMI.

It is not the monitor or cable as I changed both (tried on a TV Philips, and on a Dell Monitor). Also, booting the same RBPi3+ with Arbiam 11, I got a text boot and a graphical mode running the default DE LX, no need to tweak anything.

I’ve post on r/opensuse and someone (looks like he is a microos experienced user/dev) with a very long and complicated username (LOL) told me to try to create the /boot/efi/extraconfig.txt containing hdmi_safe=1
I did and on next boot the initial video mode is 720p but later I lost video signal on the same point of boot (“Starting dracut initgroup hook…” )

Of course I have remote access (ssh) but I need console output to technicians access the device to configure my app on first use (and eventually debug my app)

I appreciate if anyone could guide me on debug this and fix the video output.


I’m fighting with this issue as well.
Is there any solution or has it been reported as a bug?
Could you upload your combustion script?
I read dracut is not correctly executing the cmb script…
Do you use hdmi to vga converter?