Microdia USB webcam 0c45:614a

Could anyone help me make this thing to work?

I have added the webcam repo, the system recognizes it

dmesg output:
1173.204072] usb 8-1: USB disconnect, address 2
1177.633059] usb 8-1: new full speed USB device using uhci_hcd and address 3
1177.778115] usb 8-1: New USB device found, idVendor=0c45, idProduct=614a
1177.778127] usb 8-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
1177.778137] usb 8-1: Product: USB camera
1177.778267] usb 8-1: configuration #1 chosen from 1 choice

Bus 008 Device 003: ID 0c45:614a Microdia

BUT it doesn’t work, v4l does nothing to it, i tried symlinking the dev to /dev/video0 but it still doesn’t work, has anyone made it to work?

What application are you using to test it?

I can’t test it at all since it doesn’t create the /dev/video0 .

Without that EVERY application will tell me that /dev/video0 doesn’t exist.

Unload and reload the driver. Check the /var/log/messages for any additional info when you do that.

Most probably, it should work with sonixj driver even though it is not listed.

Yes, i found a thread that said someone got it partially working by adding it’s identification as it is almost the same as 0c45:6418, i added the same line as 0c45:8418 in sonixj.c but changed 6148 to 614a, i wonder if it will work, anyway, unloading loading any possible module doesn’t help.

Not sure, but can you try creating the /dev/video0 device?
Major dev number = 81 and minor = 0.

Shouldn’t the system create it IF necessary?

Generally, it should. But, I am not sure that, in your case, there could be some issue.

I guess it doesn’t recognize this webcam since in sonixj.c there was no 0c45:614a and that’s what i got. I am still compiling unless you tell me how i can compile just that one module :wink:

You may not have to compile it. Just modprobe it and then, use modinfo to find out if it has any parameters for the USB ids.
If it is there, then you can load with those parameters instead of re-compiling.

Unfortunatelly there aren’t too many options i could use (there no options at all in fact), the only modinfo output are the devices in which mine is absent… Guess i will have to modify the sonixj.c, if that is so then could you tell me how could compile ONLY this module?

You can download the source from the site and untar it to any empty directory.
Then, the sequence to compile it is simple (after adding your USB ids and from the root of the source directory):

sudo make install

You have to install kernel headers using Yast or zypper before attempting this.

Thanks for the tip, i’m off to uni now so i’l reply later, thanks.

I have just purchased a Microsoft VX-3000 and I’m 24 hours from returning it. It is listed in the webcam HCL as “OK” but it isn’t working. This also uses sonixj. It is listed accurately under lsusb. Sometimes there is a video0 and sometimes not. In my case, things might be complicated by the Hauppague TV that is installed and is listed as 3 video devices (but not 0). It does not work with:

Somebody, somewhere must have gotten these to work.

I tried to help you here Prexy:
howto web cam? Logitech - openSUSE Forums
but you just ignored my post. :frowning:

I didn’t ignore you. I’m just slow to pull the trigger. :wink: