Micorophone

Hi there

Trying to get external microphone to work via CMI 8738 soundcard. Using SuSE 11.1, KDE 3.5, (No pulse). Mic works on other computer.

rpm -qa 'alsa

alsa-oss-1.0.17-1.37
alsa-1.0.18-8.12.1
alsa-utils-1.0.18-6.4
alsa-plugins-1.0.18-6.12
**
rpm -qa ‘pulse’**

libpulse0-0.9.14-2.3.1
libpulse-mainloop-glib0-0.9.14-2.3.1
libpulse-browse0-0.9.14-2.3.1

rpm -q libasound2

libasound2-1.0.18-8.12.1

uname -a

Linux Bud 2.6.27.45-0.1-pae #1 SMP 2010-02-22 16:49:47 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-cmipci

oxTw.leFtcOMtGx0:CMI8738/C3DX PCI Audio Device

alias snd-card-0 snd-cmipci
**
lspci -v**

02:08.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
Flags: bus master, medium devsel, latency 64, IRQ 17
I/O ports at de00 [size=256]
Capabilities: [c0] Power Management version 2
Kernel driver in use: C-Media PCI
Kernel modules: snd-cmipci
/usr/sbin/alsa-info.sh

Thanks in advance[/size]

After posting I remembered I had an old sound blaster soundcard and installed it.

After I updated soundcard in YaST, the Mic worked pretty much straight away.

Just a couple of clicks in KMix.

Voila!

Please forgive me if this is a silly question, but do you see any mic option in the Mixer? Did you look at your channel options and enable both the mic, which may be muted and the mic boost if present? Just asking what you do see there for a mic option in your mixer.

Thank You,

Yes the Mic and the options were available. I was aware of those options and tried a fare few combinations to get the Mic to work.

Nothing worked. That’s why I posted.

After swaping the soundcard, it was really a matter of just chosing the Mic in Kmix. No boost needed.

Thanks for the reply.