mic record volume too low

Hi all,
Ive installed skype, and the mic volume is too low. If i talk very loudly, i can hear my voice, but it’s very faint.
The ext mic boost/capture level in KMix is set to about 80%
Running Suse 11.2

My alsa-info file is here: ](http://www.alsa-project.org/db/?f=f7c44c7224a476120fce26646514e9a980fa3061)

Can anyone please advise me? I have to boot into windows everytime i have to use skype, its a real hassle.

The link didn’t show up in the previous post:

maybe this will help, maybe not…in the little application where i
can set the volume coming from my speakers (or earphones) there is
also a slider for mic volume…yours is at 80%, first turn that down
some…like to 20% then look around for something like Mic Boost (+20dB)

on mine it is a radio button (on or off) on the “Switches” tab of my
KMix…but, it is probably a little different on your machine…

anyhow, look closely and if you find it turn it on…and, try your
mic again…i think you might even have to turn it down below 20%,
mine works great at about 2% with the mic boost on, and almost not at
all with that off…

be sure and turn the mic down way below 80% FIRST!!


Well, I’ve enabled all channels in Kmix, and here’s what i have:

IEC958 Default PCM
Ext Mic
Ext Mic Capture
Int Mic
Int Mic Capture

I don’t see any mic_boost option here…

GO into settings in the mixer and you will find lots more.

Here’s the screenshot:

Free Image Hosting by ImageBam.com

And settings has only 4 options, one of which is to configure channels, the rest to configure kmix behaviour.

hdhiman wrote:
> Here’s the screenshot:

the mixer can only access what your sound system and driver will
allow…it could be that your sound system does not not have a mic
boost available…in which case you might be out of luck…

i don’t see where you describe your hardware: but yours would not be
the first i’ve heard about that the mic works GREAT with Windows and
not at all with Linux…you can thank your system hardware maker for
that problem…

i once had a headset with a boom mike that i had to buy a little
external booster to plug into the computer, and then plug the mic lead
into the booster…

actually i still have that headset, it came free in the box with OS/2
Warp 4.0 (or maybe 3.0)


Here’s the hw config, the entire information:


hdhiman wrote:
> http://tinyurl.com/ydw759q

that doesn’t help me at all…already mentioned, that not all hardware
for sale on the planet works with Linux…you need to use google to
learn if anyone has successfully used that mic with linux, any
linux…i recall that once IBM stepped out of the picture it became
more and more difficult to use all hardware with linux…

or, you can try various Hardware Compatibility Lists, like:
and, there are others…

if that way, you learn that your computer’s mic should work without
a booster, then i bet you will find (again via google) how to make it

the best way to ensure good compatibility with Linux is to buy a
machine with Linux pre-installed by the maker, you can get those from
Dell, HP, Lenovo, IBM, Asus, and others…

sorry i can’t be more helpful…


Hi, well, i managed to find some stuff. I found a patch online, i’ve posted the link, Step 1 in the webpage has both the links. It has worked for many Ubuntu users.
But i don’t know how to install the patch in Suse, and more so, whether i should do it.

Conexant CX20549 (Venice) Sound input working!!! « Local Computer Solutions

Afaik, this is for alsa 1.0.19, and mine is 1.0.20

I also found an new script for alsa 1.0.22

ALSA Upgrade Script - Ubuntu Forums

hdhiman wrote:

> But i don’t know how to install the patch in Suse,

all i would know to do is follow the directions given, and see if it

> and more so, whether i should do it.

that is a decision only you can make…you have a (i guess, since you
never said) a built in mic which is not working…but apparently
everything else does…

the best thing that could happen if you try is you get the built in
mic to work, along with everything else…

the worst thing imaginable which might happen if you try and fail is
the mic still does not work, and a whole range of other bad things
that might happen if you blindly flail around ‘trying’ stuff you don’t
understand…the range could be from mic still does not work and
neither do the speakers now…all the way to your machine won’t boot,

so, if i were gonna try i’d first do a complete system backup…
see, it may be possible to get back to where you are today by just
using YaST to reinstall alsa…or, maybe that won’t work…i do not

why don’t keep looking around…i mean, i don’t think it possible that
everyone with that laptop using linux is using a Debian based distro…

alternatively, maybe you should try plugging an external mic in and
see if that works…or, maybe lightweight, folding headset…or a
bluetooth ear accessory (i don’t know if your laptop has bluetooth
built in, or not)…see, THINK of alternatives available to avoid the
broken internal mic and trying the patch…

or just do the patch and see…your machine, your time, your decision…

another option might be to find a forum of Lenovo users somewhere…i
bet there you will find more than one other with Linux installed–that
is, keep looking…


What mic are you trying to use? According to that you have disabled your internal mic and are trying to use an external mic. Is that correct?

Simple mixer control ‘Ext Mic’,0
Front Left: Playback 33 [77%] [19.50dB] [on] Capture 23 [100%] [34.50dB] [on]
Front Right: Playback 33 [77%] [19.50dB] [on] Capture 23 [100%] [34.50dB] [on]
Simple mixer control ‘ExtMic’,0
Mono: Capture [on]
Simple mixer control ‘Int Mic’,0
Front Left: Playback 29 [67%] [13.50dB] [on] Capture 16 [70%] [24.00dB]** [off]**
Front Right: Playback 29 [67%] [13.50dB] [on] Capture 16 [70%] [24.00dB]** [off]**
Simple mixer control ‘IntMic’,0
Mono: Capture** [off]**

Yes, that is because switching onto internal mic doesn’t even capture any sound…records just some static.

OK, I also note from the script you ran …

!!HDA-Intel Codec information

Codec: Conexant CX20549 (Venice)

and I recall the Conexant 5045 was renamed to the to CX20549 (Venice) per Conexant Documentation.

… so if one looks in the HD-Audio-Models.txt file, one can see these options for the 5045:

	Conexant 5045
	  laptop-hpsense    Laptop with HP sense (old model laptop)
	  laptop-micsense   Laptop with Mic sense (old model fujitsu)
	  laptop-hpmicsense Laptop with HP and Mic senses
	  benq		Benq R55E
	  laptop-hp530	HP 530 laptop
	  test		for testing/debugging purpose, almost all controls
			can be adjusted.  Appearing only when compiled with

and so one could try to force one of those options in the /etc/modprobe.d/50-sound.conf file to see if that helps. But before trying that, it would be useful to get more information on your PC audio setup …

Can you provide the output of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
cat /etc/modprobe.d/50-sound.conf

rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -q libasound2

cat /etc/modprobe.d/50-sound.conf

#options snd slots=snd-hda-intel
options snd-hda-intel model=thinkpad

u1Nb.iJWhLrosxI5:ThinkPad T61

alias snd-card-0 snd-hda-intel

This last file i changed a bit upon looking around, but it made no difference in sound setup. Also, i haven’t tinkered with the settings after this change.

Did you try to add more controls from the mixer settings menu?? I accidentally turned off the capture control in alsa mixer and had no mic for a while then playing around in Kmixer I found the capture control was not being shown until I added it from the settings.

Indeed, and thinkpad is the wrong option for your hardware.

I am surprised you have any sound at all.

What would help is for you to delete that file, and then reconfigure your sound with YaST > Hardware > Sound and then provide the new /etc/modprobe.d/50-sound.conf file, so I have a reasonable baseline to use in making syntactical recommendations to fix the file.

Again, thinkpad is NOT the correct model option to be using for a Conexant 5045.

Do you have a reference as to why you believe “thinkpad” is the correct option for your precise hardware?

Here’s the link from where i got the model options:
[ubuntu] snd_hda_intel options database - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1043568)

I also tried to install the kernel-source.rpm, from this link:
SDB:Intel-HDA sound problems - openSUSE

But I didn’t find any file named ALSA-Configuration.txt under:

Well, from what i have, all the channels in Kmixer are enabled.