Mic not detected

First time in Opensuse ( after many years of manjaro, ubuntu,etc…) on a LAPTOP DELL Inspiron 15 serie 7000 → card model → Cannon Lake PCH CaVS

just started it looks ok, but MIC not detected

looked up on the forum , but not solved

Any idea? thank you very much


Please check in YaST → Hardware → Audio if the Sound Card(s) have been configured, or not.

The openSUSE wiki page may also be of use to you for further diagnostic steps…

Check the mic settings in ‘pavucontrol’ as well.

I tried

Quick Automatic Setup . This is the result

The kernel module snd-soc-skl for sound support
could not be loaded. This can be caused by incorrect
module parameters, including invalid IO or IRQ parameters.

Now also audio has been disabled

Thank you for answerung me

The wiki page shows how to run the alsa-info.sh diagnostic script…


This can be run in a terminal and it will upload to an online server, with a link to it provided so that you can share it here. That might help others to advise further.


thank you to anyone

Ok, the audio hardware is reported as

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
	Subsystem: Dell Device [1028:0922]

with the snd-hda-intel driver loaded

!!Loaded ALSA modules


This indicates the mic boost is at minimum…

Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

and not sure which capture device is relevant below but the second one is off (muted)…

Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 39 [62%] [12.00dB] [on]
  Front Right: Capture 39 [62%] [12.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] -17.25dB] [off]
  Front Right: Capture 0 [0%] -17.25dB] [off]

You could investigate with alsamixer (press F6 to select your sound card) and then you can try adjusting as required.

Thank you
Looked up for alsamixer opensuse everywhere , it doeasn’t work the installatron… 1 hour tryng to installare. non solution…

also WINDOWS partition not detected (Error mounting /dev/nvme0n1p3 )

Too many issues…

may be OPEN SUSE too much for me.

Sadly coming back to ubuntu…


Ok, all the best with that.

I don’t know who is better or lucky

may be I’m not so expert but from yesterday i’ve a lot of problem since the beginning

I say it’s no normal spend a l lot of time attempting to install alsamixer without finalize it…may be I’m not so expert for this OS…

All good. Use the distro that works for you. :slight_smile: