mic issue

I thought the mic was about the simplest thing you could plug into your pc, but I can’t get mine to work. It is not even recognized, doesn’t show up in the mixer all the time. I have always checked that nothing is muted.

I don’t know if this is related, but I have tried unsuccessfully to use a usb turntable. I get an error message that, sometimes, says cannot mount /dev/dsp. I get this same message when playing certain videos in mplayer, although they play fine with no sound problems, so I ignore it. Occasionally, I’ll play a video and a series of error messages pop up that say nothing more than “error 153” then “error 401” etc. I made those numbers up because they seem random and don’t affect the actual playing of the video. I ignore them.

suse thinks the usb turntable is a microphone. That’s why I think the /dev/dsp message might relate to my mic problem.

Running 11.1 and kde 4.3 and I zypper up daily.

Setting up a mic on Linux is always a PITA. For the longest time I avoided trying to help users on their mics, as I don’t know it that well myself. But eventually I learned a bit more (not much more) and realized everyone was likely in the same boat, or worse than I, when it came to knowledge of how to setup a Linux Mic.

I recently updated the openSUSE audio troubleshooting guide putting a very small (and very preliminary) section on a Mic here:
SDB:AudioTroubleshooting - openSUSE - configuring the microphone
where in essence it simply refers one to here:
Microphone - openSUSE
and I also updated that microphone wiki, providing advice to try this:

 arecord -vv -fdat foo.wav

and then play with one’s mixer settings.

Note in KDE4 one can add extra channels to one’s mixer.

If you want a more detailed look taken at your settings, then I need more information. In which case with your mixer set up EXACTLY how you think it should be for your mic to work, with your PC connected to the internet, please run twice (1st time as root to update, and second time as a regular user to get the URL) the following diagnostic script:


and post the URL here. Just the URL.

and also provide output of running in a konsole:

rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I note you have KDE-4.3. I don’t provide support for non-stock KDE versions, where KDE-4.1.3 is the “stock” version for openSUSE-11.1. Hence while I agree KDE-4.3 is superior to KDE-4.1.3, if I do not see anything obvious, I am not going to waste my time (nor your time) making up suggestions which may simply not work because KDE-4.3 has not seen the testing that KDE-4.1.3 has seen.

Good luck and I hope that (despite my views wrt KDE versions) still manages to help a bit.

Thanks for the tips. I will try them later today when I have more time to devote. If I get this working my granddaughter, 1,000 miles away, and I will both be grateful to you. :wink:

I’m on my way to getting this to work. I got a response from the mic, but have not yet tried to work it along with a web cam. It seems the simplest answers are the best. (Occam’s razor?)

There is one correction to make. The code calls for lspci --verbose. This failed. What worked was lspci -v. I would edit it but don’t know how exactly and don’t know if this is true on anybody else’s system. I ran it but got no useful info. Nothing referred to a mic. There were a couple of references to my Intel card.

This was the key, although it was not very intuitive. There are no menu options to offer this. A right-click brings up a dialog box with the word channels in it, but no check box for that. I clicked on the word itself and a dialog box popped up with many more available channels. I clicked on **mic **and got a volume control for mic that had been muted. I went back into krecord and tested the mic. I could see the graph moving but heard no sound (Confession time - I had the speakers turned way down :shame: ). I adjusted the speakers but still got insufficient volume unless I pretty much shouted. I went back to kmix and added another channel that I saw the first time: mic boost (20 db). Sure enough, that got me good volume and no distortion in krecord. While in kmix, I added a channel called mic select that seems to indicate I have two microphones. But, it doesn’t matter which I select, the mic works. That channel may come into play if I get my usb turntable working properly.

I didn’t have to run it twice. As root, after it runs, it gives you the option of saving it locally or sharing. When you select share and exit the script, this line appears in the konsole:
One other thing happened when I ran the script. It asked (and I said yes) to update alsa. I find this odd since I zypper up daily. I ran
rpm -qa | grep alsa
and it gave me


Since this appears to be working at the moment, would posting the other output be useful or instructive?

You have helped a great deal. Besides getting mic output, I have learned a bit about sound in suse.

Thanks! :slight_smile:

looking at the script, I can not help but think you ran this BEFORE you had your mic tuned the way you report. … because this script suggests your mixer settings for your mic are wrong. I quote from the script:
!!Amixer output

!!-------Mixer controls for card 0 [I82801DBICH4]

Card hw:0 ‘I82801DBICH4’/‘Intel 82801DB-ICH4 with AD1981B at irq 17’
Mixer name : ‘Analog Devices AD1981B’
Simple mixer control ‘Line’,0
Front Left: Playback 1 [3%] -33.00dB] [on] Capture [off]
Front Right: Playback 1 [3%] -33.00dB] [on] Capture [off]
Simple mixer control ‘Line Jack Sense’,0
Mono: Playback [off]
Simple mixer control ‘Mic’,0
Mono: Playback 31 [100%] [12.00dB] [off]
Front Left: Capture [on]
Front Right: Capture [on]
Simple mixer control ‘Mic Boost ( 20dB)’,0
Mono: Playback [on]
Simple mixer control ‘Mic Select’,0
Items: ‘Mic1’ ‘Mic2’
Item0: 'Mic1’
Simple mixer control ‘Aux’,0
Front Left: Playback 0 [0%] -34.50dB] [off] Capture [off]
Front Right: Playback 0 [0%] -34.50dB] [off] Capture [off]
Simple mixer control ‘Mono Output Select’,0
Items: ‘Mix’ ‘Mic’
Item0: ‘Mix’
Simple mixer control ‘Capture’,0
Front Left: Capture 15 [100%] [22.50dB] [on]
Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control ‘Stereo Mic’,0
Mono: Playback [off]The items I highlighted in RED would give me pause, … but you report it working, so presumably then the items highlighted in GREEN were enough to get the mic functioning.

I confess I don’t believe this. :slight_smile: … I’m thinking it was something else that give you this impression, but not really what you thought … Can you do a screen dump pix if it happens again? Put the pix on a paste site, and post a link to the pix here?

Well, my view is always, if it ain’t broke, don’t fix it. :slight_smile:

That part of the wiki was not put in place by me, but after reading your post I went in to the wiki and did an edit. … I may have gone a bit overboard :slight_smile:
Microphone - openSUSE

I also edited the reference to kmix, noting extra channels can be added for more mixer control.

I ran the script again, saved locally. The only difference is that Mic -> Mono -> Playback was off and now is on. The other items (Line, Aux etc.) remain off.

I never used a paste site for images. Can you suggest one? Also, could the script itself have been what updated?

Thanks. Interesting.

A pastebin site is: pastebin - Type, paste, share.

However the script should upload its output to the alsa site paste section and there should be no need to use a paste bin site.

If one just wishes to share the mixer settings, one can use amixer and curl like this in a terminal (note Linux is case sensitive):

amixer > amixer.txt && curl -F file=@amixer.txt nopaste.com/a

Looking at the line you can see that the command ‘amixer’ is run, and its output is being redirected to a text file “amixer.txt” (instead of being displayed on the screen). Then using " && " the curl command is run which takes the text file and puts it on nopaste.com and then provides the URL of the paste.

I find that an easy way to share one’s mixer configuration.

When the alsa-info.sh script runs, it does immediately check on the alsa web site to see if there is an update to the script. If there is it will tell you there is an update to the script, and one can then choose YES to update. However if one is running the script as a regular user, the update of the script will fail because the script is located in /usr/sbin and one needs root permissions to change anything in that directory. Having the script update of itself fail is no big deal. It can be rerun any time with root permissions so as to be updated.