MIC doesn't work in openSuse 11.0

Hi guys. Im using openSuse 11.0 (64bit) on my pc. My problem is that my mic isnt working. It works on winblows so I know that the hardware works. However I dont here anything when the mic is connected in suse 11.0.

rpm -qa | grep alsa returns the following

alsa-plugins-1.0.16-57.1
alsa-tools-1.0.16-47.1
alsa-devel-1.0.16-39.1
alsa-firmware-1.0.16-24.1
java-1_6_0-sun-alsa-1.6.0.u12-1.2
alsa-utils-1.0.16-35.1
alsa-oss-1.0.15-48.1
alsa-1.0.16-39.1
alsa-oss-32bit-1.0.15-48.1
cairo-dock-alsaMixer-1.6.3-3.pm.20081109
alsa-plugins-pulse-1.0.16-57.1

rpm -qa | grep pulse returns

pulseaudio-module-x11-0.9.10-26.5
pulseaudio-esound-compat-0.9.10-26.5
libpulse0-32bit-0.9.10-26.5
libpulse-mainloop-glib0-0.9.10-26.5
pulseaudio-0.9.10-26.5
libpulse-browse0-0.9.10-26.5
pulseaudio-module-gconf-0.9.10-26.5
gstreamer-0_10-pulse-0.9.5-54.1
libpulsecore4-0.9.10-26.5
vlc-aout-pulse-0.9.8a-1.1
pulseaudio-utils-0.9.10-26.5
libpulse0-0.9.10-26.5
pulseaudio-module-bluetooth-0.9.10-26.5
alsa-plugins-pulse-1.0.16-57.1
pulseaudio-module-lirc-0.9.10-26.5
pulseaudio-module-zeroconf-0.9.10-26.5

rpm -q libasound2 returns

libasound2-1.0.16-39.1

cat /etc/modprobe.d/sound returns

u1Nb.3CqPijR+eOE:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

uname -a returns

Linux fuzzylogic 2.6.25.18-0.2-default #1 SMP 2008-10-21 16:30:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

Pleeeeese help guys pleeeeeeeeeeease. :frowning:

Internal mic (ie in a laptop) ? or an external mic that you plugged in the mic jack?

Could you also run this diagnostic script by copy and pasting the following line to a gnome terminal or kde konsole (you need wget installed) with your PC connected to the internet:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

That will give you a URL when it is complete. Please post here the URL it will give you. Just the URL.

its an external mic. Its my desktop :frowning:

yep i ran that script u gave me and got this url

http://www.alsa-project.org/db/?f=e21d4758d0cdd8dadccd8f19ba651ba981a4ff48

And thanks in advance :slight_smile:

OK, thanks.

From the script I note this re: your mixer:!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xb5100000 irq 22’
Mixer name : ‘SigmaTel STAC9221 A1’
Simple mixer control ‘Input Source’,0
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: ‘Mic
Simple mixer control ‘Input Source’,1
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: 'Front Mic’I don’t have your hardware, so I need to speculate a bit. Did you try the “line” setting? also didyou try reversing the “front mic” and “mic” settings?

I note your PC has a stac9221 from the script:

!!HDA-Intel Codec information
!!---------------------------
Codec: SigmaTel STAC9221 A1

I searched the alsa web site re: the stac9221 and stac92xx and noted 1.0.16 appears to have the latest update for the stac92xx (although sometimes the updates are not so obvious). The autoprobe does work better in 1.0.19 of alsa.

Still, lets try work with 1.0.16 of alsa. … I note from the ALSA-Configuration.txt file for 1.0.16 of alsa the following list of model options for the stac9221:

	STAC9220/9221
	  ref		Reference board
	  3stack	D945 3stack
	  5stack	D945 5stack + SPDIF
	  intel-mac-v1	Intel Mac Type 1
	  intel-mac-v2	Intel Mac Type 2
	  intel-mac-v3	Intel Mac Type 3
	  intel-mac-v4	Intel Mac Type 4
	  intel-mac-v5	Intel Mac Type 5
	  macmini	Intel Mac Mini (equivalent with type 3)
	  macbook	Intel Mac Book (eq. type 5)
	  macbook-pro-v1 Intel Mac Book Pro 1st generation (eq. type 3)
	  macbook-pro	Intel Mac Book Pro 2nd generation (eq. type 3)
	  imac-intel	Intel iMac (eq. type 2)
	  imac-intel-20	Intel iMac (newer version) (eq. type 3)
	  dell-d81	Dell (unknown)
	  dell-d82	Dell (unknown)
	  dell-m81	Dell (unknown)
	  dell-m82	Dell XPS M1210

Hence what you could do is try each of those model options, one at a time, until you find one that works for your PC. … You need to apply the option into your /etc/modprobe.d/sound file.

However when I went to make a sample recommendation for an example of the very specific syntax you need to apply to that file, I noted you did not provide the correct output of “cat /etc/modprobe.d/sound”.

So please try that again, and provide the correct output of:
cat /etc/modprobe.d/sound

Thanks!

this is what cat /etc/modprobe.d/sound returns

options snd slots=snd-hda-intel

u1Nb.3CqPijR+eOE:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

Sorry for the late reply and thank you so much for your help.

Hence what you could do is try each of those model options, one at a time, until you find one that works for your PC. … You need to apply the option into your /etc/modprobe.d/sound file.

Compared to you Im still a noob. I’d appriciate it very much if you could show me how to do this. Do i need to restart the machine after each change or would simply an init 3 and then init 5 suffice?

Oh and I forgot. My Motherboard is intel D945GNT.

Again… Thank you so much for your help :slight_smile:

OK, lets say you wish to try the item in the list called “3stack”. Then edit your /etc/modprobe.d/sound file to look like this (note I added a line), and save the change:

options snd slots=snd-hda-intel
options snd-hda-intel model=3stack
# u1Nb.3CqPijR+eOE:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel 

… then restart your alsa sound driver by typing su -c ‘rcalsasound restart’ and enter root password when prompted and also restart your mixer. Then test your mic.

Assuming that does not work, try another item in the list, … say “5stack”, … you do so by replacing “3stack” with “5stack” such that the /etc/modprobe.d/sound file looks like this:

options snd slots=snd-hda-intel
options snd-hda-intel model=5stack
# u1Nb.3CqPijR+eOE:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel 

… then restart your alsa sound driver by typing su -c ‘rcalsasound restart’ and enter root password when prompted and also restart your mixer. Then test your mic.

… and keep doing that for each item in the list that I provided in an above post.

can someone help me too, my link is :

http://www.alsa-project.org/db/?f=fca09de483ac5559f660659d131bcf2c899ec391

thanks a lot in advance :\

Again sorry for being late. I tried all the options and restarted the sound driver just like u said and tested the mic each time it restarted. Still it doesnt work. This is driving me nuts!

Pleeeeeeeeeaaase help :frowning:

My best recommendation is to relax. Mellow out. Go to a movie … Really, computers are not worth getting upset over. They are definitely not worth being driven nuts over. There are far far more important things in life. … Honest! … when I find the PC does not work for me, … I just walk away … and come back when it is less important in the scheme of things …

Anyway, you could consider updating your version of alsa sound driver to a newer version. Since its been a while since you answered, how about an update as to what you have installed. Please provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
and I’ll provided some suggested commands for updating alsa

Please start a new thread. Trying to support you and harindaka on the same thread will only lead to confusion.

Hmm hey thanks oldcpu. Sorry cudnt reply sooner but the thing is I suspect this is an alsa problem. I tried live CDs of Ubuntu 9.04 and even opensuse 11.2 Milestone 2 (Which I bet has the latest alsa). Both distros have the same problem with my onboard intel sound card. So I doubt updating alsa on my openSuse 11.0 would fix things. Im almost certain now that its an alsa bug since two distros gave me the same result and when I removed pulse audio and used OSS, the mic worked (but there was a delay between me actually speaking into it and hearing the sound in my headset). I think that alsa doesnt detect the right settings for my card. Oh and all the threads I came across with ppl using the same inel sound card and have the same problem… not a single thread got solved. Believe me I viewed atleast 50 threads but not a single one got solved

So I went ahead and tried something different. I had an old CMedia sound card lying around and connected it to a PCI slot, disabled the onboard intel sound via BIOS and switched the machine on. Presto! my sound worked without even configuring a thing. Even the mic worked. All I did was switch the mic on from gnome alsa mixer.

Anyway later I removed the intel sound card entry which was at index 0 from yast > sound and let it configure the CMedia card to be the default (index 0)

Life is good again. But now I face another prob. When talking in skype the people at the other end complain of a loud hiss and that they cant hear me properly. They ask me if its raining lol.:D. But the thing is I cant hear anything like that in my headset where everything is clear… Any Suggestions?

Sorry, I do not use Skype.

Thats OK man. You’ve been a great help already :D. Btw I solved my issue with the mic. When I restarted my pc i found that skype which worked right after installing my new sound card refused to work. It displayed an error message “Problem with audio playback” when trying the test call feature. After some googling I found out that pulseaudio didnt quite agree with skype. So i killed the pulseaudio process and clicked the test call again. It Worked! I enabled mic boost via gnome alsa mixer too. No hissing now. Quality sounds all around. Skype works too after restarting even though I didnt remove pulseaudio. Just killed it and initiated the test call. Anyways my problem’s solved! Thanks a bunch! I owe u one :smiley: