Mic broke - sound still works

I have had the mic working on my laptop until yesterday. I updated KDE 4.2 to the current Factory for version 11.1 x64. I also added a few video related codecs.

I have gone back to the “Resolve your multimedia issue in 10 easy steps” and have tested the mic with arecord. All dependencies for xine1, alsa, etc. seem fine.

Are previous builds of KDE4 Factory available that I can downgrade to?

I am not sure if one of the other codecs have caused conflicting libraries to be installed.

I have included ALSA info link (below).

Any help to determine the issue and get the mic working again would wonderful!



Thanks. Your mixer settings do not look correct. Please take a closer look at your mixer. There are some settings there that may be blocking your mic.

Please also provide the output of:
rpm -qa | grep alsa
rpm -qa | grep plus
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I checked the mixer settings. I was able to get the mic to record again but it is very distorted. Actually, I am using Input Source (Mic) and Capture to achieve mic recording. This doesn’t seem like it should be correct. Mic and Front Mic settings don’t have any effect on the mic as it would seem it should.

Output of the other things are below.

Thanks for your help!

rpm -qa | grep alsa


rpm -qa | grep plus


rpm -q libasound2


uname -a

Linux linux-32we #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

catoptions snd slots=snd-hda-intel,snd-hda-intel

u1Nb.Yt6oDjuomQ5:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

moNa.69B6GgQyZCF:Radeon HD 3870 Audio device

alias snd-card-1 snd-hda-intel

The above alsa rpm list is not good. You have stock alsa rpms mixed with an alsa-driver-kmp-default from the repos. IMHO you should be consistent, and if you are going to use that alsa-driver-kmp-default, then you should also update to the corresponding git versions of alsa-oss, alsa-oss-32bit, alsa-utils, alsa, alsa-devel, alsa-plugins, alsa-plugins-pulse and libasound2. If it were me, I would also install alsa-tools.

Reboot and test after updating.
There is general guidance for updating alsa here:
Alsa-update - openSUSE

Alright. Things are up and running.

I had followed that ALSA-update link a few days before. I assume with the state of my packages that it installed some other missing packages but didn’t update the standard ones to the PackMan repo.

In KDE4 the channel that should be controlling the mic is the MIC channel, correct? Why doesn’t that seem to be working? Am I missing some other configuration?

Thanks for your help!

ok, great, … I assume that means you have some sort of functionality with your mic ?

I don’t know. In KDE4 you can add extra mixer settings via one of the menu selections. … But as to which of the settings is correct for your PC ? I don’t know. I think this is very hardware dependant, and its the sort of question one needs to ask either someone with the same hardware (who has this working) or ask a developer.

Yes. The mic is working. I just updated to the new update kernel 2.6.7-19 and corresponding ALSA updates.

It is capturing more ambient noise (fan and other noise in the room) than I would expect. But it is working.

Thanks for your help!

Great! Glad to read its working.