meta4 / IETF metalink file broken to download openSUSE 11.4 RC2 ?

Have somebody else tried to download openSUSE 11.4 Release Candidate 2 (11.4 RC 2) using the new version of Metalink (meta4 / metalink version4 / IETF Metalink) ?

Both on the standard
Download openSUSE 11.4 RC 2
and on
the download.openSUSE mirrorlist server
seems to be broken metasums if I use Firefox, DownThemAll! and the metasum (or metasum4).
(I have tried with both pages/links on my 11.4 system [to download the GNOME 32bit iso] and and the first one on my 11.3 system)

But the old metasum (meta3, metasum version 3) seems to be unbroken (tested on the GNOME live CD iso image).

The broken/false (first of 12) mirror/‘original’ address seems to be:

instead of (I guess):


openSUSE-GNOME-LiveCD-Build0012-i686.iso.meta4 in the End of the Code:

<url type="bittorrent" preference="100"></url>

    <!-- Meta URLs -->

    <!-- Found 18 mirrors: 0 in the same network prefix, 0 in the same autonomous system,
         3 handling this country, 5 in the same region, 3 elsewhere -->

    <!-- Mirrors in the same network (xxx): -->

    <!-- Mirrors in the same AS (xxx): -->

    <!-- Mirrors which handle this country (DE): -->
    <url location="de" priority="1"></url>
    <url location="de" priority="2"></url>
    <url location="de" priority="3"></url>

    <!-- Mirrors in the same continent (EU): -->
    <url location="at" priority="4"></url>
    <url location="ch" priority="5"></url>
    <url location="cz" priority="6"></url>
    <url location="fr" priority="7"></url>
    <url location="gr" priority="8"></url>

    <!-- Mirrors in the rest of the world: -->
    <url location="jp" priority="9"></url>
    <url location="us" priority="10"></url>
    <url location="jp" priority="11"></url>


I will try to make install of this to my laptop.

I have now just

  1. looked at the the meta4 file of the stable version (11.3) -> in my amateurish view I see not difference to the not working one of 11.4 RC2
  2. opened just for fun in a stupid way the 11.4 RC2 with the GNOME “open with” and choosing ‘/usr/bin/aria2c’ -> this gave me (in a bit ‘ghostly way’) after ca. 8 minutes a file on /home/savesurfer/openSUSE-GNOME-LiveCD-Build0012-i686.iso
    So ether aria2 has fallen back automatically on the working mirrows/is using the file just as a bittorrent file or DownThemAll! is buggy/is not ideally configurated in using not only the mirrors but also the original server under
<url type="bittorrent" preference="100"></url>


Funny thing but if DownThemAll! is working it is in my view an ideal way to get a checksum-tested image for a user who is not experienced with Linux based systems.

puzzled pistazenfresser