Meta+Shift+Tab doesn't work in KDE Leap 42.2


The Meta+Shift+Tab short cut does not work in openSuse Leap 42.2.

I want to have it set to walk backwards through the activities. Meta+Tab for walking forward through the activities works fine.
I had the problem already with openSuse Leap 42.1 as mentioned here, but could never solve it and it is still not resolved.
I tried for hours to check all shortcut settings for all programs I could find to make sure no other software is grabbing the wanted short cut, could not find any cause for my problem. Although I read many discussions about not working shortcuts Google did not give me any working advice either.

My configuration is correctly set via
Configure Desktop-Desktop Behavior-Activities-Switching-Shortcuts
to the two mentioned combinations for walking forward and backward through activities. It is also correctly shown in
Configure Desktop-Shortcuts-Global Shortcuts-Activity switching-Walk through activities and …-Walk through activities (Reverse)
but the backwards shortcut (Meta+Shift+Tab) does not work.

I tried another Meta combination, Meta+F and Meta+Shift+F, they worked fine for the two directions.

To me it seems something in the system outside the obvious KDE mechanism grabs the Meta+Shift+Tab and makes it useless by that.

Does anybody have an advice how to solve this or hunt down where and how the configured shortcut “gets lost”. For me this is a very annoying issue which I try to solve for many months now without any success yet.

Comment #1 from this bug report might still be relevant perhaps?

How and where can this be addressed to give it a better momentum to find a solution?

This problem exists already too long and it doesn’t seem anybody is working on fixing it. I would like to see that changed. I assume it won’t be that difficult if somebody who has the right background looks into it.
From a KDE user perspective I could not find anything working how to tackle this problem which is disappointing.

I’m only a user myself and appreciate that long standing bugs can be quite frustrating. Unfortunately the developers, all of whom volunteer their time, probably don’t regard this as a high priority bug. As to whether it is a trivial fix or not, I don’t know.

If you have any additional information that may help then you could add to the bug report ( ), or if you believe it to be more appropriate, create a new report. ( )

Seems to be fixed with Leap 42.3, at least on this system . . . – Plasma Framework version 5.32.

Hm, sounds promising. I wanted to open a new bug report under the mentioned KDE forum, but in this case I will wait for the next Leap version and hope you are right and the issue is solved there. Would be great.
Thanks for the hints.

You could try to use the Leap 42.2 KDE Frameworks 5 LTS repository:
Be aware that, you’ll have to change all of KDE – everything that’s KDE – including things such as “plasma5-desktop” – to use this “LTS” directory.
[HR][/HR]Don’t know the actual status of this “Long Term Support” (LTS) repository – maybe this Forum’s administrators will be able to provide an answer.


I freshly installed OpenSuse Leap 42.3 and I can confirm that Meta+Shift+Tab to walk backwards through the activities works without any issues there.
That does not solve the Problem in Leap 42.2, but it’s a solution for me.

Thank you for your suggestions.