Messed up my nvidia graphic card configuration

So I recently got an older graphic card installed (NVIDIA Corporation G84GL [Quadro FX 570] (rev a1) according to lspci) in order to have dual monitor setup.

The card worked relatively fine, I decided to try nvidia drivers. I installed drivers http://opensuse-community.org/ (actually I extracted repo from http://opensuse-community.org/nvidia.ymp and added it manually I also uninstalled x86-video-nouveau) then installed the same package the file set. I tried Geforce 400 driver, after restarting it did not work (also plasma was crashing after logging in). I then tried other packages, but neither worked.

At the end I uninstalled all of them and installed x86-video-nouveau back, but after rebooting the login screen appears, but as soon as I logged in computer froze.

Since then I followed https://en.opensuse.org/SDB:NVIDIA_the_hard_way and this time KDE works again, there are some glitches though. Mainly the lock screen (the login screen works fine) is EXTREMELY slow.

Any idea what could be the problem?

Don’t understand why you uninstalled nouveau. You don’t need to :stuck_out_tongue: So have no idea what you did to the system

That is an old card and the driver appears to be old also (304.117) and I doubt is works with the new kernels. I don’t know if if newer NVIDIA drivers support that hardware but NVIDIA tends to drop support after about 5 years ±.

Probably the easiest way to get the system back is to install again but select upgrade.

I uninstalled it as an alternative to blacklisting the driver (my understanding is that novueau is conflicting with nvidia driver).

Perhaps this might help locate the problem. I created another user and after I logged in to that account the locking works fine, so perhaps the configuration got corrupted when trying to use different drivers?

Since it might be user configuration issue, the reinstallation might probably not help.

If a different user then works it is in a user config file. Nouveau does not use user configs but there may be setting in the desktop. Nvidia-setting by default saves some settings in a file in user area (~/.nvidia-settings-rc)

So which desktop? If the above does not work

I mentioned nouveau because wanted to state everything I did.

Now it looks like something got corrupted when plasma was crashing. I think probably the easiest thing will be to maybe remove configs and repopulate by hand things that I’m missing.

Maybe. You know where the Desktop configs are?? ~/.confige At least in KDE