Messed up booting selection

Seems I have messed up something.

I can boot into openSUSE and into Vista, so it is not screwed.

I have 1 hard disk
I have an OEM Vista (so a 9 GB EISA rescue partition),
the Vista partition (~100GB) and the 3 partitions for openSUSE (2/20/467).

Before just wiping the linux partitions I tried to switch back to M$ booting but failed.
ATM I boot to splash screen showing 3 entries: 2 openSUSE and 1 windows.

When I choose Windows I get to the next screen showing Windows and - ubuntu (I had ubuntu via wubi before but wasn’t convinced, so (w)ubuntu does not exist anymore).
I thought installing openSUSE will fix the issue that ubuntu shows up on M$ booting screen but ofc I was wrong.

I didn’t want to wipe the still unused openSUSE partitions before being successfull so instead I tried:

  • booting into M$ rescue CL: bootrec /fixmbr does not give an error but bootrec /fixboot or /rebuildbcd - automatic system repair does not show any partition, fixboot /scanos finds C:
  • using bcdedit and EasyBCD (fail)
  • booting into openSUSE and fix it with YAST (restore MBR but skipping Step 1 from the tutorial as I can boot successfully)

Now I’m unsure how to proceed.

Maybe I should point out what I want:
1st the Windows selection style (default boot into Vista)
2nd to choose the Linux boot options (grub)

What should I do next?
How do I fix this?

TIA

First question: I cannot read clearly whether both Vista and openSUSE do boot and run. Do they?

On openSUSE open a terminal window and post output here of commands below


fdisk -l
su -c 'cat /boot/grub/menu.lst'
(enter rootpassword when asked for)

From what it looks like your openSUSE GRUB links to the Windows bootloader, which still has the entry for Ubuntu in it.
Don’t know if you can load openSUSE’s GRUB from the Vista bootloader. If I were you I’d rather boot Vista straight from GRUB (I don’t boot Vista at all), no Vista bootloader at all.

Vista and openSUSE do boot and run.

I can NOT load openSUSE’s GRUB from the Vista bootloader.

If I were you I’d rather boot Vista straight from GRUB (I don’t boot Vista at all), no Vista bootloader at all.

Ok, how to get rid of it?

output of fdisk -l


Platte /dev/sda: 640.1 GByte, 640135028736 Byte
255 Köpfe, 63 Sektoren/Spuren, 77825 Zylinder
Einheiten = Zylinder von 16065 x 512 = 8225280 Bytes
Disk identifier: 0x2b3cbecd

   Gerät  boot.    Anfang      Ende     Blöcke   Id   System
/dev/sda1              1      1176     9437184   27  Unbekannt
/dev/sda2           1176     13924   102406244    7  HPFS/NTFS
/dev/sda3   *      13925     77825   513284782+   f  W95 Erw. (LBA)
/dev/sda5          13925     14186     2104483+  82  Linux Swap / Solaris
/dev/sda6          14187     16797    20972826   83  Linux
/dev/sda7          16798     77825   490207378+  84  Linux

output of cat /boot/grub/menu.ls


# Modified by YaST2. Last modification on Do Mär 11 23:41:50 CET 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-WDC_WD6400AAKS-07A7b0_WD-WMASY5286256-part6 resume=/dev/disk/by-id/ata-WDC_WD6400AAKS-07A7b0_WD-WMASY5286256-part5 splash=silent quiet showopts vga=0x31a
initrd /boot/initrd/2.6.31.5-0.1-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-WDC_WD6400AAKS-07A7b0_WD-WMASY5286256-part6 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga =0x31a
initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,1)
    chainloader +1

Addition FYI:
I just used my Recovery DVD and did an automatic repair.

So grub is gone now and PC boots directly into Vista.

EasyBCD does not fail to launch anymore so I made a Backup of the bootloader settings and changed the line

Windows Vista ™ Home Premium (recovered)

to

Windoof

:slight_smile:

dow in german = doof = dumb :wink: