Message "CUPSToOmni: No pages printed!" ??

Hello,
I just installed OpenSuSE 11.0 on my old computer.
I got a problem with the printer, an old but easy-to-use HP laserjet 1200, which worked perfect with all previous versions of OpenSuSE (I used hplip),
The printer is connected to the parallel port (/dev/lp0).
YaST found it, but the test page can’t even be printed; I get instead the following error message in CUPS:
“CUPSToOmni: No pages printed!”

The CUPS error log says a bit more :
CUPSToOmni: Fatal error: unable to load “libHP_LaserJet_1200.so”, g_module_error returns “libHP_LaserJet_1200.so: cannot open shared object file: No such file or directory”

So I can’t figure what to do.

I’ve got exactly the same problem with a Brother HL730 printer.

And I solved it by downloading a PPD file from OpenPrinting - The Linux Foundation and using that instead of the omni driver.

and where did you put the .ppd file?

This is sort of an old thread and I imagine the original authors have long since solved their problem. But for those who might come behind, I solved it by installing the gutenprint drivers. The default “omni” drivers that were loaded did not work for my Canon i850.