menu font colour on GTK apps in KDE

Opensuse 11.3 with kde 4.4.xx

Having a problem with the menu font colour in GTK apps (firefox & thunderbird).

All menus in all other apps have the correct font colour (black) but as you can see in this screenshot the font colour is white for thunderbird.

http://img412.imageshack.us/img412/4779/fontcolour.th.jpg](http://img412.imageshack.us/img412/4779/fontcolour.th.jpg](http://img412.imageshack.us/i/fontcolour.jpg/)](http://img412.imageshack.us/i/fontcolour.jpg/))

The only way I can find to change the text to black is to change in Configure Desktop > Appearance > Colours
The setting for “selected text” to black.

Now I could be wrong - but I am pretty sure this should not be the setting that effects the menu colour in GTK apps.

Here are the colour settings I presently have

http://img842.imageshack.us/img842/3571/fontcolour2.th.jpg](http://img842.imageshack.us/i/fontcolour2.jpg/)

Anybody have any idea on how to correct this?
Did not have this issue in 11.2

Using QTCurve window style
Have also set GTK Style and Fonts to use QTcurve and KDE font settings.

I do remember QTCurve in Opensuse had a button to apply its settings to KDE3 & GTK apps but this is not present in the QTCurve version on 11.3

should mention that if I click on the menu bar in GTK apps that the drop-down menu list has black fonts.
Found the setting in QTCurve to export settings to qt3 & kde3 apps but does not appear to be there for GTK any more. unsure if this would help my issue anyway.

Changing to a different window style still get white fonts n GTK apps.

So you have some control over GTK in KDE. Go to the KDE menu / Personnel Settings / General Tab / Look & Feel / Appearance / GTK Styles & Fonts.

Have you tried this KDE 4.x option before?

Thank You,

Thanks, but yes. I have already tried this. Making changes to the settings in this window has no effect on the colour.

OK - appears something had become corrupt in Thunderbird and Firefox themselves as creating new profiles fixed up the problem.
Still not sure what caused it - will post an update if I work it out.

In Thunderbird you can go to Edit / Preferences / Display / Formatting Tab / Text Color.

Have you tried this one?

Thank You,

This only has an effect on the messages. Not the toolbar.

I believe it is something to do with QTCurve - when I changed the background colour for the menubar.
Chaning back to original worked in everything except Thunderbird and Firefox so there may be some kind of bug re this setting in QTCurve and GTK apps (can’t test any other GTK apps as that is the only two I have.

In QtCurve you can decide with which colors the menubar are drawn. You can find this in the QtCurve configuration under “Menubars.” Now what you observe here in Firefox, (i.e. that the Menubar foreground-color matches “Selection Text” of your color scheme) can be achieved with setting Coloration to "Selected background.

However, this normally would mean that both foreground and background colors are drawn from SelectedText/SelectedBackground and that they are applied to all applications. And not just the foreground color to gtk+ applications. :\

As to possible solutions to your problem I can think of the following:

  • Check your QtCurve settings for “Menubars” especially “Coloration.” I think the default is “Background”, which means that FF uses ViewText/WindowBackground when you use the Oxygen theme for the Menubars, and the WindowText/WindowBG pair when you use the Default theme.

  • Try out what happens when you change the theme that FF uses. By default there are two: Default and Oxygen. (In FF: Tools > Add-ons > Themes)

  • Try out what happens with and without the option “Apply colors to non-KDE4 applications” (Appearance > Colours > Options)

  • Get a newer version of QtCurve. I have all four QtCurve packages (KDE4, GTK, KDE, WindowDecoration) from here installed:
    Index of /repositories/home:/cornelisbb/openSUSE_11.3

Probably the FF themes. As I said, by default there are two themes: Oxygen and Default. The Default theme is active by default.

When I was playing around with that, I believe I had to save/overwrite the “QtCurve” color scheme before it was applied.

OK - getting there. But whether it is a bug in QTCurve or Mozilla applications I couldn’t say as yet.

When creating a menu background colour in QTCurve it is writing to Firefox & Thunderbird the file userChrome.css
I didn’t have these files previously but understand that they are files that can be created to customize mozilla apps.

Anyway - the content of the file in its entirety is this

menubar > menu { color: HighlightText !important; } menubar > menu[_moz-menuactive="true"] { background-color : HighlightText !important; color: HighlightText !important; } /* Added by QtCurve -- do not remove */

This file is being left behind and remaining unmodified when changing the settings back in QTCurve - so most likely a bug there.

Simply deleting the css file or changing the content fixes the problem up.

I was also having this issue.
The strange things is that I was not using QTCurve on my GTK apps, but oxygen-molecule instead. I did have QTCurve installed and have tried it and modified some options, but that was it. It seems that even not being used, QTCurve was modifying the file you mentioned (located under ~/.mozilla/firefox/xxxxxxx.default/ if anyone doesn’t know where to find it, where xxxxxxx is a random string with numbers and letters). The even stranger aspect of this problem was that the file kept being regenerated on every firefox startup, so simply deleting it didn’t solve anything. I actually removed all QTCurve related packages from my system and now everything is perfect.