mendeleydesktop not installing

Hello;
I try to install the application mendeleydesktop from the opensuse site:

https://software.opensuse.org/package/mendeleydesktop

I use zypper, but I get this message:

Problem: nothing provides libQt5Core.so.5(Qt_5.10)(64bit) needed by mendeleydesktop-1.18-lp150.4.1.x86_64
Solution 1: do not install mendeleydesktop-1.18-lp150.4.1.x86_64
Solution 2: break mendeleydesktop-1.18-lp150.4.1.x86_64 by ignoring some of its dependencies

If I go on installing with Solution 2 the software does not run. The library libQt5Core exists but apparently
it is a different version than needed by the mendeley package.

I cannot find a simple solution, as installing a new version for libQt5Core seems to break many parts of the
system. Is there a simple solution to this?.

Thanks.

Ask the packager or the deveoper. Packages from home:/ repos are not supported by the distro itself and these repos are meant for packagers as a place where they can break things.

I didn’t test or attempt to troubleshoot the package you tried to install.

Instead, I went to the mendeley website and followed the instructions to install the “generic Linux” solution.
Unlike the supported Debian packages and my guess what the package you tried to install does, the “generic Linux” install is a web application… In other words, it runs in a web browser from a mendeley server instead of installing in your machine.

Seems to have full functionality, I explored a few features in the app…

To install the web application…
Open your web browser to the following location and click on the 64-bit link
https://www.mendeley.com/download-desktop/Linux/
or run the following in a command line console

https://www.mendeley.com/autoupdates/installer/Linux-x64/stable-incoming

Extract the contents of the file you just downloaded

tar -xf mendeleydesktop-1.19.2-linux-x86_64.tar.bz2 

Follow the instructions for installing on this page
https://www.mendeley.com/guides/download-mendeley-desktop/linux/instructions

The Mendeley Desktop is not a Desktop as we define in Linux, it’s an overlay application that can run on top of any Desktop you have installed (or for that matter any other OS like MSWindows or MacOS).

TSU

Thank you; the package from the mendeley website works in leap15.0.
Thanks for your help.