mencoder/ffmpeg Audio Video syncing problems

**** Background ****

I have a few videos that I have downloaded, they play fine using mplayer and xine.

I want to view the videos on my Nokia N95. With this in mind i decided to use mencoder to rescale the videos to fit the resolution of the N95.

The N95 plays movies in a mp4 container without bother. The N95 has a screen resolution of 320x240.

**** The Problem ** **

When I use either ffmpeg or mencoder to rescale the movie file to this resolution in a mp4 container the audio and video go out of sync.

I have tried to uninstall and reinstall the mplayer ffmpeg and all the libraries related to these programs, but it doesn’t make a difference.

Has anybody got a scrip that works i have tried to use google and all the scripts that are meant to work fail with the audio and video being out of sync.

Help appreciated

I’ve used the dumpstream command from mplayer to get a
copy of the file, then used ffmpeg as follows for a Treo;

ffmpeg -a <input_file>.avi -sameq -vcodec xvid -acodec mp3 -s
320x240 <output_file>.avi

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 0:36, 1 user, load average: 0.00, 0.04, 0.17
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

You could also try avidemux to rescale (and resync, if necessary).

Thanks people i will try and let you know how i get on :slight_smile:

you will find there is an avidemux forum, and you may find much valuable support there

Avidemux2 Forum

they talked me through changes in file format that was very helpful; avidemux can do many things, so is not intuitive to new users (I found)