Memory Detection

Hi,

I’ve installed Suse:

S Information
OS: Linux 2.6.27.37-0.1-default x86_64
Current user: ross@linux-wyl6
System: openSUSE 11.1 (x86_64)
KDE: 4.1.3 (KDE 4.1.3) “release 4.10.4”

on my samsung laptop.

When I installed it I used a command line argument to specify that it has 4gig of ram (as otherwise it would not install)

When I look at system information it says that there is only 3gig of ram:

Memory Information
Total memory (RAM): 2.9 GB

Does this mean that it is only using 3 gig of the 4 available?

Total memory (RAM): 2.9 GB

You need to install pae kernel and use it.
Open YaST -> software management and search for ‘kernel-pae’ without quotes, and install it. After installation restart your PC with the new Pae kernel and your memory will be detected properly.

BTW, why not use openSUSE 11.2.

what? PAE on a 64-bit system like his?

@MisterEd, this has been addressed a few times, do a little search on the forum

Thanks for the reply!

I installed 11.1 a couple of months ago when it was the latest available, I’ve only now noticed the memory issue.

Is it easy to update to 11.2? My machine is duel boot with windows vista and I don’t really want to mess things up.

If there’s a simple guide to updating then that would be really useful.

Also what does updating to the newest version actually do?

  • Does it just update the linux kernel and hidden things that make it all work?

  • Or will it update all my progs to more recent versions if available too?

I’m a little new to this so as much info as poss would be great!

Thanks again!

the whole system is updated, not just kernel and “hidden things”. It’ll do fine with your Windows and KDE4 has seen major improvements compared to your aweful 4.1.3 version. How to update? Search the forum a bit :wink:

Sorry, misread the post.

I will not personally advise to upgrade to 11.2 from 11.1, as the chances are it will mess up the things.
There is no issue with fresh/new installation of 11.2 with Vista/7.
You can follow this guide to installa 11.2.
Dual boot: openSUSE 11.2 installation with Windows 7 - openSUSE Forums