MediaTomb config file error

Now I can see some default blank folders on the Samsung TV, very encouraging!
However when trying to start Mediatomb I’m getting the following error:

2014-06-26 23:28:16    INFO: Loading configuration from: /home/username/.mediatomb/config.xml
2014-06-26 23:28:16   ERROR: Error parsing config file: /home/username/.mediatomb/config.xml line 42:
mismatched tag

I also by chance actually executed the .xml file and it says:

error on line 42 at column 13: Opening and ending tag mismatch: storage line 0 and server

Examining the config file using that info puts me right at the closure tag for the server section.
Line 42 is Column 13 puts it as the next character after the > character in that line.
There is no actual character there unless the Carriage Return counts. lol… is that still what it’s even called?
I tried inserting just a LF instead of a CR after the tag and then putting 3 spaces in to line up the tag.
But it didn’t seem to help.

<?xml version="1.0" encoding="UTF-8"?>
<config version="2" xmlns="" xmlns:xsi="" xsi:schemaLocation="">
    <ui enabled="yes" show-tooltips="yes">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
    <ui enabled="yes" show-tooltips="yes" poll-interval="2" poll-when-idle="no"/>
      <storage caching="yes">
      <sqlite3 enabled="yes">
      <mysql enabled="no">
    <protocolInfo extend="no"/><!-- For PS3 support change to "yes" -->
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
      <add header="X-User-Agent: redsonic"/>

    <!-- Uncomment the line below if you have a Telegent TG100 -->
      <ffmpegthumbnailer enabled="no">

Anyone have an idea what I’ve done to jack up the <server> section of my config file?
I don’t know much but I cut n’ paste well, can follow directions and can pirate code as well as any ol’ M$ founder. :wink:
Thanks for any advice on the config file!

If I count everything right, than your “storage” section has two opening tags but only one closing tag:

      <storage caching="yes">


On Fri, 27 Jun 2014 04:06:02 +0000, SomeSuSEUser wrote:

> Anyone have an idea what I’ve done to jack up the <server> section of my
> config file?

You’ll probably want to paste it using or at least inside
code tags here for it to be readable.

I’d be inclined to open it in an XML-aware editor like Komodo Edit -
usually that kind of error message means that there’s a tag mismatch
(beginning/ending tags that overlap, for example) that’s causing the file
to be parsed incorrectly. An XML-aware editor will be able to show you
where that problem is so you can fix it.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at