Mediaplayback crashes X.

Sometime during the last few weeks a bug has entered my suse 11.1 system. It manifests itself in following way: I start playback of a videofile or open my webkam with cheese and X crashes without any meaningful messages. I can view flash video, but playback of other videofiles leads to a crash. I’m to much of a simple user to know how to figure this out myself, so I hope there is a kind soul out there willing to help.

I have no idea where to start looking for clues, so if there are capable men or women out there, just tell me what to look for and I’ll dig it out of my computer.

First thing to consider is if you use desktop effects. If yes, turn them off and try again.
Report back either way.

X crashes even without desktop effects.

You need to provide more info on your PC, spec, graphics
kde? gnome?


zypper lr

(lets see what repo’s you are using)

zypper lr provides the following list:

arnt@tabby:~> zypper lr

| Alias | Name | Enabled | Refresh

1 | Enzokiel_bluetooth1 | Enzokiel bluetooth1 | Yes | Yes
2 | Heim | Heim | Yes | Yes
3 | KDE4_QT_1 | KDE4 QT | Yes | Yes
4 | KDE4_community | KDE4 community | Yes | Yes
5 | KDE4_extra_apps_1 | KDE4 extra apps | Yes | Yes
6 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes
7 | Malcom_bluetooth | Malcom bluetooth | Yes | Yes
8 | Xorg | Xorg | Yes | Yes
9 | openSUSE_11.1 | Seife Bluetooth | Yes | Yes
10 | repo | openSUSE BuildService - KDE:Backports | Yes | Yes
11 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
12 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
13 | repo-source | openSUSE-11.1-Source | Yes | Yes
14 | repo-update | openSUSE-11.1-Update | Yes | Yes
15 | repo_1 | openSUSE BuildService - KDE:Community | Yes | Yes
16 | repo_2 | openSUSE BuildService - | Yes | Yes
17 | repo_3 | openSUSE BuildService - Mozilla | Yes | Yes
18 | repo_4 | Packman Repository | Yes | Yes
19 | repo_5 | openSUSE BuildService - Wine CVS Builds | Yes | Yes
20 | tablet | tablet | Yes | Yes

My computer is a toshiba portege m700 tablet, sporting a x3100 intel chipset. I run KDE 4.2.1 and the qt 4.5 libraries…the problems started before I added the 4.5 repo. I’ve tried changing between the xine and gstreamer backend for phonon and I’ve tried various mediaplayers; mplayer, smplayer, kaffeine, kmplayer…etc…

try disabling xorg
and roll back all the red packages it creates by disabling it
see if that changes anything

you can always enable it again if it doesn’t help.

I switched videodriver in xine and mplayer from xv to Xshm and voila I have video again. If I recall correctly there used to be a problem with the xv video driver for intel chipsets, so I guess this means regression.

Thank you caf4926 for your help, but I dare not remove the xorg repo since that means loosing out on wacom drivers precompiled with the patch that enables touch. I find it such a convenience to have that provided for me by the gods of packaging that loosing out on XV driver is a small price to pay.

No worries. Good to hear you have a solution of sorts.