MediaCore Installation problem: python-dev error?

Hello,

I’m new to this community and hope that I can find help to solve my big problem due to the Installation of the linux software MediaCore v.0.8.2. ( Open Source Video CMS and Podcasting Platform | MediaCore ).

For your information: Root Server with openSUSE 11.1 - Plesk 9.3. Using putty for interaction with the system. Python, gcc, mysql, python setuptools and virtualenv is installed and should work correctly.

I worked along with the MediaCore v.0.8.2. documentation ( Installation — MediaCore v0.8.2 documentation ) and all pre-installations are done. I setup a Python Virtual Environment (Step 1) and go on to Step 2. My server is running python2.6.

When using the command “python2.6 setup.py develop” i get a long error list which ends with:

_imaging.c:3138: warning: return type defaults to âintâ
_imaging.c: In function âDL_EXPORTâ:
_imaging.c:3138: error: expected declaration specifiers before âinit_imagingâ
_imaging.c:3149: error: expected â{â at end of input
error: Setup script exited with error: command 'gcc' failed with exit status 1

Now I need help to solve this problem. I read that it could be the python-dev? But how can I (re)install it correctly?

Or do you know any other source of the error?

Best regards, XPL :frowning:

Hello,

I believe you want to make sure that the python-devel rpm is installed

All the best

yea but how can i do?

Hello Exxplain,

It’s pretty simple.
Just start YaST->Software->Software Management.
Enter “python-devel” in the search bar (without the quotes).
On your right a few packages will appear.
Select the one named “python-devel” and check for install.

If everything went alright python-devel should be installed.

Best of luck!:wink:

P.S. sorry if the package name is slightly different, this could be because I’m not on a openSUSE 11.1 machine.

sounds nice but i have to administrate via SSH & Putty.

so i tried to use apt-get install python-devel or dev etc

but doesnt work

Hello Exxplain,

Sorry, didn’t saw it the first time I read your post.:shame:

But don’t worry you can also do this through the command line.
openSUSE is an RPM based distro so you can’t use apt-get but in this case need to use zypper.
So run this command as root:

zypper in python-devel

You can also start YaST from terminal and go to Software->Software Management.
Just enter this command:

yast2 --install

Good luck!:wink: