media server connection

Dear All,
I am trying to use a media server, as source for media use on tv,hifi installation and as a backup solution for my pc as well.
The device has samba and nfs network capabilities.
Can Anybody advice how to configure a local network?
Thanks in advance

What is the hardware layout of this LAN? And what have you tried so far to mount the media server via nfs?

It is qnap server, especially dedicated to multimedia.Harware, it is just a harddisk 3.5" sata and is logged as a nas server.Is it what you mean ?
I tried already under windows, created a network and been able to connect.
As I am running a dual boot with suse/kde 11.2, I am trying now to communicate as well under linux.
I opened a network (called NMP-1000) but so far unable to communicate with each-other(ip threw DHCP)
I am also confuse about the wording of network type.Indeed, the server call “samba” the microsoft dedicated network type and nfs the linux one.Both are anyway turned on.

Dear All,
Does someone have a second to help on this topic?
Many thanks in advance

Have a read here for your samba setup

Have you looked at running ushare?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 15:40, 2 users, load average: 0.39, 0.14, 0.11
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

I’m not an admin or expert, but now I’ve a little bit experience using a NAS.

  1. Check, if you have the right IP-address of your NAS (via your DHCP, …) and ping it.
  2. did you create a NFS-share on your NAS? (export table) Here you should know which IP-address your client has, or you use the NAS as a DHCP-Server. (if you want to use a range of addresses, read the wiki Classless Inter-Domain Routing - Wikipedia, the free encyclopedia, it was a tip of a forum member, which helped me a lot)
  3. mount -t nfs IP_of_NAS-Server:/complete_path_of_exported_dir /mnt

On my NAS-server I can run a media-server, too. So I can connect my Internet radio to my mp3 collection.

I have no experience at all in network. I dont know what “ping it” mean.
I read the instructions again and been now able to see my linux suse machien from the nas, but cant so fare connect.
From my linux suse machine, I still cant see anything on my domestic network. I have another windows machine, a apple laptop and my nas.
Thanks for your help

ping is a command to check the connection between two net devices.
It’s also available in Windows and Mac-OS. Open a command window and type “ping <ip-address of the other computer>”.

Yes I can ping my nas
Yes I can reach it threw firefox with the same adress (web based interface to configure the nas)
But I still cant see the drive in tree view of dolphin for instance or in the network application.
Any idea of what am I doing wrong
Thank you so much for your help

sorry, I was traveling the last week and had no time left.

Do you have still problems to connect your NAS?


I could connect to my NAS but what I am still missing is the automatic “scan” of the connected devices/pc’s on my local network.
This is still not working or at least, I just don’t know how to.
I have been connecting my NAS because I new the ip adress and gave it manually. But under windows or mac, as soon as I open a browser “network”, every connected machine appears after a few second.
I red a lot about network configuration but it looks pretty complicate.
Could someone give some simple advice ?

I have just read all the posts about your problem and I think what you should do is the following (sort of check list):

  1. Out of the two network filing systems, NFS and SAMBA (SMB), I should chose SAMBA. That is because you already have a MAC and a Windows machine on the same network and they would not know anything about NFS. Hence, you would not be able to access shares on the MAC and/or Windows machine (in addition to the QNAP), if you chose NFS.

  2. Get into YAST and, under Software Management, make sure you have the following SAMBA packages installed:


I am assuming you are on a 32bit machine. If you are on a 64bit machine you will also need to have installed, the 32bit versions of most of those packages. However, if you just select ‘samba’, I think most of the other packages will be installed automatically as dependencies. The yast2 packages above may need to be selected separately.

  1. Unfortunately, the Samba packages v 3.4.3 have a slight problem at the moment, which is due to be fixed in a forthcoming release (3.4.4?). That is the reason for including Smb4k.

  2. After installation of Samba, get into Yast again and, under Network Services -> Samba Server, check the following is set correctly on these tabs:

Start-Up: ‘During Boot’ selected; ‘Open Port in Firewall’ ticked.
Shares: leave alone for now.
Identity: ‘Workgroup or Domain Name’ put in the workgroup used in all the other machines on the network; ‘Not a DC’ selected; ‘Netbios Hostname’ blank;‘Remote WINS Server’ selected; ‘Retrieve WINS by DHCP’ ticked; ‘Use WINS for Hostname Resolution’ ticked.
Trusted Domains: leave alone for now.
LDAP settings: leave alone for now.

Click OK

  1. If you have not already done so, in Yast, under Network Devices -> Network Settings, on the Hostname/DNS tab, put in the ‘Hostname’ you want to call your computer (this is the reason for leaving it blank in Samba).

Click OK

  1. With a suitable editor, as root (su or login as root), locate the file /etc/nsswitch.conf and change the line that begins ‘hosts: …’ by typing the characters 'wins ’ before the first entry (usually ‘files’). Take a backup of the file before you change it. This will allow you to communicate with other machines on the network by Netbios name - e.g. ‘ping win-laptop’. Otherwise you may have to use numerical IP addresses or the more complicated ‘ping $(net lookup win-laptop)’.

  2. Reboot the machine (just to make sure Samba is active) or alternatively check the three tasks smbd (occurs twice) and nmbd are up and running and, if not, start them manually.

  3. As root, change the permissions on /sbin/mount.cifs and /sbin/umount.cifs so that the SUID bit is set. This is for Smb4k (I think it is still required).

As I said, the Samba package appears to have problems at the moment which means you cannot mount shares in Dolphin or Konqueror due to an erroneous authentication dialogue that comes up. See swerdna’s explanation for this. However, the Smb4k desktop applet appears to work correctly (Menu -> System -> Network - Smb4K).

Hope that gives you some idea what to do. After you have got it working, you should re-consider all the security aspects again.

Good luck.

PS I see that QNAP support iSCSI and that there is a facility in Yast for that (which I have never used). If the above does not work you could have some better luck with iSCSI. p.

Dear plodder,
Well. My machine is down…
I tried to install the last package, smb4k, and my sytem aborted, “missing disc space”. Got to yast, partioning, canceled an empty partition and increase my / partition of a few Go. But since that, there is system file problem in the partition. The repair cd couldn’t fix the problem either.
Is it another way to fix the problem? Maybe this is not really your cup of tea and I should open a new thread, just tell me.

This does seem to be a separate issue from that of trying to access your NAS. Thus I would advise you to open a new thread possibly under the Install/Boot/Login forum. Try and give as much relevant information as possible, especially which system file is in error.

When you have fixed that, return to this thread and continue the discussion on Samba.

Good luck.