media not working

I am a very new user and am in the process of setting OpenSUSE up for the first time. I soooo want to get rid of Windows. I have now scrapped OpenSUSE about 4 times and through much reading of the forms have gleaned a ton of information that has at least got me to where I currently am. Fully installed with sound. However I can not play any media sound files or DVD movies. System sounds work fine.

I am unsure of the data you may require for assisting me with this headache of situation.

I am currently running a Pentium D processor
with an older Soundblaster Audigy card.

I have downloaded all the codex i can find and a program that “OlderCPU” (think that was his name) recommended to someone else I believe it was “VLC”. I would prefer to run Banshee and Totem but will make due with what ever I can get running at this point.

Note: just found another msg from “oldcpu” and downloaded/installed Xvid… that helped a little at least now the bar that shows the movie is moving… sound no… picture no… but even the moving is something.

not sure if this will work,but, have you tried mplayer ? normally works OOTB with multimedia. should be in the repo or on your install media


well with Mplayer, have some picture (on those that actualy load) but no sound. and no I hadnt tried it before. well Ive been at this for over 9 hours now think I’ll turn in now and see what transpires later. thanks for tonight though.


The first thing you should do, if you have not already, is setup your repositories for your software package manager with OSS, NON-OSS, Main Update, and Packman. I recommend you remove all other repositories. Additional repositories are not for newbies (IMHO) as it just confuses them.
Repositories - openSUSE-Community

After you have your repositories setup, ensure you have installed necessary codecs. That includes w32codec-all.

You did NOT state which openSUSE you are using, nor state if you are using “special desktop effects”. Special desktop effects are known to cause video play back issues. One’s choice is typically to disable desktop effects, and in their multimedia player select ‘auto’ or ‘xv’/‘xvideo’ as their video output module, or if one wishes “special desktop effects” and video, then select ‘x11’.

As to how much of that is applicable to you, I don’t know as you did not provide enough detail on your PC openSUSE/desktop configuration.

Have you been here? Restricted Formats - openSUSE-Community

sorry, just got home and read the forums…

running OpenSUSE 11, with Gnome UI
running on a modified HP Pavilion a1613w

PentiumD 820 (S) DC 2.8 GHz

  800 MHz front side bus
  Socket 775
  Asus P5LP-LE motherboard
  250G Sata HD
  80G Ata Hd
  500G HP one touch exteranal
  2G dd2 memmory
  Nvidia 8600 GTA 512 Video card
  Creativelabs SB Audigy PCI (orriginal not the audigy2)
  16X DVD(+/-)R/RW RAM (+/-)R DL LightScribe drive

with the last 2 suggestions I am now down to Codex issues only. mainly trying to get some M4P., Xvid MPG4. WMV, and a few AVI files to play. I am getting picture but no sound or sound and no picture. also on the M4P no sound at all… havent found any sollutions outside of this forum so not sure but what ill have to wait to get them working.

I appreciate all the wonderful suggestions that have gotten me to at least where I am now. I may be new but I catch on fast and with your help have been learning a lot lately :slight_smile:


missed a question.

application switcher, additions- enabled scale and wobbly
animations, Vacuum, Burn and Magic lamp

the rest are at default

Try running vlc from a terminal window then try to play your video. Are there any error messages coming up in the terminal window? If there are not try running vlc in the terminal window with vlc -vvv and that will give more information.

Thread moved to Multimedia