MCP55 (nVidia) Audio Stopped Working

64-bit ASUS X2 motherboard with onboard sound.
Suse 11.0
Packman OSS repositories installed

Sound was initially working (but very low).

After last updates sound is completely non-existant.

Tried deleting driver and rebooting, reinstalling.

Tried setting all mixers to high (had done that previously when I had some sound).

Tried reinstalling all recommended codecs from packman.

Test sound does not work.

Additional info: This is a GNOME System

I followed the instructions here, but nothing worked:

SDB:AudioTroubleshooting - openSUSE

jabailo@75-92-212-161:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2.731398
0 - Front Left
1 - Front Right
Time per period = 2.986666
0 - Front Left
1 - Front Right
Time per period = 2.986651
0 - Front Left
1 - Front Right
Time per period = 3.071929
0 - Front Left
1 - Front Right
Time per period = 2.986657
jabailo@75-92-212-161:~>

75-92-212-161:~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.16rc2 (Thu Jan 31 16:40:16 2008 UTC).

75-92-212-161:~ # cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfe024000 irq 21

75-92-212-161:~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.16rc2 (Thu Jan 31 16:40:16 2008 UTC).

alsaconf did not fix.
alsamixer showed all PCM and Master settings at 100.

75-92-212-161:~ # cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

75-92-212-161:~ # rpm -qa | grep alsa
alsa-oss-1.0.15-48.1
alsa-1.0.16-39.1
alsa-oss-32bit-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-plugins-pulse-1.0.16-57.1
alsa-plugins-1.0.16-57.1

75-92-212-161:~ # rpm -qa | grep pulse
pulseaudio-module-gconf-0.9.10-26.5
libpulse-browse0-0.9.10-26.5
pulseaudio-0.9.10-26.5
pulseaudio-esound-compat-0.9.10-26.5
gstreamer-0_10-pulse-0.9.5-54.1
libpulse0-32bit-0.9.10-26.5
pulseaudio-utils-0.9.10-26.5
pulseaudio-module-bluetooth-0.9.10-26.5
alsa-plugins-pulse-1.0.16-57.1
libpulse0-0.9.10-26.5
libpulse-mainloop-glib0-0.9.10-26.5
pulseaudio-module-x11-0.9.10-26.5
pulseaudio-module-lirc-0.9.10-26.5
libpulsecore4-0.9.10-26.5
pulseaudio-module-zeroconf-0.9.10-26.5

75-92-212-161:~ # rpm -q libasound2
libasound2-1.0.16-39.1

75-92-212-161:~ # uname -a
Linux 75-92-212-161.sea.clearwire-dns.net 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 x86_64 x86_64 x86_64 GNU/Linux

OK, … lets do some checks on that.

Thats a good test. When you see it say “Right Front” and “Right Left” you should be hearing a ladies voice say that.

OK, thanks, we may need to use that later.

For me to help, I need more information. To provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

**speaker-test -Dplug:front -c2 -l5 -twav

Thats a good test. When you see it say “Right Front” and “Right Left” you should be hearing a ladies voice say that.**

Yes, I do hear that!

However, I then went back to check my VideoLan DVD player application (which used to work!) and still…no sound!

I ran the wget program as instructed and uploaded the information.

Here’s the URL

tsalsa.txt - nopaste.com (beta)

Ok, thanks for running the script.

In this case I am suspicious that the problem is you have added videolan to your repositories, and then did a one-click-install which I believe will mix videolan packaged applications with packman packaged applications , resulting in some applications not working well. To investigate that, and give me an idea as to what you may have installed, you could type:

rpm -q vlc libffmpeg0 kaffeine libxine1 smplayer MPlayer amarok xine-ui libquicktime0 w32codec-all 

if you see a “pm” in the version numbering, it is likely a packman packaged application. If you do not see that, it is likely a Novell/SuSE-GmbH or videolan packaged application.

For your multimedia, where possible, I recommend you use only packman packaged applications.

A good way to do that is to setup your software package management with only repositories (ie file servers with applications) of OSS, NON-OSS, Update and Packman. Only those 4. Remove any others. In particular remove/disable. videolan. The ONLY videolan app that I recommend one install is libdvdcss2 (for video dvd playback).

Once you have your repositories setup with only those 4, you can go to yast > software > software management and replace the videolan vlc and videolan libffmpeg0 with the packman versions. Also remove xine-lib (from Novell/SuSE-GmbH) and replace ith with libxine1 (from packman). Also, smplayer, which is a good front end to MPlayer, is an excellent player to install.

Good luck.

rpm -q vlc libffmpeg0 kaffeine libxine1 smplayer MPlayer amarok xine-ui libquicktime0 w32codec-all

vlc-0.9.1-0.pm.2
libffmpeg0-0.4.9.13782-1.2
package kaffeine is not installed
libxine1-1.1.15-0.pm.1
smplayer-0.6.2-0.pm.1
MPlayer-1.0rc2-4.pm.8
amarok-1.4.10-100.pm.1
xine-ui-0.99.5cvs-20080426.pm.0
package libquicktime0 is not installed
w32codec-all-20071007-0.pm.1

So, it looks like all packman except for libffmpeg and libquicktim0 (I run GNOME so I don’t use Kaffeine).

A good way to do that is to setup your software package management with only repositories (ie file servers with applications) of OSS, NON-OSS, Update and Packman.

I have a high end nVidia card so I also have nVidia set up as a repository (the drivers never seem to be available in the basic repositories). I disabled everything but nVidia and the four repositories you recommend.

I then installed the pm versions of everything so now I see:

vlc-0.9.1-0.pm.2
libffmpeg0-0.4.9svn-20080906.pm.0
package kaffeine is not installed
libxine1-1.1.15-0.pm.1
smplayer-0.6.2-0.pm.1
MPlayer-1.0rc2-4.pm.8
amarok-1.4.10-100.pm.1
xine-ui-0.99.5cvs-20080426.pm.0
libquicktime0-1.0.3-100.pm.1
w32codec-all-20071007-0.pm.1

And VOILA! I have sound!

Truly, you are brilliant!

Excellent!

libffmpeg0 provides most of the codecs used by openSUSE media players. And I believe the videolan packaged libffmpeg0 puts those codecs in a different location than the packman packaged libffmpeg0 (a bit of speculation on my part) and the packman packaged players look in the location where the packman package puts the codecs.

I have noticed the packman packaged vlc (on my opensuse-10.3) is having a minor problem with vob and mpeg files. … This is a relatively new problem (I believe) and I need to track down when this started happening (so I can tell the packager).

I have one other problem which is that the sound volume is very low. I have tried setting the sliders in Yast and also the Pulse audio volume control and it does bring it up, but to something I was say was in the low range of listenable.

In Windows, nVidia uses a mixer applet called SoundMax. If you don’t use the equalizer to boost most of the ranges, the sound there is also low.

So, I’m thinking, that’s what I need to do in Suse…but is there a mixer that I can use with my sound chip? Which would let me boost each frequency range?

The only way I can help is to see your mixer output. Please can you run the following diagnostic script - with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

That script output has a very nicer mixer summary.

Looking back over the thread, I see you have run this script before:
amixer set ‘Master’,0 77% on
amixer set ‘PCM’,0 100% 100%
amixer set ‘Front’,0 79%,79% on
amixer set ‘Surround’,0 100%,100% on
amixer set ‘Center’,0 95% on
amixer set ‘LFE’,0 10% on
amixer set ‘Side’,0 90%,90% on
amixer set ‘IEC958’,0 100% off 100% off
amixer set ‘IEC958 Default PCM’,0 on
amixer set ‘IEC958 Playback Source’,0 Items: ‘PCM’ ‘ADC1’ ‘ADC2’ ‘ADC3’ Item0: ‘ADC3’ You could try digital audio (ie switch ON IEC958) … other than that, we need to search the alsa site for a possible update to the AD1988B. The alsa site is down now, so I can not search. I am about to go on vacation for just over a week, so I will likely not be providing any support between now and sometime around 23/24-September.

Good luck with your efforts

Thanks for pointing that out.

I moved the Front setting from 79 percent to 100 percent and now the volume can be made quite loud!

The only odd thing is that I thought I had set it to 100 a before(?)

Thanks again!