mcomix doesn't open

I have fresh install of Leap 15.4, and when I tried to install mcomix it will not run. I have messed with it a bit, and mcomix worked for me before, but after what appears to be a successful install, if I try to run it it fails to open. Here’s the errors when I tried to launch it from a command line:

**alexius@Volstagg**:**~**$ mcomix  
Traceback (most recent call last): 
  File "/usr/bin/mcomix", line 11, in <module> 
    load_entry_point('mcomix==2.0.2', 'console_scripts', 'mcomix')() 
  File "/usr/lib/python3.6/site-packages/mcomix-2.0.2-py3.6.egg/mcomix/run.py", line 124, in run 
    require_version('Gtk', '3.0') 
  File "/usr/lib64/python3.6/site-packages/gi/__init__.py", line 130, in require_version 
    (namespace, version)) 
ValueError: Namespace Gtk not available for version 3.0

It looks to me like it’s telling me that python or Gtk isn’t installed, but both are on my system. I feel like someone more experienced than me will be able to look at this and tell me ‘It’s saying XXXX is missing, install that’ but I haven’t been able to find the think that is missing. Can anyone point me in the right direction?

Is python3-gobject-Gdk installed?

I just double checked: Yes.

**alexius@Volstagg**:**~**$ sudo zypper install python3-gobject-Gdk  
Loading repository data... 
Reading installed packages... 
'python3-gobject-Gdk' is already installed. 
No update candidate for 'python3-gobject-Gdk-3.42.0-150400.1.48.x86_64'. The highest available version is already installed. 
Resolving package dependencies... 
Nothing to do.


Installed mcomix from multimedia:apps and working.

So please post:

zypper  lr -d

Have you used pip to install some python libs or Programms?

You need typelib-1_0-Gtk-3_0.

bor@10:~> zypper se --provides 'typelib(Gtk)=3.0'
Loading repository data...
Reading installed packages...


S | Name                | Type  | Version             | Arch   | Repository
--+---------------------+-------+---------------------+--------+----------------
i | typelib-1_0-Gtk-3_0 | pac-> | 3.24.31-150400.1.11 | x86_64 | Main Repository
bor@10:~> 

This did it!

Anyone know how to get a message to whoever lists the dependencies to include that?

What did it? This only provides information, it does not do anything to your system.

A bug report?

See: https://en.opensuse.org/openSUSE:Submitting_bug_reports
and: https://bugzilla.opensuse.org/index.cgi

Same username/password as here.

I should have been more clear. I did not have typelib-1_0-Gtk-3_0 installed, and once I installed it, mcomix opened normally.

Thank you, I will try to do that.

Nice you got it working :slight_smile: