mcelog fails: And ATI Graphics Issue after dual boot installation?

Yes, but don’t I need to update in order to see a desktop?

No
I thought you reached a desktop when you booted failsafe?

It might help others help you if when you get to the desktop you post the result of this from a terminal:
/sbin/lspci -nnk

Or is your wireless device a USB thingy?

I have to rush off out again.
Might be some time.

No I only got a desktop the first time I booted fail safe, now whenever I do fail safe I haven’t seen a desktop since. That is what puzzles me. I didn’t do anything or change anything that I know of that would make it not come up the second time.

Oh and when I log in during the text interface should I use the root account or my user (levi) account?

You user account: levi

Using root is NOT recommended and is not necessary

alright so I still get a text command in fail safe and the non fail safe with nomodeset… what should I do next? Do I need to get my computer access to an ethernet cable? Because I won’t be able to do that for a week or so we are in the process of wiring an ethernet cable through the wall.

Can I ask
Did you install with a DVD or CD? And did you check it like this:
http://dl.dropbox.com/u/10573557/11.4_DVD_Install/1_mediacheck.jpg

DVD and no I did not check that.

I deleted the partions I created to install opensuse and then put the DVD back in my computer, rebooted, and did the check installation media, it went through and set it was good and stuff and I went through and just installed opensuse on a smaller, 120gb partion. It installed perfectly then when it rebooted on its own I got the blue screen thing with it saying that like my graphics card doesn’t support the graphics interface for some configuration thing, it went through and installed or configured something in that blue screen, then the computer restarted and I got back to that text interface with mcelog failing just like before. Tried fail safe and in fail safe no where does it say it fails but it still remains in text interface…

OK
Interesting.
I’m kind of wishing someone who has or has used ATI would join this discussion, so I plan to edit the title a little.

But just to clarify:
You tried adding nomodest at the grub menu? And it doesn’t help
You tried failsafe but that still only gets a text login? (Though in the earlier install, failsafe did boot to the desktop Once?)

Lets see if any ATI junkies are drawn in.
I have some ideas, but they are complex and may be unnecessary

If you have a network connection in runlevel 3, just install atiupgrade from my repo and run it. As root:

zypper ar [noparse]http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_11.4/[/noparse] PTA
zypper refresh -r PTA
zypper in atiupgrade

If you don’t have a network connection, first get your netcard set up (tha’ts another problem), then run atiupgrade. I don’t know if cnetworkmanager would help (I never used it):

zypper info  cnetworkmanager
Loading repository data...
Reading installed packages...


Information for package cnetworkmanager:

Repository: openSUSE:Network:utilities
Name: cnetworkmanager
Version: 0.21.1-21.1
Arch: noarch
Vendor: obs://build.opensuse.org/network:utilities
Installed: No
Status: not installed
Installed Size: 149.0 KiB
Summary: **Command-line client for NetworkManager**
Description: 
Cnetworkmanager is a command-line client for NetworkManager, intended
to supplement and replace the GUI applets.

  • Don’t use failsafe! Boot in runlevel 3.

You have it right exactly.

Awesome thanks for giving me the stuff to type in for the graphics drivers (that is for the 6870 right?) :slight_smile: But one more problem, I’m still not clear on how I’m supposed to connect to my router wirelessly in the text interface. Is there a guide somewhere that can tell me how to get connected to my router?

I don’t set up openSUSE to use the networkmanager and don’t have wireless devices to test … but I hope soemone would write a howto on that topic. Many problems could be easily solved with a network connection in runlevel 3 (which btw means “Full multiuser with network”). The networkmanager doesn’t seem to provide any. To connect to your router issuing a dhcp request with the command dhclient might work … but you’ll have to set up the wireless nic with iwconfig first unless the networkmanager takes care of that. That’s why I wondered if cnetworkmanager (that is unfortunately not installed by default) would provide an easier solution. But as I already said, I don’t know.

Can you plug it to the Internet for the install. Need to know the net device in order to advise what to do to get wireless working. But you need to get graphics fist so find a friend and plug the machine to the net.

I will be able to in about a week or so, and are you pretty sure that once I have it connected with wired internet and I update it, it should fix the graphics problem? What about the mcelog?

Once you have Internet you can install the ATI/AMD video drivers via yast. Log in as root then run yast do the update then add the amd/ati repo then go to software management and add the ati/amd driver. Note since I use NVIDIA cards I’m not sure if you will find things under amd or ati now. Then quit yast and type reboot. This should get you the normal GUI desktop.

Need more info about your wirless to help there, You may try lspci to show a list of all the PCI devices. This should list the wireless. Note if it a USB device use lsusb

Since you got two different pieces of advice on how to install the ATI proprietary driver, I have to explain that the driver from the ATI repo you can install through YaST (or on the command with zypper) and the one you could install via atiupgrade are (most likely) NOT the same version of the driver. The one from the repo is usually not the latest one, which is normally not a problem as long as it supports your graphic card.
To install the ATI driver from repo with zypper, you can type the following in a terminal (or in console mode):

su -l
zypper ar [noparse]http://www2.ati.com/suse/11.4/[/noparse] ati
zypper refresh
zypper in x11-video-fglrxG02

Even if you install this version of the driver, you can run atiupgrade at a later point to install the latest version. It will cleanly* replace the version installed from the repo.