mcelog fails: And ATI Graphics Issue after dual boot installation?

I am totally new to the whole linux OS thing. I decided I wanted to dual boot opensuse along with my windows 7. I have a 1tb hard drive and I made a 200gb partion that I was going to use for opensuse. I then downloaded the install DVD and burned it to a disk. I booted from it just fine and went through the installer choosing the gnome desktop. When it set up the partions it automatically found my 200gb partion and I left it with the default settings, I got some error message saying I should keep it at like 128gb below or something, I ignored it. I then installed it with all the default stuff and at the end of the installation I got a blue screen that said like my graphics card is not supported or something and I had a text based installed that just went on its own. At the end my computer rebooted and then I got a black backgrund with white text poping up and it showed all these processes and all them said success or whatever in green text except one called “mcelog” failed and it gave me a log in still in the black background and white text then I logged in and it just stayed at that black background and white text. I don’t know what to do, I probably did the installation wrong or something, if I did how do I uninstall and start over? I have a quad core i5 2500k with an ati raedeon hd 6870 1gb graphics card. Please help explain to me what I have to do to successfully install this as a dual boot along side my current windows 7 installation.

I can help you thru
Do you have access to another computer at the same time?

Yes, I do.

So the install completed and it did a partial reboot?
Or have you done a hard shutdown / reboot?
Have you seen the grub boot menu yet?
Are you logged in now, as your chosen username?

It appears as if it completed and then that is when it went to the blue screen and seemed to do some sort of post installation setup/hardware configuration stuff is my guess. And then I logged into it successfully on the text interface. I then sat there confused as to what I’m supposed to do with just text typing, so I did a hard reboot, I got a screen that let me choose if I wanted to boot windows or opensuse, I choose opensuse and then the same thing happend. I dont know what the grub boot menu is to be honest.

The grub menu is the green screen menu where you choose to boot suse or windows

Please reboot and use the down arrow at that menu to select the failsafe option
Does that get you to a desktop of some kind?

I have to leave my computer shortly, so I’m adding info in advance.

If you don’t get a desktop, try adding ‘nomodest’ to the default suse boot
File:Nomodeset-example.jpg - openSUSE

Some reading:
SDB:Configuring graphics cards - openSUSE
openSUSE Graphic Card Practical Theory Guide for Users

I’ll be back shortly (30mins)

alright thanks for that i will try it now. Sorry I was away from my computer but now I will be here all night :stuck_out_tongue: I’m going too try it in fail safe then try the second thing you suggested.

I tried it in fail safe and it booted up to the desktop just fine.

First thing I would do is run
Yast > Software > Online Update

Now just install the ATI drivers
SDB:ATI drivers - openSUSE

See my sig for more guides

Once the ATI driver is installed you should be OK to boot the normal option.

Alright this is weird now. This time when I tried fail safe again it did the exact same thing as the regular boot, it stayed in the text interface and prompted a login in text and I logged in and still was stuck there. The only difference is I didn’t see the red text that says failed for mcelog. I tried typing in the “nomodeset” in the text box before booting the regular opensuse and then I still had the same red failed mcelog, just the screen was in a lower resolution for some reason. (maybe that has to do with the nomodeset)

At the login, sometimes if you login with your username and password
then type: startx
It might work

If not do this once logged in:

su -
<enter your root password when requested - it does not display as you type>

Now type:

zypper up
(this will update your system, so long as you have a wired ethernet connection)

I take it you didn’t already update or install ATI drivers?

Note startx no longer works in 11.4 with out changing some settings. Better to login as root and do init 5

I have not updated or installed the ATI drivers yet, I will try doing the startx method now. About the second option you said, you said I need a wired ethernet connection. Well, right now I’m using wireless internet. When the fail safe boot did work the first time I tried to launch the internet before shutting down the system and sure enough the internet didn’t work, I tried looking at the wireless connections but it showed nothing, I don’t think it even detected my wireless adapter.

Saying what wireless you have will help to get it to work.

Nevermind then I won’t try startx I guess.

How do I do that? I know my wireless internet name or whatever is just linksys and there is no password on it.

I guess my question now is how can I connect to my router in the text interface, if possible, so that I can get updates.

You mean now failsafe doesn’t get you to a desktop?