[Maybe urgent?] No sound in OpenSuSe 13.1 Xfce --> Fixed in OpenSuSe 13.2?


I didn’t have enough time to install 13.2 RC1 Xfce (I only tested the KDE version), so I couldn’t check it out by myself, but maybe someone else did and can report about that:

When I was using 13.1 Xfce I had the problem of having no sound output on my system. The first issue was (if I remember it correctly) that the Pulse audio server was not installed by default. But even installing it was only the first step to solve the problem, because the Pule config file (or maybe the whole directory where it is located) doesn’t have the right permissions it would need to have. So I modified the permissions and got sound working by doing so. However, after a reboot the permissions were wrong again, so no sound again. It could be a work-around to write a script running with root privileges during the start-up process which does that automatically, but that solution wouldn’t very appealing to many users.
Therefore my question: Has this issue been fixed in 13.2? If not, I would suggest to do so before releasing it… I think the only things neccessary for doing so would be 1) making Pulse be installed by default and 2) making it create the config file with correct permissions.

I would have liked continuing to use OpenSuSe Xfce (since its’ performance increase is incredible compared with the KDE edition and I don’t need the KDE features; OpenSuse KDE is a very good distro and great when it comes to productivity, still I wouldn’t advice anyone to use it on a netbook or on old hardware simply because it needs too much ressources), but because of this issue I stopped using it finally.
That’s why I thought I should post this and give the developers a chance to take a look on this before rolling out the release. I wouldn’t consider this being a minor issue.

Hmmm Did you add yourself to the audio group? That may correct permission problems

That might be a solution, too. I solved it by changing the permissions of the Pulse config file or the config directory.
But first of all there should be a sound server installed by default (when choosing Xfce as the desktop environment) and then the permissions should be automatically set in a way that it works, isn’t it?

Unfortunatly it’s a little late to correct this in 13.2, I discovered today that I had to install the pulseaudio components manually, as I then remembered I had to do in 13.1 too. I’ve never had to do anything about permissions and is not a member of the audio group it still works now in both distros. However in 13.2 I had to enable and start pulseaudio in yasts service manager to get it working. Other than that Xfce is a nice desktop.