Maximum number of X display failures reached

Hi everybody!
I tried ubuntu for a few weeks, but I couldn’t get the nvidia drivers to work, I tried everything.

So, I got sick of that, and went to download OpenSuse, which seems to be even nicer (youtube :P)

I downloaded the 11.1 liveCD (gnome) from here.
I nicley got the welcome screen, and the option screen (liveCD, check errors etc.). I chose LiveCD and it started booting, I got the splash screen with the loading bar, and after it completely loaded, the screen turns black with a lot of messages and at the end:

GdmLocalDisplayFactory: Maximum number of X display failures reached: Check X server log for errors.

Great, I hoped for better luck after Ubuntu…

My sys. specs:

Asus F3Sc 32bit
Intel CentrinoDuo
Nvidia GeForce 8400m G 128MB
3Gigs of RAM
Screen res. of 1280x800

Hope you guys can help me out…

By the way, Google didn’t help me this time…

Greets

Hi, I have the same problem. Do you have a solution meanwhile?

I see a potential solution at: GDM fails to load