Mass media storage (android) unable to detect on opensuse 12.2


I have myself the lenovo A1 tablet running on android ICS 4.1

unfortunately opensuse 12.2 is unable to detect the internal storage and sd card when I connect the USB to OS (opensuse 12.2)

it works fine on Windows 7

any idea how to fix this?

btw it’s not a rooted device recovery system is Android System recovery <3e>

anyone? must be to install some drivers… :\

On 2012-11-18 11:36, azharr wrote:
> anyone? must be to install some drivers… :\

I have no idea about those devices, but you should see something in the
log when you plug it in.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

Later Android changed to MTP (Media Transfer Protocol) I just bought a Lenovo A2109 with Android 4.0.4 on it and it will not load. I have tried three distros and followed several forum how-tos on how to fix it to no avail. The only thing that I have found for file transfer successfully, though it takes a while for large files, is to use filezilla and install SSHDroid on the device. I successfully transferred a 1.5G movie file but it took an hour over my network. If you go to Settings–>Storage–>USB computer connections, you can change to PTP. IT is supposed to work for computers with pour or no MTP Support. openSUSE reads the device but it only takes me to my picture folder and will not let me go any where else so I have not tried to transfer anything yet. I am still new to all the technical stuff on here but I hope this helps.


Not sure how many of the suggestions in this thread, not relating to an Android phone, may offer pointers.