Masquerade stopped working after upgrade do 15.3

After upgrading to 15.3, masquerade simply stopped working.

I can access the Opensuse machine from the internal network normally, but the machines in the internal network are unable do access the Internet or ping an external destination.
I´ve checked firewalld configuration (masquerade is active), tried to use the my old working SuSEfirewall2 script, used iptables directly, with no success.
/proc/sys/net/ipv4/ip_forward = 1, ipv6 is disabled

I’m running out of ideas.

What else could I check?

Can you show us your iptables script? Obfuscate any public IPs.

As I said, I’ve tried several types of previously working firewalls.

And I also tried the following basic commands after stopping firewalld service:

iptables -F
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables -A FORWARD -i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT

With only that I should be able to route the internal machines. shouldn’t I?

At least it used to work since I left using ipchains :smiley:

I really need to sleep.
The OBVIOUS problem was with dhcpd that dies after starting. Guess the machines in the internal network still was with old IP’s, but with no gateway info. I will check that later.
I’m getting old :slight_smile: